Step 4 in Joomla install HELP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Step 4 in Joomla install HELP

Postby sheaster2000 » 28. January 2011 22:09

after Entering all the correct info in step 4 for the Database and i click next this is what i am getting

"You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM CHARACTER SET `utf8`' at line 29 SQL=CREATE TABLE `jos_banner` ( `bid` int(11) NOT NULL auto_increment, `cid` int(11) NOT NULL default '0', `type` varchar(30) NOT NULL default 'banner', `name` varchar(255) NOT NULL default '', `alias` varchar(255) NOT NULL default '', `imptotal` int(11) NOT NULL default '0', `impmade` int(11) NOT NULL default '0', `clicks` int(11) NOT NULL default '0', `imageurl` varchar(100) NOT NULL default '', `clickurl` varchar(200) NOT NULL default '', `date` datetime default NULL, `showBanner` tinyint(1) NOT NULL default '0', `checked_out` tinyint(1) NOT NULL default '0', `checked_out_time` datetime NOT NULL default '0000-00-00 00:00:00', `editor` varchar(50) default NULL, `custombannercode` text, `catid` INTEGER UNSIGNED NOT NULL DEFAULT 0, `description` TEXT NOT NULL DEFAULT '', `sticky` TINYINT(1) UNSIGNED NOT NULL DEFAULT 0, `ordering` INTEGER NOT NULL DEFAULT 0, `publish_up` datetime NOT NULL default '0000-00-00 00:00:00', `publish_down` datetime NOT NULL default '0000-00-00 00:00:00', `tags` TEXT NOT NULL DEFAULT '', `params` TEXT NOT NULL DEFAULT '', PRIMARY KEY (`bid`), KEY `viewbanner` (`showBanner`), INDEX `idx_banner_catid`(`catid`) ) TYPE=MyISAM CHARACTER SET `utf8`"

i am clueless to what this means

HELP!!!!!!!!!!!!!
sheaster2000
 
Posts: 1
Joined: 28. January 2011 21:58

Re: Step 4 in Joomla install HELP

Postby Sharley » 28. January 2011 23:14

Please ask this Joomla installation issue in the Joomla forums.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Step 4 in Joomla install HELP

Postby Dai777 » 07. February 2011 13:15

TYPE=MyISAM CHARACTER SET `utf8`"
to
ENGINE=MyISAM CHARACTER SET `utf8`"
IN THE SQL FILE
Dai777
 
Posts: 12
Joined: 17. January 2011 16:37

Re: Step 4 in Joomla install HELP

Postby Rasciomon » 17. February 2011 20:41

The response:
Please ask this Joomla installation issue in the Joomla forums.

apparently does not sound like like an "apache friends" issue from your response.
I have the exact same error and do not understand why there should be a "compatibility issue" when you are creating the database from scratch on 2 different computers I have tried it on. Disabled anti-virus, etc.
Not a very friendly answer- but I will just work off my live hosting server (Bluehost) where it installs just just fine using simple scripts directed to a sub-directory. You would probably say a little more if you had a clue. So much for trying to work and learn XAMPP. They ARE much more "friendly" in the Joomla support forums.
They might even give you a link on where to go.
:arrow: http://help.joomla.org/ghop/feb2008/task048/joomla_15_quickstart.pdf
but it still does not work as explained with their instructions for XAMPP. Gee, maybe something changed in XAMPP...
So now I know where to go- it ain't here.
Apparently you might have a misnomer in your name.
~"everywhere is walking distance if you have the time"
Rasciomon
 
Posts: 2
Joined: 17. February 2011 17:10

Re: Step 4 in Joomla install HELP

Postby Rasciomon » 18. February 2011 00:28

Looking at errors I see this same error when stating xampp (Run this program only from your XAMPP root directory):
http://community.apachefriends.org/f/viewtopic.php?f=16&t=44320&p=172948&hilit=run+this+program+only+from+your+xampp+root#p172948
Except that I installed and am running it on Vista 32 bit and XP. I installed them both into c:\xampp from the installer package and turned off AVAST anti-virus and ran as administrator when installing. It would be nice to be able to test my backups locally and transfering to another host...
~"everywhere is walking distance if you have the time"
Rasciomon
 
Posts: 2
Joined: 17. February 2011 17:10


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 45 guests