I have a problem :(

Problems with the Windows version of XAMPP, questions, comments, and anything related.

I have a problem :(

Postby robertoleguizamo » 28. January 2011 04:42

I have an error loading the postgreSQL libraries I get the following PHP Startup: Unable to load dynamic library 'C: \ xampp \ php \ ext \ php_pgsql.dll' - you can not find the specified module, help please :(
robertoleguizamo
 
Posts: 4
Joined: 28. January 2011 04:29

Re: I have a problem :(

Postby Sharley » 28. January 2011 04:45

Which XAMPP version?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: I have a problem :(

Postby robertoleguizamo » 28. January 2011 04:46

1.7.4
robertoleguizamo
 
Posts: 4
Joined: 28. January 2011 04:29

Re: I have a problem :(

Postby Sharley » 28. January 2011 04:54

Here we go!

Open \xampp\php\php.ini file in your text editor and find this line
Code: Select all
;extension=php_pgsql.dll
Change it (uncomment) so it looks like this
Code: Select all
extension=php_pgsql.dll
Save the file and restart Apache.

Job done.

Good luck.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: I have a problem :(

Postby robertoleguizamo » 28. January 2011 05:12

still displays the same message when I start the apache server uncomment the line after :'(. not work. PHP Startup: Unable to load dynamic library 'C: \ xampp \ php \ ext \ php_pgsql.dll' - you can not find the specified module. my OS is windows xp service pack 3
robertoleguizamo
 
Posts: 4
Joined: 28. January 2011 04:29

Re: I have a problem :(

Postby Sharley » 28. January 2011 05:15

Please paste the line from your php.ini file here.

Clear your browsers cache (temporary Internet files).
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: I have a problem :(

Postby robertoleguizamo » 28. January 2011 06:01

umm in xampp 1.7.4 not work for me, but I went back to xammp 1.7.3 and it works
robertoleguizamo
 
Posts: 4
Joined: 28. January 2011 04:29

Re: I have a problem :(

Postby Sharley » 28. January 2011 06:50

robertoleguizamo wrote:umm in xampp 1.7.4 not work for me
Weird or what? :shock: ,
robertoleguizamo wrote:but I went back to xammp 1.7.3 and it works
Good move as I see many more staying with 1.7.3 or like you trying 1.7.4 then having to go back to 1.7.3 to get a working XAMPP version.

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Solution

Postby abeltran » 08. February 2011 19:01

I wrote LoadFile "E:/xampp/php/libpq.dll" in the httpd.conf of the Apache, and it work.
Good Luck my friend.
abeltran
 
Posts: 1
Joined: 08. February 2011 16:19

Re: I have a problem :(

Postby BertMul » 09. February 2011 20:43

You will find that many modules that were in the \xampp\php\ext\ folder of XAMPP 1.7.3 are no longer there in 1.7.4.
As a result, a lot of PHP functionality that used to be there in 1.7.3 is no longer available in 1.7.4.

Also the Microsoft .dll for accessing MSSQL is no longer there in 1.7.4.

And to add to all this, it seems that the XAMPP control panel is no longer able to start the FileZilla server without registering it as a service.
The XAMPP control panel in 1.7.3 can do that.

Should I continue?.....

My personal opinion? ... Stick with 1.7.3 if you can!
:cry:
BertMul
 
Posts: 5
Joined: 12. January 2010 11:39

Re: Solution

Postby mednetuser » 08. May 2011 13:13

abeltran wrote:I wrote LoadFile "E:/xampp/php/libpq.dll" in the httpd.conf of the Apache, and it work.
Good Luck my friend.



These Solution Works it's very useful just add the line to force apache daemon to load LIBGQ Library file Thank Abe :wink:
mednetuser
 
Posts: 1
Joined: 08. May 2011 13:10

Re: I have a problem :(

Postby faiz_ahmed » 04. April 2012 07:53

Re:Solution

I am using xampp 1.7.7 .I have fetched this problem too. I successfully solved this problem by following.

1. uncommented the ;extension=php_pgsql.dll
2.Copied 'LoadFile "C:/xampp/php/libpq.dll" in C:\xampp\apache\conf\httpd.conf

thanks..
faiz_ahmed
 
Posts: 1
Joined: 04. April 2012 07:44
Operating System: Windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 42 guests