Index.php works under localhost but not another one

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Index.php works under localhost but not another one

Postby elated » 27. January 2011 18:30

Index.php works under localhost virtual host but not under another virtual host (WAMP)?
I have two virtual hosts set up: http://localhost and http://edgeridge. the document root of my wamp server is c:/webs and the application I am running resides in c:/webs/myapp/public/. in myapp folder i have two files (index.php; which just runs the phpinfo() command, and the second is index.html which just has the text "Hello World")

The following works under the localhost virtual directory:
http://localhost/myapp/public/index.php
http://localhost/myapp/public/index.html

I have set up the document root of the virtual host for http://edgeridge to
c:/webs/myapp/public/

However, when i browse to http://edgeridge, http://edgeridge/index.html works but http://edgeridge/index.php does not work; i get the error 404 page not found code.

I have check the DirectoryIndex to make sure it includes .php for which it does. All settings seem to be set up correctly since it works under http://localhost/myapp/public/index.php.

Any help please, this has been bugging me for the past 3 days... help!!!
User avatar
elated
 
Posts: 2
Joined: 27. January 2011 18:27

Re: Index.php works under localhost but not another one

Postby JonB » 27. January 2011 18:45

Before I venture any advice - are you on XAMMP or WAMP as you intimated:
but not under another virtual host (WAMP)


:shock:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Index.php works under localhost but not another one

Postby elated » 27. January 2011 18:49

I am running under Windows XP, Apache 2.2 MySql and PHP 5


JonB wrote:Before I venture any advice - are you on XAMMP or WAMP as you intimated:
but not under another virtual host (WAMP)


:shock:
User avatar
elated
 
Posts: 2
Joined: 27. January 2011 18:27

Re: Index.php works under localhost but not another one

Postby JonB » 27. January 2011 21:54

Try to directly answer the question, you will get better results.

I am running under Windows XP, Apache 2.2 MySql and PHP 5


But not in the XAMPP package???

IF you are not running the XAMPP distribution, then this is not the right spot for your inquiry - reason? All these issues are functions of the server configuration and each distrinbution works differently (that's why there are variants in Open Source solutions like Apache and PHP). This forum is for supporting the XAMPP - Apache Friends distribution.

If you aren't on XAMPP. Your inquiry should go to a forum that is intended for standalone installations of Apache/PHP or general hosting/server/IT questions.

To wit:

http://bytes.com/topic/apache/
or
http://stackoverflow.com/
or
http://www.daniweb.com/

So IF you are running XAMPP, tell us what version/release, because THAT will make a difference too.

Good Luck
:)



ysfl
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 56 guests