Weird error. External access works only from other IP's

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Weird error. External access works only from other IP's

Postby Bruno-Philipe » 27. January 2011 00:06

Hello!
I am having a weird problem with a Xampp installation on my server, which is placed in my office. I can not access it from the external IP if I am in the same sub-net as it. But if I am on another sub-net (at this case, my home), it works perfectly!
May this have something to do with the server ISP?
Thanks for reading and I wait for an answer.
Bruno-Philipe
 
Posts: 2
Joined: 27. January 2011 00:00

Re: Weird error. External access works only from other IP's

Postby Sharley » 27. January 2011 00:36

You can't access using the WAN IP from within a LAN but you can access using the IP of the computer that XAMPP is installed on for example http://192.168.x.x or what ever IP has been assigned to the XAMPP host computer in the LAN.

The local loop back address 127.0.0.1 will only access XAMPP on the computer it is installed on.

From home you will be accessing via the internet using your ISP created (WAN) IP.

In version 1.7.3 of XAMPP the security settings for this behavior are in \xampp\apache\conf\extra\httpd-xampp.conf file under the heading New XAMPP security concept, <LocationMatch> and Allow from entries.

Best wishes and I hope this helps with understanding how it works.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Weird error. External access works only from other IP's

Postby Bruno-Philipe » 27. January 2011 00:55

My problem it's a little deeper. For some bizarre reason, the server is no way accessible from computers in the same network as it. If I use a computer from some other place, it works.
In both them I try to access with the exactly same IP address, but from the local network, it does not work.
I don't want to use the local IP because I use an domain name for my server, and I wanted to use it all the time.
I realized that that security enhancement on Xampp just works in the Xampp folder and in the Database.
Thanks for your attention
Bruno-Philipe
 
Posts: 2
Joined: 27. January 2011 00:00

Re: Weird error. External access works only from other IP's

Postby Sharley » 27. January 2011 01:16

Altrea wrote:You should find out if your company runs their own DNS-Server.
from this post with similar issues in the topic.
viewtopic.php?p=170798#p170798

Good luck.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Weird error. External access works only from other IP's

Postby JonB » 27. January 2011 05:51

Some routers do not support NAT loopback, check yours :shock:

That would mean using the resolvable external IP on a lcal loop.

Good luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests