mysql as service

Problems with the Windows version of XAMPP, questions, comments, and anything related.

mysql as service

Postby Jean1 » 26. January 2011 10:29

Hello,

I copied my whole working xampp map to a new pc.
Apache and Filezilla are succesfully running as services but mysql is not.
If I check Svc in the xampp panel and click ok, then Start, it starts, but I can't see the service in services.msc, and on the next reboot, I have to check Svc and Start in the xampp panel again.
If I run mysql_installservice.bat I can see the mysql service in services.msc but if I try to start it, it says 'could not start mysql as service. Error 1067'
So, I have mysql running but not as a service I guess.
This is xampp 1.7.0.

Thanks.
Jean1
 
Posts: 9
Joined: 26. January 2011 10:17

Re: mysql as service

Postby Sharley » 26. January 2011 10:40

Make sure everything is stopped and no ticks in any of the Svc check boxes in the XAMPP Control Panel and then run the \xampp\setup_xampp.bat file to have it set the paths to the new location including those in the my.ini file - if offered select option 1 to refresh the XAMPP installation.

This my.ini file in \xampp\mysql\bin folder looks like a shortcut to my but if you drag that my into your text editor you will see the paths in the configuration settings which you can check are correct for your new location.

The MySQL service can't be installed correctly if the paths are incorrect in my.ini file.

Once it is corrected then you will be able to tick the Svc box to install the Windows MySQL service and Start MySQL in the XAMPP Control Panel.

Good luck and best wishes.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: mysql as service

Postby Jean1 » 26. January 2011 11:24

Hey Sharles, thanks.
I already had run setup_xampp.bat and just tried again (after stopping everything) and again it says: sorry, nothing to do! Very polite script :)
Both my.ini and my.cnf have correct paths (it's all an exact copy of a previously good working setup on another machine).
Any other suggestions or some way to debug this?
Jean1
 
Posts: 9
Joined: 26. January 2011 10:17

Re: mysql as service

Postby Sharley » 26. January 2011 11:36

'Nothing to do' means the paths are fine.

Sorry, In 1.7.0 my is my.cnf not my.ini - you don't have a my.ini as well do you?

I have just tried to simulate what you have done and I can't get it to replicate your issue, sorry, it works every time no matter what PC or partition I move the xampp folder to - "weird or what". :shock:

Try a reboot and see if it helps.

You didn't have another installation of XAMPP or MySQL on the new PC did you?

Have a look in the \xampp\mysql\data\*.err file (usually the name of your PC the * refers to) - mostly gobbledygook but sometimes there is a clue.

Check the Windows Event Viewer/Applications for clues also.

Good luck.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: mysql as service

Postby Jean1 » 26. January 2011 12:21

Sharley wrote:Sorry, In 1.7.0 my is my.cnf not my.ini - you don't have a my.ini as well do you?


Yes I do have an \xampp\mysql\bin\my.ini file too

Try a reboot and see if it helps.


Done that several times already, I'm setting up this (new) machine.

You didn't have another installation of XAMPP or MySQL on the new PC did you?


Nope.

Have a look in the \xampp\mysql\data\*.err file (usually the name of your PC the * refers to) - mostly gobbledygook but sometimes there is a clue.


Yes, well, it reports the crash: 110126 10:24:51 - mysqld got exception 0xc0000005 ;
Can't find much usefull on it though.

Check the Windows Event Viewer/Applications for clues also.


Nothing much to see there.

If forgot to mention two things:
- I couldn't install the control panel as a service either, after some tries I gave up and just put a link to it in program files/startup, it does not run as a service but I don't care that much about the control panel not doing that.
- Few years ago I had about the same problem with apache as service. I just kept checking Svc and start on the panel and after a few weeks it went away and started working, talk about weird. :) I guess I will so again.

Hey Sharley thanks a bunch for your great help.
Ok, now back to Melbourne on tv. :)
Jean1
 
Posts: 9
Joined: 26. January 2011 10:17

Re: mysql as service

Postby Sharley » 26. January 2011 12:26

Try renaming the my.ini file as only the my.cnf is used but if there is also a my.ini file then MySQL and Windows may get confused and chuck a wobbly. :)

This new PC what OS is it?

You would have to be logged in as an administrator in newer versions of Windows like Vista and Win7 to be able to configure services and if you have UAC then you may have to circumvent this or disable it.

Best wishes Jean and happy OZ day.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: mysql as service

Postby Jean1 » 26. January 2011 13:02

Winxp sp3.

No it's not about OZ day, I live in Netherlands, it's the australian open. :)

Again as usual through sheer stubbornness I found a solution somewhere: http://www.wampserver.com/phorum/read.p ... iew,page=2
See post from Hbk.

I found my solution for this. After trying all of the above it still would not work, but after going into services.msc (start-->run-->services.msc) I was able to get the mysql service working.
Just click the "Log On" tab on the mysql service's properties and check "Allow service to interact with the desktop." I hope this helps others.
Jean1
 
Posts: 9
Joined: 26. January 2011 10:17


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 29 guests