Can't run Apache?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't run Apache?

Postby HellenaMaezono » 24. January 2011 21:19

Hello, I'm writing here because I have a very big problem with XAMPP lite... :oops:
I've installed it, and I've opened the Control Panel... but when I click on "start" near to Apache, it says "running" but then it immediately stops, showing again the "start" button.
Yesterday everything worked, unless for the code I've uploaded through the Apache Admin Panel, which didn't redirect me to the XAMPP control panel when I typed my no-IP address. Probably something was wrong...
Anyway, can you help me starting Apache? I've read the FAQs but nothing helped me. I've checked the ports, and some are taken by a process that I can't stop... :shock:
Well, let me know, thanks for your help...
HellenaMaezono
 
Posts: 4
Joined: 24. January 2011 20:31

Re: Can't run Apache?

Postby Sharley » 25. January 2011 00:07

HellenaMaezono wrote:...I've checked the ports, and some are taken by a process that I can't stop...
When you did the port check what process was using port 80 and port 443 ?

If you tell me the process then I may be able to help you stop the process.

All ports XAMPP uses must show as being free for Apache to run.


BTW, any particular reason to use XAMPPLite version as the full version is far superior and contains all the bells and whistles. :)

Best wishes.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Can't run Apache?

Postby HellenaMaezono » 25. January 2011 11:12

Sharley wrote:When you did the port check what process was using port 80 and port 443 ?

Thanks for replying, the process is named inetinfo.exe, it's in C:\WINDOWS\system32\inetsrv.
HellenaMaezono
 
Posts: 4
Joined: 24. January 2011 20:31

Re: Can't run Apache?

Postby Sharley » 25. January 2011 11:22

This service belongs to IIS (Internet Information Services) or as it now known World Wide Publishing.

Click on the link in this post:
viewtopic.php?p=169028#p169028

Good luck and let me know please if this is the solution for you.

Good luck and best wishes.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Can't run Apache?

Postby HellenaMaezono » 25. January 2011 11:49

Fine! The service has been disabled and deactivated... but, what was it for? :?
HellenaMaezono
 
Posts: 4
Joined: 24. January 2011 20:31

Re: Can't run Apache?

Postby Sharley » 25. January 2011 11:55

It is Microsoft's Windows Web server offering that they turn on by default just to cause people like you, who don't want to use it, a lot of hassle to disable it - just look at all the different names it goes under, just to make life even more difficult.

Apache, the real web server, must have port 80 and 443 exclusively and IIS sits annoyingly on those ports trying to look pretty. :D

Best wishes and good luck with XAMPP.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Can't run Apache?

Postby HellenaMaezono » 25. January 2011 13:09

Thank you, but there's still something wrong :cry:
I'm following a tutorial for setting up the server, and it says to edit the C:\xampplite\apache\conf\extra\httpd-xxamp.conf file. I've edited is as the tutorial did, and then it says "You should then be able to type in your no-IP address into your browser and be directed to the xampp control panel."
But, unfortunately, I'm not directed there. What's wrong? :(
HellenaMaezono
 
Posts: 4
Joined: 24. January 2011 20:31

Re: Can't run Apache?

Postby Sharley » 25. January 2011 13:31

You should not have to edit any conf files to get XAMPP up and running and doing it wrong could open a security hole that you may regret.

You must not be able to access any XAMPP files and folders from the Internet only your own web site files and folders, so the tutorial is opening a security hole which is very wrong indeed.

So please return your httpd-xampp.conf file back to the default New XAMPP security concept settings before proceeding.

With regard to your tutorial I have no idea what that is as you failed to give details or provide a link to it.



First, make sure that your installation works by Starting Apache and MySQL in the XAMPP Control Panel making sure they both show a green running indication then type in your browser:
http://localhost/xampp/

You should see the Language setting page and then the XAMPP Welcome Demo page if your installation is working fine.

Now delete the index.php and the index.html file already in the htdocs folder and replace it with your own web site index file.

When the Apache server is running and you have put your web site files and folders in the htdocs folder then when you type in your no-ip address Apache should find the index file of your web site.

Good luck.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: JJ_Tagy and 40 guests