HOW TO GET BACK A SITE CREATE WITH JOOMLA! W/XAMPP PROBLEMS?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

HOW TO GET BACK A SITE CREATE WITH JOOMLA! W/XAMPP PROBLEMS?

Postby lucbrasil » 23. January 2011 05:45

I was building a site with Joomla! 1.5.18 on localhost on my own computer, when it was impossibile to run “Apache” with XAMPPLITE that I have installed.
I made a copy of all the complete folder “xampplite” and also one more copy of the folder “htdocs”.
I was not able to make a copy of the database because XAMPPLITE didn't work and I was not able to enter http://localhost/phpmyadmin/
Then I deleted XAMPPLITE and I installed XAMPP 1.7.3, which runs correctly (Apache and MySql).
I copied in the "new" folder "htdocs" in XAMPP 1.7.3 the folder with the site that I was building, but – as I thought – nothing happened.
What I must do? How can I solve this problem? Where can I find the database of the site I was building?
It is possibile to get back all the articles I wrote?
I don't know if I must create in "htdocs" of XAMPP 1.7.3 a new folder with Joomla! 1.5.22 version and then to copy one by one all the files of the site which were located in the "old" folder "htdocs" of "xampplite", putting them in the related folders of the new installation.
Which is the easiest solution? Thanks.
lucbrasil
 
Posts: 3
Joined: 22. January 2011 03:28

Re: HOW TO GET BACK A SITE CREATE WITH JOOMLA! W/XAMPP PROBL

Postby xfsgpr » 23. January 2011 06:43

The joomla database files are located at [in Windows XP]:

<C:\Documents and Settings\All Users\Application Data\MySQL\MySQL Server 5.5\data>

The data folder will contain the name of your database you have created to store joomla files.

I hope this gives you the idea how to locate the files in Vista or Windows 7.
xfsgpr
 
Posts: 27
Joined: 20. August 2009 21:45

Re: HOW TO GET BACK A SITE CREATE WITH JOOMLA! W/XAMPP PROBL

Postby Sharley » 23. January 2011 06:46

You should not have copied the whole of the htdocs folder only the Joomla folder from the htdocs of xlite to the htdocs folder of 1.7.3 and of course any other files that you had installed in the xlite htdocs folder but not the xampp folder\files as I said in your other topic when uninstalling xampp.

The joomla database is stored under xampplite\mysql\data and the folder would be named joomla or similar.
Try and copy that whole folder over to the 1.7.3 version and put it in \xampp\mysql\data folder and see if it works.

Restart the MySQL server first.


BTW, you can delete your double post by clicking on the X in your post in your other topic and we will proceed in this topic with this issue - no need to double post in these forums as only one will be answered.

Best wishes.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 61 guests