XAMPP & Win 7 64 Apache not working - SOLVED

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP & Win 7 64 Apache not working - SOLVED

Postby Radyation » 13. January 2011 20:04

First - to moderators and public.
May be this topic already exists, however i couldn't find it. Accept my apologies for repeating, flooding, or whatever you call it.

Second - to them girls, and the public of course.
I am an absolute newbie and do not pretend to have whatsoever sophisticated knowledge. Simply user.
While following some tutorial I downloaded and installed XAMMP 1.7.3 on Win7 64 running machine. After a while I realized that Apache was not running. Pressed the start button, program not responding for a while, and finally nothing. Tried few times - the same story. Then I thought there must be a solution in this forum. And I searched. All I found after 2 hours were thousands of crying girls' complaints with the same or similar problems but not a single solution. I don't believe that all of you girls left your problems unsolved, or rolled back to XP, or bought new 32 version of 7, or whatever...
You spent hours wandering around, complaining and crying for help, and you couldn't find 2 minutes for posting a solution? Or even worse, 2 seconds for posting a link?

Third - The solution - to anyone and everyone, including crying girls.

http://www.sevenforums.com/software/668 ... start.html

...and for just in case it get lost from there some copy/paste:

"I've installed XAMPP and when i try to start Apache from the Control Panel, it sometimes starts, but then a few seconds later it stops, but sometimes nothing happens when i press start. Please help me, and i am a newbie to XAMPP so please explain it simple."
"u can not use it coz it use 80 port in the machin by the way iis also use 80 port in the windows 7 that is why xamp and wamp not work in the windows 7 sometime ,
e so u have to change the iis port in windows 7

How to do this?
#1. In Start menu Search option, type: IIS and click Internet Information Services Manager or simply do a run command: inetmgr .
#2. Under Connections, You’ll see your PC name click on it to expand the list. Now you can see “Sites” click on it to expand.
#3. Under Sites you can see Default Web Site, right click on it and Select EDIT BINDINGS.
#4. Edit HTTP binding port from 80 to 81.
#5. Open your browser and type: //localhost:81/yoursite. You should be able to access your local sites without any problems.

if not iis in search function

#1. In Start menu Search option, type: turn windows features on or off
#2 and tik the internet information services and ok

So, this was my relief.


P.S. Any resemblance to persons living or dead is intentional and should be plainly apparent to them and those who know them.
Posts: 1
Joined: 13. January 2011 19:12

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 52 guests