Trouble starting apache

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Trouble starting apache

Postby shelby_polo » 09. January 2011 22:05

I recently downloaded XAMPP and I'm trying to get apache started, but there seems to be a problem.

When I start XAMPP control panel and click start next to apache the only progress I get is "Busy... Apache started" and it doesn't ever get any further (the start button doesn't change to stop), and http://localhost/ will not work.

I am using Windows 7
Turned off/uninstalled IIS 7
Quit Skype and unchecked the use port 80 box
Turned off any firewalls
Uninstalled any old versions of PHP

I can't think of or find many more solutions; any ideas?

Edit: apache error log

(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
shelby_polo
 
Posts: 5
Joined: 09. January 2011 21:53

Re: Trouble starting apache

Postby Sharley » 10. January 2011 00:08

Please run \xampp\xampp-portcheck.exe to find out which app is using the ports Apache needs exclusively.

Usual culprits are Skype and IIS (Micro$oft's web server), but there could be other apps involved also.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Trouble starting apache

Postby shelby_polo » 10. January 2011 00:28

Here is what I get after running xampp-port.exe:
Image

I'm not entirely sure what is means though :oops:
shelby_polo
 
Posts: 5
Joined: 09. January 2011 21:53

Re: Trouble starting apache

Postby Sharley » 10. January 2011 00:41

Open the XAMPP Control Panel and remove the tick in the SVC box, answer the questions positively and then see if you can start Apache.

Often a reboot will fix this issue but not always and the above may do the trick.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Trouble starting apache

Postby shelby_polo » 10. January 2011 01:04

Sharley wrote:Open the XAMPP Control Panel and remove the tick in the SVC box, answer the questions positively and then see if you can start Apache.

Often a reboot will fix this issue but not always and the above may do the trick.

I never tried with the svc box checked, should I try with it checked? I also rebooted and am atill having the same problem.
shelby_polo
 
Posts: 5
Joined: 09. January 2011 21:53

Re: Trouble starting apache

Postby Sharley » 10. January 2011 01:17

No leave the Svc check box unchecked as it seems you have another Windows service using port 80.

Take a read through these Advanced Search Results and see if any of the solutions helps your case.


Could be http.sys or some other service that uses port 80.

You say you disabled IIS7 but it goes by the name of World Wide Publishing in Win 7.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Trouble starting apache

Postby shelby_polo » 10. January 2011 01:45

Sharley wrote:You say you disabled IIS7 but it goes by the name of World Wide Publishing in Win 7.

Is there an easy way to find out if I have IIS7 and World Wide Publishing off/uninstalled?

If I go to "Turn windows features on/off", then open 'Internet Information Services' I have Web Management Tools unchecked, which I'm under the impression that would turn off IIS7? World Wide Web Services and FTP Sever are both checked.
shelby_polo
 
Posts: 5
Joined: 09. January 2011 21:53

Re: Trouble starting apache

Postby Sharley » 10. January 2011 01:52

See if the link in this posts helps:
viewtopic.php?p=169028#p169028
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Trouble starting apache

Postby shelby_polo » 10. January 2011 02:06

Works now :D Thank you very much for your help!

I ending up doing this:
"stop and disable the www service
type services.msc from the run command prompt > scroll down to World Wide Publishing service.
or go to control panel > Administrative Tools > Services.msc > World Wide Publishing service."
shelby_polo
 
Posts: 5
Joined: 09. January 2011 21:53

Re: Trouble starting apache

Postby Sharley » 10. January 2011 02:11

You can also get to the Windows Services by clicking on the SCM button in the XAMPP Control Panel.

Good luck and best wishes.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 31 guests