Problem with XAMPP running on Windows Server 2003

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problem with XAMPP running on Windows Server 2003

Postby LintechMotion » 05. January 2011 22:23

I just installed XAMPP on a Windows 2003 Server Standard edition with Service Pack 2 - everything installed fine - when I go to the XAMPP Control Panel Application - and try to Start the Apache service - in the white box it says "Apache service Started" - but I can not access the Admin for Apache - is this normal ?? When I insatlled the XAMPP on a windows XP stand Alone machine I was able to access this
LintechMotion
 
Posts: 2
Joined: 05. January 2011 22:18

Re: Problem with XAMPP running on Windows Server 2003

Postby Sharley » 06. January 2011 03:57

Does the \xampp\apache\logs\error.log file hold any clues?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Problem with XAMPP running on Windows Server 2003

Postby LintechMotion » 06. January 2011 22:45

Here is the error log info:

(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

How do I fix this ??
LintechMotion
 
Posts: 2
Joined: 05. January 2011 22:18

Re: Problem with XAMPP running on Windows Server 2003

Postby Sharley » 06. January 2011 23:48

Run \xampp\xampp-portcheck.exe to find out what is using the ports that XAMPP needs exclusively.

Often it is down to Skype and can be corrected by configuring Skype to use ports other than 80 and 443.

The other culprit and more the likely one in a Windows 2003 Server is IIS (Internet Information Services) which can be disabled in Windows Add/Remove Windows Components or similar location.

You can't run more than one application server on the same port and Apache uses ports 80 and 443 exclusively.

BTW, in future and for faster responses, you could use the XAMPP For Windows English forum:
viewforum.php?f=16

Good luck and best wishes.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Problem with XAMPP running on Windows Server 2003

Postby ignaciogutierrez » 02. November 2012 01:33

You may be required to install the Microsoft Visual C++ 2008 Redistributable.
Download from:
http://www.microsoft.com/en-us/download/details.aspx?id=29
http://www.microsoft.com/en-us/download/details.aspx?id=15336

Ignacio Gutierrez
SAIT Software Administrativo
ignaciogutierrez
 
Posts: 1
Joined: 02. November 2012 01:31
XAMPP Version: 5.5.19
Operating System: win2003


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 64 guests