1.67 -> 1.73 upgrade php question

Problems with the Windows version of XAMPP, questions, comments, and anything related.

1.67 -> 1.73 upgrade php question

Postby nvisioncurtis » 05. January 2011 04:34

Hi All,

I think this is a PHP upgrade issue but I am stumped just the same.

I reinstalled the latest 1.73 xampp for window recently when my computer was taken down by a nasty virus. I was using v1.67

Question/Problem. I seem to be having issues including certain files and get
Code: Select all
Warning: Cannot modify header information - headers already sent .... 


This is not an issue of a space before <?php> and its the same code that worked in previous version...

I think this may be due to some older php classes but why am I not getting a syntax error?

Thanks for any insight
nvisioncurtis
 
Posts: 7
Joined: 05. January 2011 04:17

Re: 1.67 -> 1.73 upgrade php question

Postby Altrea » 05. January 2011 05:11

And there is no output before that Warning?
Please take a look at the sourcecode view of your Browser of that page.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: 1.67 -> 1.73 upgrade php question

Postby nvisioncurtis » 05. January 2011 16:02

For now I have downgraded back to 1.63. And curiously it all works.

I suspect that its the inclusion of my custom mysql wrapper class. Its old and I use it everywhere. Not sure why its not throwing an error message that I can see but when I comment it out my problem goes away. Must be a mysql or php class syntax that is not compatible with the upgrade.

Just my luck.
nvisioncurtis
 
Posts: 7
Joined: 05. January 2011 04:17


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests