Can't view my localhost

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't view my localhost

Postby meytal » 02. January 2011 22:01

I think i tried everything, but i cant see my localhost in the browser. I am going nutts!
I even installed Ubuntu in VB, but it is too much of a hassle. I rather use xampp.
This is the message i get in the browser:

This webpage is not available.

The webpage at http://localhost/xampp might be temporarily down or it may have moved permanently to a new web address.

More information on this error
Below is the original error message

Error 101 (net::ERR_CONNECTION_RESET): Unknown error.


HELP!???
meytal
 
Posts: 7
Joined: 02. January 2011 21:59

Re: Can't view my localhost

Postby Sharley » 02. January 2011 23:31

See if there are any clues in the xampp\apache\logs\error.log file at about the date and time you try and access http://localhost in your browser.

Also clear your browser's cache from time to time when trying out localhost addresses.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Can't view my localhost

Postby meytal » 04. January 2011 19:48

This the errors i get in the log:


(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
httpd.exe: Syntax error on line 35 of C:/xampp/apache/conf/httpd.conf: ServerRoot must be a valid directory
httpd.exe: Syntax error on line 35 of C:/xampp/apache/conf/httpd.conf: ServerRoot must be a valid directory
httpd.exe: Syntax error on line 35 of C:/xampp/apache/conf/httpd.conf: ServerRoot must be a valid directory
httpd.exe: Syntax error on line 35 of C:/xampp/apache/conf/httpd.conf: ServerRoot must be a valid directory
httpd.exe: Syntax error on line 35 of C:/xampp/apache/conf/httpd.conf: ServerRoot must be a valid directory
httpd.exe: Syntax error on line 35 of C:/xampp/apache/conf/httpd.conf: ServerRoot must be a valid directory
httpd.exe: Syntax error on line 35 of C:/xampp/apache/conf/httpd.conf: ServerRoot must be a valid directory
httpd.exe: Syntax error on line 35 of C:/xampp/apache/conf/httpd.conf: ServerRoot must be a valid directory
httpd.exe: Syntax error on line 35 of C:/xampp/apache/conf/httpd.conf: ServerRoot must be a valid directory
meytal
 
Posts: 7
Joined: 02. January 2011 21:59

Re: Can't view my localhost

Postby WilliL » 04. January 2011 19:56

meytal wrote:This the errors i get in the log:
httpd.exe: Syntax error on line 35 of C:/xampp/apache/conf/httpd.conf: ServerRoot must be a valid directory

and whats in line 35 of httpd.conf (and in line 34)?
There seems to be the error. (may be mistyping on change)
Willi
WilliL
 
Posts: 661
Joined: 08. January 2010 10:54
Operating System: Win7Home Prem 64 SP1

Re: Can't view my localhost

Postby meytal » 04. January 2011 19:59

# Do not add a slash at the end of the directory path. If you point
# ServerRoot at a non-local disk, be sure to point the LockFile directive
# at a local disk. If you wish to share the same ServerRoot for multiple
# httpd daemons, you will need to change at least LockFile and PidFile.
#
ServerRoot "/xampp/apache"
meytal
 
Posts: 7
Joined: 02. January 2011 21:59

Re: Can't view my localhost

Postby meytal » 04. January 2011 20:06

in my xampp control panel. i see that my mysql is "running", but apache is not.
i click on "start" next to apache and i get the following message in the log:
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

meytal
 
Posts: 7
Joined: 02. January 2011 21:59

Re: Can't view my localhost

Postby meytal » 04. January 2011 20:11

update:

i changed port from http.conf Listen to 8080 and ssl.conf to 4430 and apache and mysql are running.
The only thing is, in order to see anything, i have to put this in my urkl:
http://localhost:8080

can't i change the url in the host file though without the 8080 in it?

thanks
meytal
 
Posts: 7
Joined: 02. January 2011 21:59

Re: Can't view my localhost

Postby WilliL » 04. January 2011 20:13

try
Code: Select all
 ServerRoot "C:/xampp/apache"
Willi
WilliL
 
Posts: 661
Joined: 08. January 2010 10:54
Operating System: Win7Home Prem 64 SP1

Re: Can't view my localhost

Postby WilliL » 04. January 2011 20:19

Code: Select all
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down

perhaps another program like skype, IIS is listening on port 80
Willi
WilliL
 
Posts: 661
Joined: 08. January 2010 10:54
Operating System: Win7Home Prem 64 SP1

Re: Can't view my localhost

Postby meytal » 04. January 2011 20:22

no other way around skype?
meytal
 
Posts: 7
Joined: 02. January 2011 21:59

Re: Can't view my localhost

Postby WilliL » 04. January 2011 20:32

do you mean that? skype can work without using standard http port
Willi
WilliL
 
Posts: 661
Joined: 08. January 2010 10:54
Operating System: Win7Home Prem 64 SP1

Re: Can't view my localhost

Postby meytal » 04. January 2011 20:33

i mean must i change my ports?
cant we change something with skype instead?
meytal
 
Posts: 7
Joined: 02. January 2011 21:59

Re: Can't view my localhost

Postby Altrea » 04. January 2011 20:58

Skype has an option to not use Ports 80 and 443.
Just search in their settings.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Can't view my localhost

Postby Sharley » 05. January 2011 01:12

meytal wrote:ServerRoot "/xampp/apache"
Did you install XAMPP on a USB drive or some other portable device that does not require the use of drive letters?

Did you run setup_xampp.bat file after installing XAMPP?
You can run it anytime to help if you get path errors, for example if you move the XAMPP installation to another location or you get the Syntax error that you posted above.

To help with the troubleshooting of collision errors on port 80, did you run xampp-portcheck.exe to see what program is occupying the ports that XAMPP requires exclusively?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 52 guests