My Apache not Starting. Please help ?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

My Apache not Starting. Please help ?

Postby TomTom2010 » 21. December 2010 06:42

Hi, on my Xampp Control Panel, my Apache is not Starting or running. Im useing a Windows VPS 2008, to Run my XAMPP. So can anyone help me ?

Image
TomTom2010
 
Posts: 3
Joined: 21. December 2010 06:38

Re: My Apache not Starting. Please help ?

Postby Altrea » 21. December 2010 06:54

- read the apache error.log file
- check if your ports (80, 443) are free
- execute the control panel as administrator (rightclick context menu option) if needed
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: My Apache not Starting. Please help ?

Postby TomTom2010 » 21. December 2010 06:59

If i give you Windows VPS access, my VPS infomation. Can you FIX it ?
TomTom2010
 
Posts: 3
Joined: 21. December 2010 06:38

Re: My Apache not Starting. Please help ?

Postby Altrea » 21. December 2010 07:01

no.
you will not learn anything from this problem if someone else solves it for you.
Last edited by Altrea on 21. December 2010 07:38, edited 1 time in total.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: My Apache not Starting. Please help ?

Postby TomTom2010 » 21. December 2010 07:07

PLease come on guys, Can anyone help me ?
TomTom2010
 
Posts: 3
Joined: 21. December 2010 06:38

Re: My Apache not Starting. Please help ?

Postby xfsgpr » 21. December 2010 07:50

Are you running IIS by default? If so then you need to shut it down or change the Apache's port number to 8080 because both IIS and Apache use port 80 by default. I normally run IIS as my main webserver but recently my clients wanted to start using OpenSource so I have installed apache on my test machines.

hth
xfsgpr
 
Posts: 27
Joined: 20. August 2009 21:45

Re: My Apache not Starting. Please help ?

Postby markg99051 » 22. December 2010 05:03

I am having this exact same problem. I loaded XAMPP and the first night it worked fine. The next day, whenever I try to start Apache it says "Apache Started" and the message "WARNING terminating worker thread 0" and it never starts. MySql starts fine. I checked the ports, it says they are all free including Ports 80 and 81. I've exited my security software. Any ideas? Oh yeah, I am also NOT running IIS.
markg99051
 
Posts: 2
Joined: 22. December 2010 04:54

Re: My Apache not Starting. Please help ?

Postby markg99051 » 22. December 2010 05:16

I found it! Another thread suggested looking in the error log. I had a syntax error in my httpd-vhosts.conf file.

From the other thread:
When ever you have problems with the Apache server in XAMPP, first check the error log file, which is located in a default installation here:
C:\xampp\apache\logs\error.log

Drag the file into your text editor to view the contents or associate the file extension .log with your text editor (Always open with Notepad - for example).

Look for entries at the date and time you last tried to start Apache.


Thanks. This was great!
markg99051
 
Posts: 2
Joined: 22. December 2010 04:54

Re: My Apache not Starting. Please help ?

Postby jstein » 22. December 2010 15:08

I've just installed the app also and my Apache isn't starting. it seems. I did a port-check using the link in the app and I'm seeing that it seems that Skype is using port 80 and 443. 81 seems to be free though. How can I change the port...even to 8080 as someone suggested.

P.S. Please write in uber newbie language. I'm pretty much clueless!

Thanks!
J
jstein
 
Posts: 1
Joined: 22. December 2010 15:04

Re: My Apache not Starting. Please help ?

Postby Altrea » 22. December 2010 16:24

Why don't you just uncheck the Skype option which permitted Skype to use those ports?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: My Apache not Starting. Please help ?

Postby djburner » 23. December 2010 17:24

Hi everyone. Same problem here: In the XAMPP control panel when I hit "start" Apache runs for a second and then nothing, the green running status bar never shows. MySql and the others run smooth.

I’m using XP SP2. I've worked with XAMPP in the same computer before so I've erased old versions. Then I've installed XAMPP (win32-1.7.3.exe) at C: as usual.

I don’t have IIS
I don't have Skype installed.
Ports 80 -81 - 443 are free
Apache has all the exceptions in my Firewall.

I tried with the apache_start.bat directly but nothing happens.

The apache error log shows:

Can't open nul: No such file or directory - perl_parse: No such file or directory

So, what could it be the problem?
Thank for any help in advanced.
djburner
 
Posts: 3
Joined: 23. December 2010 17:05

Re: My Apache not Starting. Please help ?

Postby Altrea » 23. December 2010 17:29

please start your setup_xampp.bat script and disable mod_perl and try again to start your Apache.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: My Apache not Starting. Please help ?

Postby djburner » 23. December 2010 17:53

The “setup_xampp.bat” throws the cmd. How do I disable mod_perl there? Or do I must to open the bat as txt and then change something inside?.

Thanks for your time.
djburner
 
Posts: 3
Joined: 23. December 2010 17:05

Re: My Apache not Starting. Please help ?

Postby Altrea » 23. December 2010 18:04

no, you must execute the setup_xampp.bat file.

It should open in the commandline and show a menu of 7 configurations (one of them about mod_perl - option 6):
Image
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: My Apache not Starting. Please help ?

Postby djburner » 23. December 2010 19:35

It's weird but I dont have any of those 6 options, these is what I get with setup_xampp.bat:

Image

what do I must to enter to get these menu?
thanks.
djburner
 
Posts: 3
Joined: 23. December 2010 17:05


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 47 guests