Apache won't start

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache won't start

Postby tsims25 » 12. December 2010 20:59


I've installed Xammp to run Wordpress and everything was working fine up until today. The Apache server won't even start and I cannot run localhost to see the wordpress site. Any suggestions?
Posts: 1
Joined: 12. December 2010 20:55

Re: Apache won't start

Postby Sharley » 13. December 2010 05:06

tsims25 wrote:The Apache server won't even start...Any suggestions?
When ever you have problems with the Apache server in XAMPP, first check the error log file, which is located in a default installation here:

Drag the file into your text editor to view the contents or associate the file extension .log with your text editor (Always open with Notepad - for example).

Look for entries at the date and time you last tried to start Apache.
User avatar
AF Moderator
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Apache won't start

Postby midicreation » 16. December 2010 19:47

I had exactly the same problem and have found a solution. This may or may not help everyone else with this problem but I hope it helps at least some of you.

If you also have Skype installed, read on, otherwise this doesn't apply to you.

Apparently the updated version of Skype (and maybe the older versions too) allows you to use port 80 and 443 as alternate ports for incoming connections. If this is enabled, it locks port 80 since you can only bind one program to a particular port.

Open up skype - go to 'tools' then 'options' - click on the 'Advanced' button on the bottom left - click on 'Connection' under 'Advanced' and un-tick the tickbox by 'Use port 80 and 443 as alternatives for incoming connections'.

This solved the problem for me.
Posts: 1
Joined: 16. December 2010 19:35

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 43 guests