Making Server Public to Internet?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Making Server Public to Internet?

Postby nblufire12 » 09. December 2010 23:03

Hello all,

my IP is 76.21.245.7 and I am trying to view it on the internet. I unblocked port 80 but it's still not showing up!!!

I have Verizon ISP
nblufire12
 
Posts: 13
Joined: 04. December 2008 02:30

Re: Making Server Public to Internet?

Postby xfsgpr » 10. December 2010 03:32

I suggest create a free domain name at the link I attach below and use your IP address to redirect all traffic to your site:

http://free.domain.name/

There is a drop down list of various domain names to select from. Take your time to select the one you want to use.

hth
xfsgpr
 
Posts: 27
Joined: 20. August 2009 21:45

Re: Making Server Public to Internet?

Postby nblufire12 » 10. December 2010 03:37

I have a domain. I've setup Xampp before and made it work with a domain and ftp server.

But I wiped my computer and I can't seem to make it work again :(

I'm having truoble making my site public. I opened port 80 but nothing's working. I have other ports open like ventrilo 3784 and vnc 5900 but i cant see my site on the internet...
nblufire12
 
Posts: 13
Joined: 04. December 2008 02:30

Re: Making Server Public to Internet?

Postby JonB » 10. December 2010 05:26

make sure your ISP isn't blocking port 80, and that if your IP is dynamic you are using a service like DynDNS or NoIP

good luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Making Server Public to Internet?

Postby nblufire12 » 10. December 2010 05:31

I have Verizon FiOS and I'm sure it isn't.

After all I had a working server public to the web before I reinstalled Windows XP...

This is so frustrating!
nblufire12
 
Posts: 13
Joined: 04. December 2008 02:30

Re: Making Server Public to Internet?

Postby JonB » 10. December 2010 15:00

Did you check the Windows Firewall???
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Making Server Public to Internet?

Postby nblufire12 » 10. December 2010 17:10

Checked windows firewall, yea sorry I pasted the wrong IP, it's 72.81.134.223 and my domain name is www.compaqserver.info
nblufire12
 
Posts: 13
Joined: 04. December 2008 02:30

Re: Making Server Public to Internet?

Postby xfsgpr » 11. December 2010 23:53

Is it likley that MX on the CPanel on Verizon (actually it is at your registrar - company you registered/bought your domain from) is showing where to direct all the traffic associated to your domain? Perhaps, the IP address has changed since you last updated your records so it is worth logging in to their website to see your records once again.

I have checked your records online and noticed that you are registered with GoDaddy so I suggest logon to their website and check whether you need to change the MX records from CPanel.

http://www.whois.net/whois/compaqserver.info

hth
xfsgpr
 
Posts: 27
Joined: 20. August 2009 21:45

Re: Making Server Public to Internet?

Postby nblufire12 » 12. December 2010 00:32

Well I can't even access my site with the numbers 72.81.134.223 so why would my domain work?

My IP hasn't changed for a couple months now.
nblufire12
 
Posts: 13
Joined: 04. December 2008 02:30

Re: Making Server Public to Internet?

Postby Sharley » 12. December 2010 02:26

xfsgpr wrote:Is it likley that MX on the CPanel...
MX records are for the Mail Exchange which specifies the mail servers for the domain name and so are not really related to this issue - as long as the OP has setup his domain zone file at his registrar correctly and I believe he has, then we can eliminate that as contributing to his issues.
xfagpr, more reading for you on the DNS Zone File here:
http://www.hansenonline.net/Networking/zonefile.html
http://en.wikipedia.org/wiki/Zone_file
http://bobcares.com/blog/?p=30



@ nblufire12
I tried to connect to both your IP and your domain name and both are showing 'connection refused'.

This may indicate a mal-configured router firewall or your Windows firewall perhaps.

The connection from my PC to your PC goes all the way and is blocked or refused access at your PC.

Make sure also that your ISP has allowed port 80 traffic in to your PC.
http://www.google.com/search?q=verizon+ ... ks+port+80

You would get a different error message if it was an Apache (XAMPP) server related issue - I am not getting as far as your XAMPP Apache server, connection is refused at your addresses.

Enter your IP or domain name (no www) in to the top text box and tick all the boxes at this link:
http://centralops.net/co/DomainDossier.aspx

It will give you details about your connection as if you were coming at it from another location - in fact what we all will see from the Internet to your local server.


Just a few more questions to help troubleshoot this for you and to perhaps eliminate any issues with the XAMPP Apache server:
1. Where exactly are your web site files located in XAMPP ?
2. Can you access your site using http://localhost or http://127.0.0.1 ?
3. What address do you type in your browser to access your site locally ?
4. Can you access the XAMPP demo site at http://localhost/xampp/ ?

Good luck.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Making Server Public to Internet?

Postby Aflove65 » 20. December 2010 06:28

I am having the same problem. I am using xampp 1.7.3. I can access xampp thru the local host and 127.0.0.1 but I cannot access it thru my no-ip dns. I have checked the firewall and looks like everything is ok there. I am just not sure what to do next. I use http://mjgirl.bounceme.net/xampp/.
Aflove65
 
Posts: 2
Joined: 20. December 2010 05:47

Re: Making Server Public to Internet?

Postby Sharley » 20. December 2010 08:37

Aflove65 wrote:...I use http://mjgirl.bounceme.net/xampp/.
Drop the /xampp from the URI and make sure that your site's index file (index.php or index.html) is located in the htdocs folder and not in the htdocs/xampp folder.

http://mjgirl.bounceme.net

This should find your site if Apache is running and your site files are in the htdocs folder, also if your setup at no-ip is correct.

The security settings for XAMPP prevent outside access to the htdocs/xampp folder and these settings can be found in apache\conf\extra\httpd-xampp.conf file down at the bottom under 'New XAMPP security concept'.

Did you follow the link to CentralOps Domain Dossier in my previous post and type in the box mjgirl.bounceme.net and tick all the boxes - I get that your location is timing out and it appears you are also on fios.verizon.com which is the same ISP as the OP - is port 80 blocked by your ISP?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Making Server Public to Internet?

Postby Aflove65 » 20. December 2010 18:14

Ok apparently verizon does block port 80. I have it listening on port 8080 now and it is working :)
Aflove65
 
Posts: 2
Joined: 20. December 2010 05:47

Re: Making Server Public to Internet?

Postby Sharley » 21. December 2010 01:08

Aflove65 wrote:Ok apparently verizon does block port 80. I have it listening on port 8080 now and it is working :)
If having port 80 blocked becomes a pain, then it is possible to contact Verizon and have them open port 80 for you - not sure but I believe it is blocked by default so they can monitor any server they open port 80 for.

BTW, when I tested your address it now gives a 403 Access denied error because your site is being diverted to the xampp folder in the htdocs folder which is a direct result of the configuration issue I mentioned above.

You need to add your own index.php or index.html and delete or rename the XAMPP index files that are already in the htdocs folder and are redirecting visitors to the xampp folder - not allowed.

There are many alternatives to the above delete or rename approach and a few can be found in this topic:
viewtopic.php?f=16&t=43079

Good luck.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 74 guests