Please Help A Newb!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Please Help A Newb!

Postby raynalyn » 06. December 2010 19:15

Hi I am trying to setup xampp to create a wordpress site. I followed the download instructions completely but when i try to connect to: http://localhost/ with internet explorer it says cannto diplay the page. i am running windows 7 64 bit and installed xampp to my c: after logging in as an administrator. I went to firwall and allowed both apache server and the mysql server and i noticed that the apache server is on their like 4 times.

Can some please give me some advice
raynalyn
 
Posts: 7
Joined: 06. December 2010 19:06

Re: Please Help A Newb!

Postby JonB » 06. December 2010 19:53

Has Apache or a suite like XAMPP (say WAMP) been installed before (or are still installed)?

What shows in the XAMPP Control Panel??

:?:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Please Help A Newb!

Postby raynalyn » 06. December 2010 20:08

JonB thanks for a quick reply. i do not believe so. I had never heard of xampp or wamp before trying this install. I have been reading about this microsoft IIS in various posts I have no idead if that is running. I initially just ran the installer and got the same error without going into an admn account. so i uninstalled and reinstalled it seems to make no difference. i am alittle confused as wy the apache server is showing up four times in my firewall settings.

The control panel says
Windows 6.1 Build 7600 platform 2
current directory c:\xampp
Status check OK
apache Started
Busy...
Mysql started
raynalyn
 
Posts: 7
Joined: 06. December 2010 19:06

Re: Please Help A Newb!

Postby Altrea » 06. December 2010 22:40

Ignore what the control panel shows in his log window for now.
The only thing that is important for you in the control window is: Is there a green "running" label byside Apache and MySQL.

You should know, Windows have changed their User Account Control (UAC) un the last versions. They don't give full Administrate permissions to any Windows User even your Administrator.
Try this: rightclick your XAMPP control link and choose "execute as Administrator" in the context menu.

If this not helps your look should go into your Apache error.log file (\xampp\apache\logs\error.log).
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Please Help A Newb!

Postby raynalyn » 07. December 2010 00:29

Yes it is green and says running i have tried to run as administrator and still no luck. the odd thing is it apears to be working fine it just won't let me in the admin or connect through my browser here is my error log although I do not know it is generating errors:
[Mon Dec 06 12:36:34 2010] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 06 12:36:34 2010] [notice] Digest: done
[Mon Dec 06 12:36:35 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Mon Dec 06 12:36:35 2010] [notice] Server built: Nov 11 2009 14:29:03
[Mon Dec 06 12:36:35 2010] [notice] Parent: Created child process 1768
[Mon Dec 06 12:36:36 2010] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 06 12:36:36 2010] [notice] Digest: done
[Mon Dec 06 12:36:36 2010] [notice] Child 1768: Child process is running
[Mon Dec 06 12:36:36 2010] [notice] Child 1768: Acquired the start mutex.
[Mon Dec 06 12:36:36 2010] [notice] Child 1768: Starting 150 worker threads.
[Mon Dec 06 12:36:36 2010] [notice] Child 1768: Starting thread to listen on port 443.
[Mon Dec 06 12:36:36 2010] [notice] Child 1768: Starting thread to listen on port 443.
[Mon Dec 06 12:36:36 2010] [notice] Child 1768: Starting thread to listen on port 80.
[Mon Dec 06 12:36:36 2010] [notice] Child 1768: Starting thread to listen on port 80.
[Mon Dec 06 14:07:33 2010] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Mon Dec 06 14:07:33 2010] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 06 14:07:33 2010] [notice] Digest: done
[Mon Dec 06 14:07:33 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Mon Dec 06 14:07:33 2010] [notice] Server built: Nov 11 2009 14:29:03
[Mon Dec 06 14:07:33 2010] [notice] Parent: Created child process 2236
[Mon Dec 06 14:07:34 2010] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 06 14:07:34 2010] [notice] Digest: done
[Mon Dec 06 14:07:35 2010] [notice] Child 2236: Child process is running
[Mon Dec 06 14:07:35 2010] [notice] Child 2236: Acquired the start mutex.
[Mon Dec 06 14:07:35 2010] [notice] Child 2236: Starting 150 worker threads.
[Mon Dec 06 14:07:35 2010] [notice] Child 2236: Starting thread to listen on port 443.
[Mon Dec 06 14:07:35 2010] [notice] Child 2236: Starting thread to listen on port 443.
[Mon Dec 06 14:07:35 2010] [notice] Child 2236: Starting thread to listen on port 80.
[Mon Dec 06 14:07:35 2010] [notice] Child 2236: Starting thread to listen on port 80.
[Mon Dec 06 14:17:42 2010] [notice] Parent: child process exited with status 1073807364 -- Restarting.
[Mon Dec 06 14:18:04 2010] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Mon Dec 06 14:18:04 2010] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 06 14:18:04 2010] [notice] Digest: done
[Mon Dec 06 14:18:04 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Mon Dec 06 14:18:04 2010] [notice] Server built: Nov 11 2009 14:29:03
[Mon Dec 06 14:18:04 2010] [notice] Parent: Created child process 1512
[Mon Dec 06 14:18:05 2010] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 06 14:18:05 2010] [notice] Digest: done
[Mon Dec 06 14:18:06 2010] [notice] Child 1512: Child process is running
[Mon Dec 06 14:18:06 2010] [notice] Child 1512: Acquired the start mutex.
[Mon Dec 06 14:18:06 2010] [notice] Child 1512: Starting 150 worker threads.
[Mon Dec 06 14:18:06 2010] [notice] Child 1512: Starting thread to listen on port 443.
[Mon Dec 06 14:18:06 2010] [notice] Child 1512: Starting thread to listen on port 443.
[Mon Dec 06 14:18:06 2010] [notice] Child 1512: Starting thread to listen on port 80.
[Mon Dec 06 14:18:06 2010] [notice] Child 1512: Starting thread to listen on port 80.
[Mon Dec 06 14:19:55 2010] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Mon Dec 06 14:19:55 2010] [notice] Child 1512: Exit event signaled. Child process is ending.
[Mon Dec 06 14:19:56 2010] [notice] Child 1512: Released the start mutex
[Mon Dec 06 14:19:57 2010] [notice] Child 1512: All worker threads have exited.
[Mon Dec 06 14:19:57 2010] [notice] Child 1512: Child process is exiting
[Mon Dec 06 14:19:57 2010] [notice] Parent: Child process exited successfully.
[Mon Dec 06 14:36:09 2010] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 06 14:36:09 2010] [notice] Digest: done
[Mon Dec 06 14:36:09 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Mon Dec 06 14:36:09 2010] [notice] Server built: Nov 11 2009 14:29:03
[Mon Dec 06 14:36:09 2010] [notice] Parent: Created child process 3176
[Mon Dec 06 14:36:10 2010] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 06 14:36:10 2010] [notice] Digest: done
[Mon Dec 06 14:36:11 2010] [notice] Child 3176: Child process is running
[Mon Dec 06 14:36:11 2010] [notice] Child 3176: Acquired the start mutex.
[Mon Dec 06 14:36:11 2010] [notice] Child 3176: Starting 150 worker threads.
[Mon Dec 06 14:36:11 2010] [notice] Child 3176: Starting thread to listen on port 443.
[Mon Dec 06 14:36:11 2010] [notice] Child 3176: Starting thread to listen on port 443.
[Mon Dec 06 14:36:11 2010] [notice] Child 3176: Starting thread to listen on port 80.
[Mon Dec 06 14:36:11 2010] [notice] Child 3176: Starting thread to listen on port 80.
[Mon Dec 06 14:36:37 2010] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Mon Dec 06 14:36:37 2010] [notice] Child 3176: Exit event signaled. Child process is ending.
[Mon Dec 06 14:36:38 2010] [notice] Child 3176: Released the start mutex
[Mon Dec 06 14:36:39 2010] [notice] Child 3176: All worker threads have exited.
[Mon Dec 06 14:36:39 2010] [notice] Child 3176: Child process is exiting
[Mon Dec 06 14:36:39 2010] [notice] Parent: Child process exited successfully.
[Mon Dec 06 18:23:36 2010] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 06 18:23:36 2010] [notice] Digest: done
[Mon Dec 06 18:23:36 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Mon Dec 06 18:23:36 2010] [notice] Server built: Nov 11 2009 14:29:03
[Mon Dec 06 18:23:36 2010] [notice] Parent: Created child process 4836
[Mon Dec 06 18:23:37 2010] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 06 18:23:37 2010] [notice] Digest: done
[Mon Dec 06 18:23:37 2010] [notice] Child 4836: Child process is running
[Mon Dec 06 18:23:37 2010] [notice] Child 4836: Acquired the start mutex.
[Mon Dec 06 18:23:37 2010] [notice] Child 4836: Starting 150 worker threads.
[Mon Dec 06 18:23:37 2010] [notice] Child 4836: Starting thread to listen on port 443.
[Mon Dec 06 18:23:37 2010] [notice] Child 4836: Starting thread to listen on port 443.
[Mon Dec 06 18:23:37 2010] [notice] Child 4836: Starting thread to listen on port 80.
[Mon Dec 06 18:23:37 2010] [notice] Child 4836: Starting thread to listen on port 80.
raynalyn
 
Posts: 7
Joined: 06. December 2010 19:06

Re: Please Help A Newb!

Postby Altrea » 07. December 2010 00:49

Okay, so your Apache and MySQL are really running.
Lets check something different.

Instead of typing http://localhost/ please try http://127.0.0.1/

Can you try differnet browsers?
Is your internet connaction established by trying? (some users have problems with that without a connection)
How does your Windows HOSTS file look like?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Please Help A Newb!

Postby raynalyn » 07. December 2010 00:53

Hey that worked when i typed in the http://127.0.0.1

what does that mean is there something I need to change to make the http://localhost address work or is everything fine?

thank you all so much for your quick replies and help.
raynalyn
 
Posts: 7
Joined: 06. December 2010 19:06

Re: Please Help A Newb!

Postby Altrea » 07. December 2010 01:35

That means you have a problem with DNS (maybe because of IPv6).

Altrea wrote:How does your Windows HOSTS file look like?

(you can find the HOSTS file in C:\Windows\System32\drivers\etc)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Please Help A Newb!

Postby raynalyn » 07. December 2010 01:40

# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host

# localhost name resolution is handled within DNS itself.
# 127.0.0.1 localhost
raynalyn
 
Posts: 7
Joined: 06. December 2010 19:06

Re: Please Help A Newb!

Postby Altrea » 07. December 2010 01:50

okay, that looks like the default stuff (all commented out, thats okay).
Please open your command line and type in
Code: Select all
ping localhost

And please send a
Code: Select all
netstat -aon | find ":80"
in your command line too.

post these two Responses and we will see, whats going wrong
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Please Help A Newb!

Postby raynalyn » 07. December 2010 02:03

ping request could not find local host. please check the name and try again.

tcp 0.0.0.0:80 0.0.0.0:0 Listening 2708
tcp [::]:80 [::]:0 Listening 2708
raynalyn
 
Posts: 7
Joined: 06. December 2010 19:06

Re: Please Help A Newb!

Postby Altrea » 07. December 2010 02:11

raynalyn wrote:tcp 0.0.0.0:80 0.0.0.0:0 Listening 2708
tcp [::]:80 [::]:0 Listening 2708

Thats okay. Your Apache is listening on both IPv4 and IPv6

raynalyn wrote:ping request could not find local host. please check the name and try again.

Thats unexpected :shock:
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Please Help A Newb!

Postby raynalyn » 07. December 2010 02:36

I seem to be able to work around with the 127.0.0.1 address can i not just set that up to work somehow. I am only wanting to be able to see the wordpress site locally before publishing it online.
raynalyn
 
Posts: 7
Joined: 06. December 2010 19:06

Re: Please Help A Newb!

Postby WilliL » 07. December 2010 18:54

try to change
# localhost name resolution is handled within DNS itself.
# 127.0.0.1 localhost

to

# localhost name resolution is handled within DNS itself.
127.0.0.1 localhost
Willi
WilliL
 
Posts: 661
Joined: 08. January 2010 10:54
Operating System: Win7Home Prem 64 SP1


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 62 guests