[solved]XAMPP PHP Error Reporting to ignore warnings

Problems with the Windows version of XAMPP, questions, comments, and anything related.

[solved]XAMPP PHP Error Reporting to ignore warnings

Postby edalsie » 29. November 2010 05:10

I'm trying to set up Joomla and I keep getting error messages.
I've turned off PHP reporting "warnings" in Joomla Global Config with no apparent results.
Now I'm told I should come here for help.
I need to "set the XAMPP PHP Error Reporting to ignore warnings"
I am not a programmer, but can follow gentle instructions... can anyone help?
edalsie
 
Posts: 5
Joined: 29. November 2010 05:01

Re: XAMPP PHP Error Reporting to ignore warnings

Postby Altrea » 29. November 2010 10:59

edalsie wrote:Now I'm told I should come here for help.

The first things you can do is post the messages you get, to check if your PHP Version can run with Joomla.
Ignoring Warnings is not in every case the solution.

That depends on your XAMPP and your Joomla version.
So you should tell us them too.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: XAMPP PHP Error Reporting to ignore warnings

Postby edalsie » 29. November 2010 14:24

My apologies... of course you need to know what's happening.

The error messages are like these:
Warning: strtotime() [function.strtotime]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for '-5.0/no DST' instead in C:\xampp\htdocs\Joomla\libraries\joomla\utilities\date.php on line 56

Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for '-5.0/no DST' instead in C:\xampp\htdocs\Joomla\libraries\joomla\utilities\date.php on line 198

Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for '-5.0/no DST' instead in C:\xampp\htdocs\Joomla\libraries\joomla\utilities\date.php on line 198

I am running Joomla version 1.5.20, and XAMPP version win32-1.7.3.

In Joomla I went into Global Config and set error reporting to none.

Also in Joomla I set my Locale Setting to UTC -5 Eastern Time.

Joomla is set to run on localhost/joomla
edalsie
 
Posts: 5
Joined: 29. November 2010 05:01

Re: XAMPP PHP Error Reporting to ignore warnings

Postby Altrea » 29. November 2010 15:19

Not only Joomla needs to get a default timezone, php needs too.
Normally the timezone setting will be setted in the setup_xampp.bat file.
I think it's a good idea for you to run this file once. (stop your xampp components first)

If this will not help to get rid of the messages, we will take a look into your php.ini.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: XAMPP PHP Error Reporting to ignore warnings

Postby edalsie » 29. November 2010 20:06

I'm not sure what the last two posts were about as I do not read nor understand German.
But I ran setup_xampp.bat. It presented me with 1-7 and x. I chose 1 which promptly told me it was already running.
I rebooted my computer, ran it again, chose 1 and ended up with 'XAMPP Control Panel Application'.
Choosing 'setup' on the right, I ended back with the same screen as setup_xampp.bat.
Choosing Apache 'Admin' I ended up with XAMPP 1.7.3 for Windows and a whole list of choices on the left. I went through most of them without finding a path through this.

It might help you to understand where I am in this... I am 64 years old and trying to volunteer my services in setting up a web presence for a small non-profit organization. I am so far out of my element (and comfort zone) here. So "wole'... please keep your snarkiness under control. This is NOT my language.

If I am expecting too much, please let me know. 'Altrea', I appreciate your trying to point me correctly.
edalsie
 
Posts: 5
Joined: 29. November 2010 05:01

Re: XAMPP PHP Error Reporting to ignore warnings

Postby Altrea » 29. November 2010 20:17

edalsie wrote:I'm not sure what the last two posts were about as I do not read nor understand German.

Doesn't matter. This was something personally between wole and me. Sorry for offtopic :D

edalsie wrote:I am 64 years old and trying to volunteer my services in setting up a web presence for a small non-profit organization. I am so far out of my element (and comfort zone) here.

You have all of my respect :) Keep going.

Okay, to solve your problem, please take a look into your file \xampp\php\php.ini (just open it with notepad or any plain-text editor).
Search for the String "[Date]" (should be somewhere around line 1015). Some line down should be a line similar to this (maybe with a different timezone):
Code: Select all
date.timezone = "Europe/Paris"


Do you have a semicolon at the beginning of this line?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: XAMPP PHP Error Reporting to ignore warnings

Postby edalsie » 29. November 2010 20:21

No, it doesn't.
date.timezone = "America/New_York"

I would assume then that it SHOULD have a semi-colon?
edalsie
 
Posts: 5
Joined: 29. November 2010 05:01

Re: XAMPP PHP Error Reporting to ignore warnings

Postby edalsie » 29. November 2010 20:27

Yes!! No more error messages!

Altrea.... thank you very much for your help. It has been invaluable.

I won't even ask why the php.ini needs to know 'date.sunset_zenith' never mind the sunrise zenith.

Now let's see what other trouble I can get myself in. (not really!)

Thanks so very much

Allen
edalsie
 
Posts: 5
Joined: 29. November 2010 05:01

Re: XAMPP PHP Error Reporting to ignore warnings

Postby Altrea » 29. November 2010 20:31

Glad it worked for you! you're welcome :D
Have fun with XAMPP and Joomla
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: XAMPP PHP Error Reporting to ignore warnings

Postby fahmed » 06. April 2011 19:11

hi,

I have downloaded XAMPP and installed, when it started to install the servers at the start only mysql was successful because ports were being used, the status after I do a port check is:

C:\WINNT\system32\inetsrv\inetinfo.exe for port 80/443 and 21 , these need to be free right?

Is this part of dreamweaver, there is a folder called inetpub.

Thankyou for much needed help!
fahmed
 
Posts: 1
Joined: 06. April 2011 19:07

Re: XAMPP PHP Error Reporting to ignore warnings

Postby Sharley » 06. April 2011 21:31

fahmed wrote:hi,

I have downloaded XAMPP and installed, when it started to install the servers at the start only mysql was successful because ports were being used, the status after I do a port check is:

C:\WINNT\system32\inetsrv\inetinfo.exe for port 80/443 and 21 , these need to be free right?

Is this part of dreamweaver, there is a folder called inetpub.

Thankyou for much needed help!
You are off topic in this thread (XAMPP PHP Error Reporting to ignore warnings) and so you should have started a fresh topic or at least searched these English forums before posting as your issue has been well covered many times before.

However not DW related but Microsoft's web server IIS or in later Windows versions known as World Wide Publishing which is enabled by default and must be disabled if you want XAMPP to use the default http,. https and ftp ports you mention above - Apache in XAMPP can't share ports and so must have exclusive use of these ports.

To disable IIS see this post or the many others related to this topic:
viewtopic.php?p=169028#p169028
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP PHP Error Reporting to ignore warnings

Postby Altrea » 10. November 2011 16:23

because here is nothing more to say i close this topic now.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 68 guests