PHP.ini is not loaded - where to set path?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

PHP.ini is not loaded - where to set path?

Postby Caps » 22. November 2010 18:10

Renaming php.ini has no effect. I suspect it is not being loaded. Does XAMPP set path correctly? Upon a new install of a CMS I am receiving error messages

Example: "Warning: session_start() [function.session-start]: open(/path/to/your/cmsms/tmp/\sess_dhn019r82ig69mn45ibis94jl2, O_RDWR) failed: No such file or directory (2) in . . . "

PHP is working as other scripts work. The phpinfo reports:

PHP Version 5.3.1

System Windows NT VPS135 5.2 build 3790 (Windows Server 2003 R2 Enterprise Edition Service Pack 2) i586
Build Date Nov 20 2009 17:20:57
Compiler MSVC6 (Visual C++ 6.0)
Architecture x86
Configure Command cscript /nologo configure.js "--enable-snapshot-build"
Server API Apache 2.0 Handler
Virtual Directory Support enabled
[color=#FF0000]Configuration File (php.ini) Path no value
Loaded Configuration File (none)

Scan this dir for additional .ini files (none)
Additional .ini files parsed (none)
PHP API 20090626
PHP Extension 20090626
Zend Extension 220090626
Zend Extension Build API220090626,TS,VC6
PHP Extension Build API20090626,TS,VC6
Debug Build no
Thread Safety enabled
Zend Memory Manager enabled
Zend Multibyte Support disabled
IPv6 Support enabled
Registered PHP Streams https, ftps, php, file, glob, data, http, ftp, compress.zlib, phar
Registered Stream Socket Transports tcp, udp, ssl, sslv3, sslv2, tls
Registered Stream Filters convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk, zlib.*
Configuration File (php.ini) Path no value
Loaded Configuration File (none


Please assist.
Last edited by Caps on 22. November 2010 18:19, edited 2 times in total.
Caps
 
Posts: 18
Joined: 19. November 2010 19:21

Re: PHP.ini is not loaded - where to set path?

Postby JonB » 22. November 2010 18:15

XXAMPP is registry agnostic - so there are no PHP Path Settings.

It is fairly curious that no php.ini shows.

Where exactly do you have XAMPP installed?

It might also be useful to know what CMS script you are having a problem with (its most likely a problem with that script's configuration options)

:shock:

ysf
Last edited by JonB on 22. November 2010 18:18, edited 1 time in total.
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: PHP.ini is not loaded - where to set path?

Postby Caps » 22. November 2010 18:17

Hi Jon,

I gave the phpinfo info in my post. How does renaming php.ini to php.ini_xxx have no effect? This is why I think it is not being loaded. PHPinfo says there is not path. I now highlighted it.
Caps
 
Posts: 18
Joined: 19. November 2010 19:21

Re: PHP.ini is not loaded - where to set path?

Postby JonB » 22. November 2010 18:20

I just edited my reply -

Are (or were there) there other PHP installs on that server?

You also kinda went right by the question about 'what CMS it is"

:?:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: PHP.ini is not loaded - where to set path?

Postby Caps » 22. November 2010 18:34

oops, you are right. The CMS is ImpressPages: http://impresspages.org/. Check out the demo and you will see why I migrated to the latest php version and went with the relatively easy setup in xampp. Using apache 2.2 and php 5.2, I was unable to install impresspages. The impresspages install wizard reports that php Magic quotes off = no. Again looks like the php.ini is not being read as the Magic quotes off is turned off. - "magic_quotes_gpc = Off"

Caps
Caps
 
Posts: 18
Joined: 19. November 2010 19:21

Re: PHP.ini is not loaded - where to set path?

Postby JonB » 22. November 2010 18:36

OK

Where is XAMMP installed?

This is important to the correct way to proceed at this point...


(having just thought through some possible un-intended outcomes)

How does renaming php.ini to php.ini_xxx have no effect?


Actually that will have exactly the effect you describe - there will be no php.ini.

let me know how it goes - I have to get back on programming and billing stuff -

:)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: PHP.ini is not loaded - where to set path?

Postby Caps » 23. November 2010 16:37

Jon,

I sent you a PM yesterday.
Caps
 
Posts: 18
Joined: 19. November 2010 19:21

Re: PHP.ini is not loaded - where to set path?

Postby JonB » 23. November 2010 18:36

Trust me 'not in my Inbox'

Image

:shock:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: PHP.ini is not loaded - where to set path?

Postby JonB » 23. November 2010 20:26

However, impresspages is showing errors which it did not show previous to the xampp install. Removing/renaming the PHP.ini file has no effect.


So impresspages was installed before XAMMP - Right?

what was powering it?

Impresspages probably needs to be backed up and re-installed if ti was relying on a different webserver and/or MySQL installation.
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: PHP.ini is not loaded - where to set path?

Postby Caps » 23. November 2010 20:48

Impresspages would not install on the earlier version of PHP and this is why I installed xampp. Impresspages needed a later version of PHP. Now the the latest php is installed, Impresspages install wizard passes the php requirement but now I get those errors. The install wizard will not progress pass the requirement page. I also get "Magic quotes off=no, which the php.ini show the it is off. So I suspect the php.ini file is not being loaded. You would think the xampp installer setup would have loaded the php.ini file via the automated installer script.

I will attemp to install another php scripted CMS an let you know what happened.
Caps
 
Posts: 18
Joined: 19. November 2010 19:21

Re: PHP.ini is not loaded - where to set path?

Postby JonB » 23. November 2010 21:02

A good suggestion would be Wordpress, its PHP and MySQL and almost bulletproof installation.

Good Luck

(at this point I think its the configurator for Impresspages). I didn't find the XAMPP install example you taslked about

8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: PHP.ini is not loaded - where to set path?

Postby Caps » 23. November 2010 21:18

I get the same errors installing another CMS which I've been using for 5 years.

"Warning: session_start() [function.session-start]: open(/path/to/your/cmsms/tmp/\sess_dhn019r82ig69mn45ibis94jl2, O_RDWR) failed:"
Caps
 
Posts: 18
Joined: 19. November 2010 19:21

Re: PHP.ini is not loaded - where to set path?

Postby JonB » 23. November 2010 21:30

I'm not the PHP expert that Altrea is, but I'm 100% sure this is all about a php.ini setting AND an environment variable.

"Warning: session_start() [function.session-start]: open(/path/to/your/cmsms/tmp/\sess_dhn019r82ig69mn45ibis94jl2, O_RDWR) failed:"

You would think the xampp installer setup would have loaded the php.ini file via the automated installer script.


it does -

Is there an old -AMP suite (like WAMP) or a stanadlaone version of Apache and PHP still installed???

If they were uninstalled, make sure all php references are gone from the Windows path as well.

Also be sure you have not imported any .htaccess files as they can ALSO contain PHP directives

and use a global search on the drive for php.ini

:)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: PHP.ini is not loaded - where to set path?

Postby Caps » 24. November 2010 04:07

All previous apache installs were uninstalled. I just see the conf folder. I rename it and nothing has changed. I thought within the apache http.conf you are to reference the php server. I see nothing pointing within the http.conf to the php server or to the php.ini file.
Caps
 
Posts: 18
Joined: 19. November 2010 19:21

Re: PHP.ini is not loaded - where to set path?

Postby Altrea » 24. November 2010 04:54

Seems to be that your XAMPP installation fails or is corrupt (because of your filerenaming or misconfiguration!?).

Your Loaded Configuration File must have an entry, like this (installation path can be different)
Image

So, back to start!

Which OS do you use?
In which directory have you installed XAMPP?
Which XAMPP Version have you installed (.exe or .zip)
Have you followed the installation instructions?
Have you executed the setup_xampp.bat file (or if you use the .exe version, was the setup_xampp.bat file executed automatically?)

btw: The php ini dir variable (where the path is set where to search for the php.ini file) is defined in your apache\conf\extra\httpd-xampp.conf. But please, don't change anything there without any instruction by experienced XAMPP users.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 43 guests