Image Display Error in Firefox (png)

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Image Display Error in Firefox (png)

Postby Lee83120 » 18. November 2010 21:31

Hello, I'm new to XAMPP.

I've tried to display some png images in following ways. Some get error some doesn't.
Code: Select all
Error: Firefox message : Image cannot be displayed because it contains error
<img src="http://localhost/tools/12345_s.png" alt="abcde">

No error:
<img src="./12345_s.png">

No error if directly opened:
file:///D:/path/12345_s.png

No error if uploaded to 3rd party host online


It only happens in Firefox 3 (disabled all plugins already) & IE8 but not in opera and Google Chrome.
In Opera or Chrome, the png image sometimes appear broken via localhost.
But when I open it directly with firefox or other image software, they look normal.

jpg images work fine.

XAMPP 1.7.3 (same problem in WAMP) on Windows XP SP3
php.ini : memory_limit = 128M

What is the problem?
Last edited by Lee83120 on 19. November 2010 19:17, edited 1 time in total.
Lee83120
 
Posts: 3
Joined: 18. November 2010 21:22

Re: Image Display Error in Firefox

Postby JonB » 19. November 2010 01:45

Well - it might be really useful to see the code that went with the errors.

:shock:


ydf
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Image Display Error in Firefox

Postby Lee83120 » 19. November 2010 19:16

Thanks for the reply!

The code will be nearly the same. Just a simple html img page.

Code: Select all
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html>
<head>
   <title>Testing</title>
</head>
<body>
<img src="http://localhost/tools/test/8980387_s.png" alt="thumbnail_8980384">

</body>
</html>


Here is a sample of the png images that is causing the error
http://yfrog.com/2h8980387sp
Lee83120
 
Posts: 3
Joined: 18. November 2010 21:22

Re: Image Display Error in Firefox (png)

Postby JonB » 19. November 2010 20:58

Ahhh - nothing to do with your code or XAMMP.

I'm pretty sure it isn't 'really' a browser problem - its a source image problem, and some browsers are less picky than others. The problem is browsers have different rendering engines, so you get different results. Photoshop 7 had to be patched for this, and there are still png output options that will produce files that don't render on all browsers. As I recall - always select the 24 bit options - I'll look later at home.

Google "png alpha channel problems"

Good Luck, and 'chill a bit' as you are not nuts...

8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 62 guests