Apache suddenly stopped working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache suddenly stopped working

Postby raventearsx » 10. November 2010 23:28

Help!

I installed XAMPP on Saturday, had it running and working fine while I began configuring Joomla!, but upon starting the program Monday, Apache won't run.

I am running XP Pro, all SPs installed.
Using XAMPP Windows 1.7.3 Basic

No error messages. I click "start" MySql, and the button changes from "start" to "stop", and I get the "Running" dialogue.

But when I click "start" on Apache, the log reads "Apache started", but the "start" button never changes and I don't get the "running" dialogue.

Any input or suggestions as to what I can try would be GREATLY appreciated!
raventearsx
 
Posts: 5
Joined: 10. November 2010 23:15

Re: Apache suddenly stopped working

Postby Altrea » 11. November 2010 05:39

Please take a look into your xampp\apache\logs\error.log file.
Is there anything interesting in it?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache suddenly stopped working

Postby raventearsx » 11. November 2010 16:04

Here's what the error log says:

(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
raventearsx
 
Posts: 5
Joined: 10. November 2010 23:15

Re: Apache suddenly stopped working

Postby Altrea » 11. November 2010 16:55

Do you run another Webserver, Skype, Teamviewer or some other program which is listening on port 80?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache suddenly stopped working

Postby JonB » 11. November 2010 16:59

99.95% chance - You have another application or servcice running that uses port 80 by default.

Did you install Skype (or any other 'new' applications) recently.

You could run the XAMPP Control Panel's port check, or a utility like ActivePorts to see what's running.

What version of Windows are you running?
:?:

Good Luck
:)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Apache suddenly stopped working

Postby raventearsx » 11. November 2010 17:09

Port Check results:

Apache (HTTP) 80 Program: C:\windows\system32\inetsrv\inetinfo.exe


OK, so now thanks to everyone's help I know that Microsoft IIS is using (and thus blocking) port 80. But why did it work last week, and not anymore? How do I accommodate two programs with one port? Can I get rid of IIS?

Help?

Thanks
raventearsx
 
Posts: 5
Joined: 10. November 2010 23:15

Re: Apache suddenly stopped working

Postby JonB » 11. November 2010 20:19

You still didn't answer the question about Windows version (it is still somewhat relevant - especially to that WHY question).

The brief answer -

IIS 'may' have been enabled if something like Remote Management was recently used (or a variety of other MS tools that want to 'push' things onto the web). Have you installed anything like Visual Studio or Sharepoint Designer?

In the Windows Service Control Manager - you can make the start type for IIS 'manual', and as long as you are not using a Microsoft service that is dependent on it - there will not be a comflict with Apache. If you need to use IIS for something, you can simply Stop the Apache Server and manually start IIS in the Windows SCM.

much too much info:
http://technet.microsoft.com/en-us/libr ... 4(EXCHG.65).aspx

Look In Windows Services -

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Apache suddenly stopped working

Postby raventearsx » 12. November 2010 16:25

See first post:

Running XP Pro with all SPs installed

Making IIS manual sounds like the answer. I got rid of IIS temporarily and that finally allowed Apache to work, but to turn it back "on" I had to reinstall it from the Windows installation disk. I will look into solving that. Any other helpful suggestions?

Thanks for everything!
raventearsx
 
Posts: 5
Joined: 10. November 2010 23:15

Re: Apache suddenly stopped working

Postby raventearsx » 12. November 2010 20:29

I finally figured out how to make it manual, thanks to your advice.

Thank you, thank you, thank you!
raventearsx
 
Posts: 5
Joined: 10. November 2010 23:15


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 49 guests