have tried many things to connect xampp

Problems with the Windows version of XAMPP, questions, comments, and anything related.

have tried many things to connect xampp

Postby asher » 30. October 2010 15:51

i'm using xampp 1.72 with os win vista
i have tried :
1. reinstall my xampp
2. change httpd.conf port
ServerName localhost:88
Listen 88
3. driver etc hosts file
127.0.0.1 localhost
4. error log
[notice] Parent: Created child process 5344
[notice] Digest: generating secret for digest authentication ...
[notice] Digest: done
[notice] Child 5344: Child process is running
[notice] Child 5344: Acquired the start mutex.
[notice] Child 5344: Starting 150 worker threads.
[notice] Child 5344: Starting thread to listen on port 443.
[notice] Child 5344: Starting thread to listen on port 88.
[notice] Child 5344: Starting thread to listen on port 443.
[notice] Child 5344: Starting thread to listen on port 88.

but stil couldnt connect to localhost:88, anything i miss, anyone could help me, ty b4
asher
 
Posts: 9
Joined: 30. October 2010 15:29

Re: have tried many things to connect xampp

Postby JonB » 31. October 2010 02:02

I think I know why -

Try this:

http://localhost:88/index.html

let me know what happens

:)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: have tried many things to connect xampp

Postby asher » 31. October 2010 12:22

Unable to connect
Firefox can't establish a connection to the server at localhost:88

firewall is off using eset smart security v3
asher
 
Posts: 9
Joined: 30. October 2010 15:29

Re: have tried many things to connect xampp

Postby JonB » 31. October 2010 13:53

So much for theory #1

I have checked two running XAMPP servers, neither show these lines twice:
[notice] Child 5344: Starting thread to listen on port 443.
[notice] Child 5344: Starting thread to listen on port 88.

Is that just a cut and paste error?

FWIW - I would suggest you temporarily disable eset, enable the Windows firewall and make the exception for Apache when prompted. In my experience failed to connect generally means blocked or "its off at the other end'.

Last question for now - do you have any vhosts in your configuration?


:?:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: have tried many things to connect xampp

Postby asher » 31. October 2010 14:26

the err log just cut and paste error just omitting the date, have disable both firewall still cant connect, how could i know if there is any vhosts configuration, ty for the reply
asher
 
Posts: 9
Joined: 30. October 2010 15:29

Re: have tried many things to connect xampp

Postby JonB » 01. November 2010 15:15

If you didn't set up vhosts, there aren't any by default - so not an issue.

I do have a question - why did you want/need to run XAMPP on port 88?

:?:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: have tried many things to connect xampp

Postby asher » 01. November 2010 17:00

no specific reason just thought maybe the xampp isnt running cause port 80 has been used
asher
 
Posts: 9
Joined: 30. October 2010 15:29

Re: have tried many things to connect xampp

Postby JonB » 01. November 2010 19:40

OK -

Best course of action -

I'm going to presume you haven't built anything as its not working. (if you have BACK IT UP)

If you have Apache and MySQL running as services - uncheck the Svc box for each and OK the next dialog box (it has to be done one at a time)

Restart you machine
Start the XAMPP Control Panel - Apache and MySql should not show as running now
1st - run the Port Check - see if port 80 is free.

IF port 80 shows as free -
-- Uninstall your XAMMP
-- Follow these instructions
http://www.apachefriends.org/en/xampp-windows.html#524

then - reinstall XAMPP CLEAN - to the default folder - and give it a go

ELSE

IF Port 80 was used by another application when you did the port check - tell us what it was.


Good luck
:)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: have tried many things to connect xampp

Postby asher » 02. November 2010 14:37

[notice] Server built: Jul 22 2009 11:35:54
[notice] Parent: Created child process 4888
[notice] Digest: generating secret for digest authentication ...
[notice] Digest: done
[notice] Child 4888: Child process is running
[notice] Child 4888: Acquired the start mutex.
[notice] Child 4888: Starting 150 worker threads.
[notice] Child 4888: Starting thread to listen on port 443.
[notice] Child 4888: Starting thread to listen on port 80.
[notice] Child 4888: Starting thread to listen on port 443.
[notice] Child 4888: Starting thread to listen on port 80.

have reinstall but just the same cant connect to localhost, i should add PATH to environment variables?
asher
 
Posts: 9
Joined: 30. October 2010 15:29

Re: have tried many things to connect xampp

Postby JonB » 02. November 2010 19:37

asher -

The path thing only matters to locating executables from the command line, or with a system call.

I have looked at several of my XAMPP installs and none of them have 'two start messages' in the Apache log.

this is what a clean session on a 'clane new' XAMMP install looks like

[Tue Nov 02 12:47:39 2010] [notice] Digest: generating secret for digest authentication ...
[Tue Nov 02 12:47:39 2010] [notice] Digest: done
[Tue Nov 02 12:47:40 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Tue Nov 02 12:47:40 2010] [notice] Server built: Nov 11 2009 14:29:03
[Tue Nov 02 12:47:40 2010] [notice] Parent: Created child process 4108
[Tue Nov 02 12:47:42 2010] [notice] Digest: generating secret for digest authentication ...
[Tue Nov 02 12:47:42 2010] [notice] Digest: done
[Tue Nov 02 12:47:43 2010] [notice] Child 4108: Child process is running
[Tue Nov 02 12:47:43 2010] [notice] Child 4108: Acquired the start mutex.
[Tue Nov 02 12:47:43 2010] [notice] Child 4108: Starting 150 worker threads.
[Tue Nov 02 12:47:43 2010] [notice] Child 4108: Starting thread to listen on port 80.
[Tue Nov 02 12:47:43 2010] [notice] Child 4108: Starting thread to listen on port 443.
[Tue Nov 02 13:33:17 2010] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Tue Nov 02 13:33:17 2010] [notice] Child 4108: Exit event signaled. Child process is ending.
[Tue Nov 02 13:33:18 2010] [notice] Child 4108: Released the start mutex
[Tue Nov 02 13:33:19 2010] [notice] Child 4108: All worker threads have exited.
[Tue Nov 02 13:33:19 2010] [notice] Child 4108: Child process is exiting
[Tue Nov 02 13:33:20 2010] [notice] Parent: Child process exited successfully.


So there is something funky going on (that's why I previously asked about the two sets of start actions...)

Question - you installed XAMPP and made NO modifications or additions, right?
Is there a reason for choosing XAMPP 1.7.2 instead of current version?
you installed into c:\xampp?
you installed as an adminstrator, right?
LOL - just covering all the bases -

WHOOPS - glad I did that,
you may also need to remove the IPv6 loopback
::1 localhost

or disable IPv6

http://www.mydigitallife.info/2007/09/0 ... -in-vista/

That's why we have two start messages! listening on two interface addresses (jemandem die Daumen drücken) :shock:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: have tried many things to connect xampp

Postby asher » 03. November 2010 13:40

Question - you installed XAMPP and made NO modifications or additions, right?
-> yup dont made any modif or addt

Is there a reason for choosing XAMPP 1.7.2 instead of current version?
-> want to use drupal 6, and had been installed current version but still the same

you installed into c:\xampp?
->yup

you installed as an adminstrator, right?
->yup

you may also need to remove the IPv6 loopback
::1 localhost
where can i find this, in etc hosts dun have it

or disable IPv6
have disabled it with the instruction link that JonB provide

still cant connect and have two start messages
asher
 
Posts: 9
Joined: 30. October 2010 15:29

Re: have tried many things to connect xampp

Postby JonB » 03. November 2010 14:19

the hosts file DOES have an entry that says?

127.0.0.1 localhost

http://httpd.apache.org/docs/2.0/bind.html

If you want Apache to handle IPv4 connections only, regardless of what your platform and APR will support, specify an IPv4 address on all Listen directives, as in the following examples:

Listen 0.0.0.0:80
Listen 192.170.2.1:80

try making your listen statement:

Listen 127.0.0.1:80

BTW - You are still getting two start messages because you used the adapter level fix for IPv6 - don't worry about it.

While you are on the machine Open a Command window (DOS prompt) and type Ping 127.0.0.1 (return) and see what the results are
Then try pinging localhost...

8)


Good Luck
:shock:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: have tried many things to connect xampp

Postby asher » 04. November 2010 12:55

# Copyright (c) 1993-1999 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host
#
127.0.0.1 localhost

had changed httpd.conf

Listen 127.0.0.1:80

pinging both localhost and 127.0.0.1 are reply, but still cant connect
asher
 
Posts: 9
Joined: 30. October 2010 15:29

Re: have tried many things to connect xampp

Postby JonB » 04. November 2010 15:20

At this point it is my belief its now down to some kind of firewall problem. Could be from Eset, could be from the Windows firewall - there's no way to tell - other than to unplug from your router (a small precaution) and turn off/uninstall Eset, disable the Windows firewall and test.

If you got ping responses from both queries, the 'network side' IS working, so somrthing must be blocking the application (Apache) from communicating with the browser(s)

Speaking along those lines you could try (I suppose) a different browser (on the theory that an unusal browser setting is in place, like use a proxy sever). That last item could cause a websever form running on Port 80 on 127.0.0.1 as that is the address a self-hosting proxy would use.

I'd suggest Google Chrome or Firefox if you aren't running them - DO NOT IMPORT SETTINGS.

Good Luck
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: have tried many things to connect xampp

Postby asher » 05. November 2010 13:16

has uninstalled eset and turned off windows firewall still cant connect

have used opera, chrome, firefox still the same

there is any chance that this is about my windows?
asher
 
Posts: 9
Joined: 30. October 2010 15:29

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 81 guests