Fresh install, mysql broken

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Fresh install, mysql broken

Postby jason_85 » 25. October 2010 18:45

Hi everyone,

So I had just spent the whole day following "tutorials" on how to set up mysql/php/apache, and nothing worked so I decided to give this out-of-the-box xampp thing a try. It installed great on my windows 7 system, and I installed the apache and mysql services without receiving any errors. However, when I go to localhost/phpmyadmin I get the following error:

#1045 - Access denied for user 'root'@'localhost' (using password: NO)

I couldn't find any solutions to this. Other than installing XAMPP I haven't changed any settings. Is there some installation step I'm missing??
Posts: 2
Joined: 25. October 2010 18:39

Re: Fresh install, mysql broken

Postby gillwill » 29. October 2010 05:24

Sorry, have to ask this:

Do you by any chance already have another install of mysql and\or phpMyAdmin on your system that was already there before you installed xampp?

You can also look at the "" in the phpMyAdmin folder in xampp with a text editor and see what it indicates under

/* Authentication type and info */
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['AllowNoPassword'] = true;

Does it indicate something different than this?
Posts: 4
Joined: 29. October 2010 04:52

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 78 guests