Please help - nothing seems to work - cannot access mysql et

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Please help - nothing seems to work - cannot access mysql et

Postby tvgirl » 22. October 2010 17:40

Hello - newbie here!

I was recommended Wordpress to create a new version of my website and want to test it locally on my computer before putting it out onto the web. The wordpress help forums recommended xampp but I am having sooo much trouble with it. This is where I have got to - please help me!

My OS is Windows XP Professional with SP3

I have downloaded XAMPP and it appears to have installed fine. I could get Apache to run so I went to c:\xampp\apache\conf and opened httpd and changed the ports from 80 to 8080 and the servername to localhost:8080. I then went into \extra and opened httpd-ssl and changed the ports etc there from 443 to 4430. I do have Skyper installed but have unticker the 'use ports 80 and 443'.

I can now for the first time access XAMPP by going to http://localhost:8080 but when I go to php my admin I get this error message: MySQL said #2003 - Can't connect to MySQL server on 'localhost' (10061). When I go to status it tells me that everything is deactivated except HTTPS (SSL) and SMTP Service which are activated.

If I go the XAMPP control panel and do a port check I get the following
Apache <HTTP> port 80 program C:\Windows\system32\inetsrv\inetinfo.exe. I get the same for Apache <HTTPS> save that the port number is 443. Port 8080 (which I specified as my local host etc above) is listed as being used by Tomcat, which I don't know anything about and which is not listed as active on my control panel.

Any ideas what I should do? I am new to this and have spent three days trying to download it - I need help in words of one syllable please!

Thanks in advance
tvgirl
 
Posts: 8
Joined: 22. October 2010 17:30

Re: Please help - nothing seems to work - cannot access mysql et

Postby meows » 22. October 2010 19:59

tvgirl wrote:Hello - newbie here!
My OS is Windows XP Professional with SP3

I have downloaded XAMPP and it appears to have installed fine.

> I could get Apache to run so I went to ?>c:\xampp\apache\conf and opened httpd and ?>changed the ports from 80 to 8080 and the ?>servername to localhost:8080.
((( Never change anything that is working UNLESS you totally understand what problems your keypresses are going to cause and how to fix them )))
I then went into \extra and opened httpd-ssl and changed the ports etc there from 443 to 4430. I do have Skyper installed but have unticker the 'use ports 80 and 443'.
(( DITTO above advice )))

If I go the XAMPP control panel and do a port check I get the following
Apache <HTTP> port 80 program C:\Windows\system32\inetsrv\inetinfo.exe. I get the same for Apache <HTTPS> save that the port number is 443. Port 8080 (which I specified as my local host etc above) is listed as being used by Tomcat, which I don't know anything about and which is not listed as active on my control panel.

Any ideas what I should do? I am new to this and have spent three days trying to download it - I need help in words of one syllable please!

Thanks in advance

You have multiable web servers installed.
ISS ( WindowsXP Pro ) and (Apache-XAMP) You have problems.Yes indeed. I would go to Windows Firewall and use your Exceptions tab and set up your servers. (( Apache [port 80])) Then use the Xampp bat file to set things straight with Apache and Mysql= it's default port. When you go to windows firewall it will show you the default ports,

Hope this helps
meows
 
Posts: 44
Joined: 31. January 2007 10:28

Re: Please help - nothing seems to work - cannot access mysql et

Postby tvgirl » 22. October 2010 20:28

Thank you and I am sorry for being so dim, but I am still struggling.

I have gone to Windows Firewall and Apache HTTP Server is listed - when I go to edit it says path C:\xampp\apache\bin\httpd.exe but I can't amend it.

I have added a port for Apache as port 80, but am not sure that this is in any way effective!

MySQL Server is listed as port 80

mysqld is on there too - listed as path G:\xampp\mysql\bin\mysqld.exe (I had previously tried installing xampp on my external hard drive - drive G but uninstalled this earlier today. I can't amend this path information.

Then there is The MySQL Server listed as path C:\xampp\mysql\bin\mysqld.exe

I can't make head nor tail of what I am supposed to do or how to use xampp bat file to sort things out afterwards :? :? :? :? :?

Any ideas?
Thanks
tvgirl
 
Posts: 8
Joined: 22. October 2010 17:30

Re: Please help - nothing seems to work - cannot access mysql et

Postby tvgirl » 22. October 2010 20:30

OMG - scratch that!! I just randomly hit refresh assuming nothing would happen and I'm In!!

I'll no doubt be back with more queries on the next stage, but at least there's progress!

Thanks for your help!! :D :D :D
tvgirl
 
Posts: 8
Joined: 22. October 2010 17:30

Re: Please help - nothing seems to work - cannot access mysql et

Postby tvgirl » 24. October 2010 13:32

Aaaarrggghhhh! Please help!

For two days since my last post, all has been working ifne and I even managed to start playing with a wordpress site, but today I have gone to load it and nothing! When I use the link to access it (localhost:8080/wordpress/wpadmin) I am told the browzer cannot access it. If I go to localhost then I get the MS IIS. The Xampp control panel has everthing turned off - MySQL won't start and Apache starts for a second and then the green 'running' message goes off again. A portscheck shows 80 and 443 as using C:\WINDOWS\system32\inetsrv\inetinfo.exe again.

Please tell me what I should do! I was just starting to get over my frustration of spending 3 days trying to install wordpress and here we go again - it was obviously just a fluke before :( :( :( :roll: :roll: :roll:
tvgirl
 
Posts: 8
Joined: 22. October 2010 17:30

Re: Please help - nothing seems to work - cannot access mysql et

Postby meows » 25. October 2010 08:37

The apache does not start on my system!!!This problem can be several reasons:

1.You have started more then one HTTP Server (IIS, Sambar, ZEUS and so on). Only one Server can use port 80. This error message indicate the problem:
"(OS 10048)... make_sock: could not bind to adress 0.0.0.0:80
no listening sockets available, shutting down"
2.You have other software, such as the Internet Telephone "Skype" which also blocks the port 80. If the problem is "Skype", you can:
Go in Skype to Actions --> Options --> Connection --> remove the check mark at "use port 80 for an alternate port" and restart Skype. Now it should work.
3.You have a firewall which blocks the Apache port. Not all firewalls are compatible with Apache, and sometimes deactivating the firewall is not enough and you must deinstall it. This error message indicates a firewall:
"(OS 10038)Socket operation on non-socket: make_sock: for address 0.0.0.0:80,
apr_socket_opt_set: (SO_KEEPALIVE)
Also if Apache can start, but your browser can't connect to it.
meows
 
Posts: 44
Joined: 31. January 2007 10:28

Re: Please help - nothing seems to work - cannot access mysql et

Postby tvgirl » 25. October 2010 18:15

Thanks - where will I find the error log? I can't seem to find an error log anywhere.

I am fairly certain the issue is that there is IIS installed - a windows thing, but I think I need this to upload changes to current website which I do through ftp using an explorer type window. I have amended the Skype settings to turn off port 80 and 443. What's confusing me is that it was working perfectly for two days and then suddenly stopped again...

I know I sound completely computer illiterate - mainly because I am!
tvgirl
 
Posts: 8
Joined: 22. October 2010 17:30


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 52 guests