After install XAMPP,to connect PHP and MySQL needed anyDrive

Problems with the Windows version of XAMPP, questions, comments, and anything related.

After install XAMPP,to connect PHP and MySQL needed anyDrive

Postby lse123 » 22. October 2010 13:54

new version of XAMPP when it will get released, same time will get released and the upgrade to prior ver?
After install XAMPP, to connect PHP and MySQL needed any MySQL driver like ODBC ...? As in CFML or as Java connections?
Leonidas Euripide Savvides
lse123
 
Posts: 143
Joined: 15. November 2008 13:49
Location: Polis, Paphos
Operating System: vista 64 ultimate

Re: After install XAMPP,to connect PHP and MySQL needed anyDrive

Postby JonB » 22. October 2010 14:17

I can't address the matter of any release date, as I know there are things needed that XAMMP developers have no control over.

However, I am sure that, as in the past, the next XAMMP release will have PHP and MySQl integrated as installed and no other driver will be required to make that work.

Good luck
:D
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: After install XAMPP,to connect PHP and MySQL needed anyDrive

Postby lse123 » 22. October 2010 15:47

same implies for Perl?
What if installed Python?
Ok, but for using that same MySQL of XAMPP from, ColdFusionML and Java, can I? and needed drivers for this?
drivers for the version 5.1 of mysql, the same as if installed stand alone(no bundle)?
Leonidas Euripide Savvides
lse123
 
Posts: 143
Joined: 15. November 2008 13:49
Location: Polis, Paphos
Operating System: vista 64 ultimate

Re: After install XAMPP,to connect PHP and MySQL needed anyDrive

Postby JonB » 22. October 2010 18:05

AFAIK - the Perl DBD will be included - that means the native MySQL driver.

I have not yet been advised if the next release will also be able to make your coffee...

Look - whatever is NOT in the basic future XAMPP package will need a driver OR method/extension, and it will almost certainly have to be the driver designed for the correct 'version' of the language/framework/whatever you are asking about AND the supported version of MySQL that comes with XAMPP.

see this FAQ about 'mixing versions' of key components:

http://bravo.newnetenterprises.com/word ... age_id=254

Good Luck
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: Gharas and 65 guests