apache does not display 'running'

Problems with the Windows version of XAMPP, questions, comments, and anything related.

apache does not display 'running'

Postby cinci-hal » 20. October 2010 21:03

I am installing XAMPP for the first time following the tutorial (http://sixrevisions.com/tutorials/web-d ... velopment/) and got to the part where you open the control panel and start Apache. After I clicked on the Start button next to Apache, the control panel dispays:

XAMPP Control Panel Version 2.5.8 (2009-07-28)
XAMPP for Windows Version 1.7.3
Windows 5.1 Build 2600 Platform 2 Service Pack 3
Current Directory: C:\xampp
Status Check OK
Busy...
Apache started


The tutorial says that 'running' would be displayed next to Apache, but this does not happen, so apparently Apache has started but is not running? The tutorial also mentioned that I might get a Windows Firewall popup, which I did not get. Any help getting to the next step would be appreciated.
cinci-hal
 
Posts: 4
Joined: 20. October 2010 20:33

Re: apache does not display 'running'

Postby Altrea » 20. October 2010 21:15

Please take a look into the xampp\apache\logs\error.log file, espeacially any error messages are relevant.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: apache does not display 'running'

Postby cinci-hal » 21. October 2010 15:18

OK, so I opend up the error.log file:

(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs


I'm not sure how to check to see what is using this socket address. Please help

I did look to see if there was another apache server running, but did not find one. The following is how I looked and what I found:

Checked to see if there was any other Apache server application in Control Panel > Add or Remove Programs. Did not see any

Found a Folder in Programs files (C:\Program Files\Apache Software Foundation\Apache2.2), it didn't look like there was much in it, but I deleted it anyways.

Checked Control
Panel > Administrative Tools > Services and there is no other Apache server running

checked HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services and there is no Apache application listed.

Rebooted Windows and reinstalled C:\xampp\apache\apache_installservice.bat, but still the same error log.
cinci-hal
 
Posts: 4
Joined: 20. October 2010 20:33

Re: apache does not display 'running'

Postby Altrea » 21. October 2010 15:31

The first thing you can do is running the xampp portcheck which comes with your installation.

The other thing you can do is starting your Windows commandline and type in this command:
Code: Select all
netstat -aon |find ":80"


Take a look for the lines where the left of the two IPs ends with :80 and the Status is something like "LISTENING".
Remember the last column "PID" of this line. You need the PID to find out which process it is.

Now open the task manager processes tab and enable the column PID.
Search the process you remembered in the list.

If we know which process blocks your port we can see what to do to fix the problem.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: apache does not display 'running'

Postby cinci-hal » 21. October 2010 16:22

OK, so here is what is running on port 80:

1288 inetinfo -> 80 TCP C:\WINDOWS\system32\inetsrv\inetinfo.exe

Instead of unintalling IIS, can I have Apache use a different port. The only reason for using Apache/XAMPP is so I can have a vertual server for creating and checking a custom WordPress theme off-line. In other words I do not need this Apache server to connect to the internet. If I can use a different port, How do I set one up and configure it? What are my other options?
cinci-hal
 
Posts: 4
Joined: 20. October 2010 20:33

Re: apache does not display 'running'

Postby Altrea » 21. October 2010 16:26

You can:
- stop IIS Server, if you don't need it
- change the Ports of your IIS Server
- change the Ports of your XAMPP Apache server
- run only one of the servers at the same time

It's up to you. But only one process can listen on one port on the same time.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: apache does not display 'running'

Postby cinci-hal » 21. October 2010 16:40

Thank you!
cinci-hal
 
Posts: 4
Joined: 20. October 2010 20:33

Re: apache does not display 'running'

Postby tvgirl » 27. October 2010 08:56

Altrea wrote:You can:
- stop IIS Server, if you don't need it
- change the Ports of your IIS Server
- change the Ports of your XAMPP Apache server
- run only one of the servers at the same time

It's up to you. But only one process can listen on one port on the same time.


Sorry to hijack, but I am having the same problem. How do I do each of these? The process I have on port 80 is inetinfo.exe and I get the same message as the previous poster on the port check. I am not sure whether I need the IIS (I think this is what it is) so am loathe to uninstall it, but would quite like to turn it off so I get xampp and mysql working!

Thanks.
tvgirl
 
Posts: 8
Joined: 22. October 2010 17:30


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 31 guests