php-sendmail problem

Problems with the Windows version of XAMPP, questions, comments, and anything related.

php-sendmail problem

Postby btolman » 11. October 2010 22:17

I have a php script that is submitting some of the emails, but not all of them:

Here is the script
Code: Select all
                do {
                    set_time_limit(45);
                    if (@mail($agentemail, $subject,$header.$contents.$footer,
                    "To: $agentemail\n" .
                    "From: me<info@mydomain.com>\n" .
                    "MIME-Version: 1.0\n" .
                    "Content-type: text/html; charset=iso-8859-1"))
                    {
                        ?>
                        <tr>
                            <td><b><?php echo $all_clients['firstname']." ".$all_clients['lastname'];?></b></td>
                            <td><?php echo $clientemail;?></td>
                            <td>Yes</td>
                        </tr>
                        <?
                    } else {
                        ?>
                        <tr>
                            <td><b><?php echo $all_clients['firstname']." ".$all_clients['lastname'];?></b></td>
                            <td><?php echo $clientemail;?></td>
                            <td>No</td>
                        </tr>
                        <?
                    }
                    ?>
        <?php } while ($all_clients = mysql_fetch_assoc($get_all_clients));


So when it sends, I get a "yes" otherwise, I get "no"

And the number of actual recieved emails coorsponds to the yes/no rate. The probem is when I try to send more than 6, it will send the first six, then none of the rest. Sometimes, it will send others from the list, but generally speacking, it sends 6.

Version of XAMPP is 1.71. By the way, it will send them "One at a Time" just fine.
My php.ini
Code: Select all

[mail function]
; For Win32 only.
SMTP = mail.mydomain.com
smtp_port = 25

; For Win32 only.
sendmail_from = me@mydomain.com

; For Unix only.  You may supply arguments as well (default: "sendmail -t -i").
;sendmail_path = "C:\xampp\sendmail\sendmail.exe -t"

; Force the addition of the specified parameters to be passed as extra parameters
; to the sendmail binary. These parameters will always replace the value of
; the 5th parameter to mail(), even in safe mode.
;mail.force_extra_parameters =

; added logging

; Log all mail() calls including the full path of the script, line #, to address and headers
mail.log = "C:\xampp\apache\logs\php_mail.log"



By the way, the log doesn't work, either.
btolman
 
Posts: 2
Joined: 11. October 2010 22:05

Re: php-sendmail problem

Postby btolman » 12. October 2010 18:27

How about this: Can anyone get the log working?

The one response I had was about the set_time function - I do this because the app will mail out about 13K emails.

Any thoughts?
btolman
 
Posts: 2
Joined: 11. October 2010 22:05


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 65 guests