A simple XAMPP version question please advise.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

A simple XAMPP version question please advise.

Postby seansingh » 06. October 2010 08:05


I'm going to try installing a local Joomla on XAMPP for the 1st time ever on a windows 7 OS. I have a question before I install.

My production server has got -

Hosting OS - Proprietary *nix
MySQL version - 5.1.30
PHP version - 5.2.5
Perl version - 5.8.4

Whereas XAMPP latest (1.7.3) version has got -

Hosting OS - Apache 2.2.14
MySQL - 5.1.41
PHP - 5.3.1
Perl - 5.10.1

Since XAMPP has newer versions of MySQL, PHP and Perl, If I install Joomla on it and work on my site and then move my finished site to my live server which has slightly older versions of everything, will I have any kind of issues ?

Please help.


Posts: 1
Joined: 06. October 2010 07:54

Re: A simple XAMPP version question please advise.

Postby JonB » 07. October 2010 00:43

OK, althought it may SEEM simple LOL, its like lots of things people call simple...

First - AFAIK Joomla does not use Perl, so that's not an issue.

So I will take a whack at this - GENERALLY if two webservers BOTH meet the minimum specs for an application it will run on both. The key is that major version 5.x 2.x 1.x represent functional changes in the servers and languages. The minir revisions are typically new small features, security fixes and most important - bug fixes! So most higher versions in the same Major release are backward compatible with their older relatrves.

There is one big thing - make sure neither PHP version is blacklisted for bugs by Joomla. -


Sometimes there are add-ins that may be picky, so if you have anything like that you know of, check their info.

If you plan to code your own, don't use any features of PHP or extensions not supported in the lowest version.

I did my best on this, but the BEST place to ask is on a Joomla forum


Have fun and good luck with your project
User avatar
AF Moderator
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 17 guests