It won`t start as i want!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

It won`t start as i want!

Postby Thephpdude » 11. September 2010 15:57

Hello, i have installed xampp on windows 7 platform and i placed my website in the c:/xampp/htdocs/ . The problem is when i want to acces any file, it gives me a new window to chose: to download it, or to view it (note the file is .php). If it`s .html everything works fine...but .php doesn`t want to do the same. Can you please help me?
Image:
Image
Thephpdude
 
Posts: 4
Joined: 11. September 2010 15:30

Re: It won`t start as i want!

Postby lrasan » 12. September 2010 17:41

do you double click the php files in the htdocs folder to open?

if so, you cannot view a php file by double clicking. you have to access php files by localhost.

go to http://localhost/xampp/ if this take you to xampp main page you shouldn't have any problems in viewing the php files as well. you just have to type in the path of the php file on your browser address bar. http://localhost/htdocs/install.php

this should open up the php file on your browser. just note that php files do not open simply by double clicking like a html file. you have to give the correct path where the file exist.

i'm not a php guru but hope this helps ~ :D
lrasan
 
Posts: 8
Joined: 10. September 2010 12:20

Re: It won`t start as i want!

Postby Thephpdude » 13. September 2010 21:01

yes,it helped me. You are rigth i need to give in, the rigth adress/path in that www. bar .
mmm...i moved the install.php in the bar to see if it works...but still C://....... but now it works...ooohh...i will note that. When i was on free webhosting and i was working on a script (still php) i didn`t had this problem...but in xampp it seems i mus`t follow some basic rules.
Solved
Thank you
(sorry if my english is bad in this post but i„m in a rush)
Irasan, again, thank you.
Thephpdude
 
Posts: 4
Joined: 11. September 2010 15:30

Re: It won`t start as i want!

Postby lrasan » 15. September 2010 03:18

:D glad it worked for you ! :wink:
lrasan
 
Posts: 8
Joined: 10. September 2010 12:20


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests