Can't start Mercury service

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't start Mercury service

Postby Etdashou » 09. September 2010 18:15

Hello,

I have a problem with my Mercury service. It was working fine until a month ago.

When I try to launch the Mercury service in the Services window of my server, I have the following error

Could not start the Mercury service on Local Computer.
Error 1: Incorrect Function.

Do you guys have any idea why I see that and what I could do to help me fix this issue.
In the mercury logs their is nothing about this issue.

I have Mercury v4.5
Etdashou
 
Posts: 24
Joined: 01. April 2008 20:20

Re: Can't start Mercury service

Postby JonB » 10. September 2010 04:50

What version of XAMPP?

I don't think its a Mercury error, I think its a Windows service error.

Check the Path to Executable in the Windows Service Manager (right click on Service, Properties)

Just a suspicion

(did you add or remove any drives back when the problem started?)

8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Can't start Mercury service

Postby Etdashou » 10. September 2010 14:13

Well...

First thank you for the reply.

Second, I decided to not use Mercury anymore. I will simply modify my php.ini to connect to our SMTP server directly and that will be perfect.

I don't want to support another product :)

Thanks anyway!
Etdashou
 
Posts: 24
Joined: 01. April 2008 20:20

Re: Can't start Mercury service

Postby JonB » 10. September 2010 16:27

Good IDEA! LOL

That's what sendmail is really for, anyway.

As you have learned, I'm sure - supporting your own Mail servers is not a lot of fun. (spoken as one hwo has several to keep watch over).

I think you will find you need the 'sendmail.exe' (that is found in xampp\sendmail) to use as the MTA. There's a sample sendmail.ini file with examples to create account/connections in.

Good Luck

:mrgreen:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Can't start Mercury service

Postby Etdashou » 10. September 2010 17:37

:D
Etdashou
 
Posts: 24
Joined: 01. April 2008 20:20


Return to XAMPP for Windows

Who is online

Users browsing this forum: Bonniem and 69 guests