Object not found!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Object not found!

Postby mimbreno » 31. August 2010 16:30

Hi,

Head is spinning a bit having taken on xampp, joomla, particulars of my webhost, etc all at once and things weren't helped by a hard drive crash on my laptop after I got everything up and running. Now retracing my steps.

Probably overlooking some obvious config issue here. Is it something within phpmyadmin? Privileges?

Have xampp installed and get "Congratulations" at http://localhost/xampp/ or http://127.0.0.1/xampp/ Can access other menu items, security, etc, see below. Created a DB - mysite - via phpmyadmin. Trying to invoke Kickstart.php located at c:\xampp\htdocs\mysite to initiate a restore of an akeebabackup of mysite at same location as kickstart - previously restored w/o problems on the dead laptop.

However
http://localhost/xampp/mysite/kickstart.php or
http://localhost/xampp/htdocs/mysite/kickstart.php or
http://127.0.0.1/xampp/mysite/kickstart.php or
http://127.0.0.1/xampp/htdocs/mysite/kickstart.php
(I understand that htdocs is normally not in the typed path but I'm being a bit redundant)

all result in

Object not found!
The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.
If you think this is a server error, please contact the webmaster.
Error 404
localhost
8/30/2010 6:18:53 PM
Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1

What am I missing?

Perhaps the following would be helpful, or if not, please let me know so I can direct my attention to more fruitful pursuits!
I noted that there are 4 .htaccess files within c:\xampp - 2 w/ identical content and time stamps at
c:\xampp\htdocs\xampp and
c:\xampp\security\htdocs as follows

AuthName "xampp user"
AuthType Basic
AuthUserFile "C:\xampp\security\xampp.users"
require valid-user

so I assume these are in a default state from the install. Is this where the problem lies?
The other 2 are located at
c:\xampp\htdocs\xampp\sqlite as follows

Order deny,allow
Deny from all

and
c:\xampp\phpmyadmin\libraries as follows

# This folder does not require access over HTTP
# (the following directive denies access by default)
Order allow,deny

this is from
XAMPP Status
This page offers you one page to view all information about what's running and working, and what isn't working.
Component Status Hint
MySQL database ACTIVATED
PHP ACTIVATED
Perl with mod_perl ACTIVATED
Apache::ASP ACTIVATED
HTTPS (SSL) ACTIVATED
Common Gateway Interface (CGI) ACTIVATED
Server Side Includes (SSI) ACTIVATED
IPv4 ACTIVATED
IPv6 DEACTIVATED
SMTP Service DEACTIVATED
FTP Service ACTIVATED
Some changes to the configuration may sometimes cause false negatives. All reports viewed with SSL (https://localhost) do not function!

And this is from http://localhost/security/
XAMPP SECURITY [Security Check 1.1]
This page gives you a quick overview of the security status of your XAMPP installation. (Please continue reading after the table.)
Subject
Status
These XAMPP pages are not accessible through the network by anyone SECURE
The MySQL admin user root has a password SECURE
PhpMyAdmin password login is enabled. SECURE
The FileZilla FTP password was changed SECURE
A POP3 server like Mercury Mail is not running or is blocked by a firewall! UNKNOWN
The Tomcat add-on is not installalled. UNKNOWN

The above status and security settings worked on the previous dead laptop setup as I'm not dealing with a mailserver yet and have no idea what tomcat is.

tia!
mimbreno
 
Posts: 3
Joined: 03. August 2010 15:21

Re: Object not found!

Postby Altrea » 31. August 2010 18:02

mimbreno wrote:Trying to invoke Kickstart.php located at c:\xampp\htdocs\mysite to initiate a restore of an akeebabackup of mysite at same location as kickstart - previously restored w/o problems on the dead laptop.

However
http://localhost/xampp/mysite/kickstart.php or
http://localhost/xampp/htdocs/mysite/kickstart.php or
http://127.0.0.1/xampp/mysite/kickstart.php or
http://127.0.0.1/xampp/htdocs/mysite/kickstart.php
(I understand that htdocs is normally not in the typed path but I'm being a bit redundant)

all result in

Object not found!
The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.
If you think this is a server error, please contact the webmaster.
Error 404
localhost
8/30/2010 6:18:53 PM
Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1

What am I missing?

Try http://localhost/mysite/kickstart.php
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Object not found!

Postby Nobbie » 31. August 2010 18:22

mimbreno wrote:What am I missing?


The most basic knowledge about a webserver, you probably never read any documentation about Apache (and "DocumentRoot").
Nobbie
 
Posts: 8768
Joined: 09. March 2008 13:04

Re: Object not found!

Postby mimbreno » 31. August 2010 18:51

<snip>
Try http://localhost/mysite/kickstart.php

Well, that was embarrassingly simple!

Thanks for your help.
mimbreno
 
Posts: 3
Joined: 03. August 2010 15:21

Re: Object not found!

Postby mimbreno » 31. August 2010 21:49

Nobbie wrote:
mimbreno wrote:What am I missing?


The most basic knowledge about a webserver, you probably never read any documentation about Apache (and "DocumentRoot").


Point well taken re: my "basic knowledge about a webserver" but actually I've read LOTS of documentation - not all of it well written. As I continue I will revisit the documentation in hopes that increased comprehension will track increased familiarity.

Thanks for taking the time to reply.
mimbreno
 
Posts: 3
Joined: 03. August 2010 15:21


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 72 guests