phpMyAdmin doesn't work, mySql is showing as deactivated.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

phpMyAdmin doesn't work, mySql is showing as deactivated.

Postby drop_lord » 24. August 2010 12:34

I know next to nothing about software programming. I'm a bricks and mortar kind-of-guy.

Installed XAMPP.

I can access myaqladministrator.exe and access mysql.

mysql is running as a service.

MySql is showing as DEACTIVATED

and this is the error when clicking on phpMyAdmin
phpMyAdmin - Error

Cannot load mysqli extension. Please check your PHP configuration. - Documentation


I looked at the documentation but my eyes glaze over.
drop_lord
 
Posts: 14
Joined: 24. August 2010 12:11

Re: phpMyAdmin doesn't work, mySql is showing as deactivated.

Postby JonB » 25. August 2010 05:17

Couple questions first -

What Windows version?

What XAMPP version?

Then I guess I should explain that XAMPP has its own MySQL installation that is part of the package.

The fact that "MySQLAdministrator.exe" exists tell me that MySQL was installed standalone at some point (its not part of the XAMPP package). XAMMP is designed to use phpMyAdmin to roughly the same affect. (that's why the XAMMP MySQL doesn't want to run - there's already a MYSQL service running)

Did you install MySQL separately? :?: (its OK if the answer is yes, we are just trying to get to the bottom of things)

I'll wait on giving a 'fix' for your answers.

Good Luck
:)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: phpMyAdmin doesn't work, mySql is showing as deactivated.

Postby drop_lord » 25. August 2010 23:18

XAMPP 1.7.3
XP Pro all the latest patches
XAMPP has it's own MySql.
MySql Administrator was installed separately.
There is no other copy of MySql on the computer.
The XAMPP MySql runs, it's the XAMPP MySQL and not some other one.

.... xampp\mysql\bin\mysqld.exe" --defaults-file="C:\SYSTEM\xampp\mysql\bin\my.ini" MySQL

Is the business end of the service loading command.

Tell me what to look for, oh helpful emissary.
drop_lord
 
Posts: 14
Joined: 24. August 2010 12:11

Re: phpMyAdmin doesn't work, mySql is showing as deactivated.

Postby JonB » 26. August 2010 16:29

MySql Administrator was installed separately.


What else was installed separately?

:?:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: phpMyAdmin doesn't work, mySql is showing as deactivated.

Postby drop_lord » 27. August 2010 02:53

I dunno, iTunes.

What does that have to do with anything?
drop_lord
 
Posts: 14
Joined: 24. August 2010 12:11

Re: phpMyAdmin doesn't work, mySql is showing as deactivated.

Postby JonB » 27. August 2010 04:24

Well -

You likley broke XAMMP in some fashion when you "installed separate;ly" there.

Easy fix, un-install XAMPP, clean up - reinstall XAMPP (without installing any extra pieces) see if it works. If it does - don't "install extra things" anymore.

Good Luck

8)

ysf
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: phpMyAdmin doesn't work, mySql is showing as deactivated.

Postby drop_lord » 27. August 2010 13:50

Apache2.x, then OpenFire, then MySql were installed.
The MySql Administrator, a stand-alone, separate program which 'talks' with MySql through the address:port, was installed.
Then Apache2.x and OpenFire and MySql were uninstalled.
Then XAMPP was installed, and along with that was the included MySql.
Now XAMPP knows *nothing* about MySql Administrator, a stand-alone app that interfaces with the MySql database when you run it. MySql Administrator has no file-system interaction with XAMPP. It could be as well installed on your local computer, and I could grant access from the computer here, and thereby you could interface with your MySql Administrator to the XAMPP MySql installation.

So now we have established the facts, what does the error mean in plain english so I can go fix it?

Thanks :mrgreen:
drop_lord
 
Posts: 14
Joined: 24. August 2010 12:11

Re: phpMyAdmin doesn't work, mySql is showing as deactivated.

Postby BigWetDog » 27. August 2010 14:05

What is the installation path for xampp? Specifically, where is php_mysqli.dll? Also, do a search on you system and make sure there is only one php.ini.
User avatar
BigWetDog
 
Posts: 148
Joined: 25. February 2010 15:54

Re: phpMyAdmin doesn't work, mySql is showing as deactivated.

Postby drop_lord » 27. August 2010 17:56

yes. Thank you.

XAMPP installed to C:\SYSTEM\xampp\

php_mysqli.dll C:\SYSTEM\xampp\php\ext\
There are no other copies of php_mysqli.dll.

Only one php.ini on all of C:, and it's C:\SYSTEM\xampp\php\

I'll PM it to both of you.

Thanks again. :wink:
drop_lord
 
Posts: 14
Joined: 24. August 2010 12:11

Re: phpMyAdmin doesn't work, mySql is showing as deactivated.

Postby BigWetDog » 27. August 2010 18:35

Anything telling in your apache logs?
User avatar
BigWetDog
 
Posts: 148
Joined: 25. February 2010 15:54

Re: phpMyAdmin doesn't work, mySql is showing as deactivated.

Postby drop_lord » 27. August 2010 21:04

What am I supposed to look for?
drop_lord
 
Posts: 14
Joined: 24. August 2010 12:11

Re: phpMyAdmin doesn't work, mySql is showing as deactivated.

Postby JonB » 28. August 2010 02:49

Is C:\SYSTEM by any chance your acronym for the Windows systemroot?

just asking...
:)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: phpMyAdmin doesn't work, mySql is showing as deactivated.

Postby drop_lord » 28. August 2010 04:44

Ah, no. Did you think I learned how to install windows yesterday, then XAMPP the day after? :P


What am I supposed to look for in the apache logs?
drop_lord
 
Posts: 14
Joined: 24. August 2010 12:11

Re: phpMyAdmin doesn't work, mySql is showing as deactivated.

Postby BigWetDog » 28. August 2010 11:33

anything that might say somthing isn't loading and why.
User avatar
BigWetDog
 
Posts: 148
Joined: 25. February 2010 15:54

Re: phpMyAdmin doesn't work, mySql is showing as deactivated.

Postby drop_lord » 29. August 2010 20:40

I think the main apache has a log for that.

Been looking at errorlogs.
Have a couple of virtual hosts also though I presume the error you are mentioning is not in there.

I am working on it. Report back later.
drop_lord
 
Posts: 14
Joined: 24. August 2010 12:11

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 77 guests