Can't fix error #1045 when trying to access phpmyadmin

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't fix error #1045 when trying to access phpmyadmin

Postby alwise17 » 23. August 2010 02:34

Hi, i know this has propably been posted a hundred times, but iv spent the last 2 days trying to correct the #1045 error i get when i try to access phpmyadmin, iv tried almost every possible solution i can find, but to no avail. im using the latest 1.7.3 xampp.
So, every time i go to my localhost and try to access phpmyadmin, iv already set a password in the security section but only
MySQL said:

#1045 - Access denied for user 'root'@'localhost' (using password: NO)
Connection for controluser as defined in your configuration failed.
phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.

my phpmyadmin config.ici is below
* This is needed for cookie based authentication to encrypt password in
* cookie
$cfg['blowfish_secret'] = 'xampp'; /* YOU SHOULD CHANGE THIS FOR A MORE SECURE COOKIE AUTH! */

* Servers configuration
$i = 0;

* First server

/* Authentication type and info */
$cfg['Servers'][$i]['auth_type'] = 'cookie'; /* Authentication method (config, http or cookie based) */
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['AllowNoPassword'] = true;

/* Server parameters */
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['compress'] = false;

/* Select mysqli if your server has it */
$cfg['Servers'][$i]['extension'] = 'mysqli';

/* User for advanced features */
$cfg['Servers'][$i]['controluser'] = 'pma';
$cfg['Servers'][$i]['controlpass'] = '4c71c9d8a17f1';

/* Advanced phpMyAdmin features */
$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
$cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
$cfg['Servers'][$i]['relation'] = 'pma_relation';
$cfg['Servers'][$i]['table_info'] = 'pma_table_info';
$cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
$cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
$cfg['Servers'][$i]['column_info'] = 'pma_column_info';
$cfg['Servers'][$i]['history'] = 'pma_history';
$cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';

* End of servers configuration

* Directories for saving/loading files from server
$cfg['UploadDir'] = '';
$cfg['SaveDir'] = '';

$cfg['AllowAnywhereRecoding'] = true;
$cfg['DefaultCharset'] = 'utf-8';
$cfg['DefaultLang'] = 'en-utf-8';
$cfg['DefaultConnectionCollation'] = 'utf8_general_ci';

$cfg['MySQLManualBase'] = '';
$cfg['MySQLManualType'] = 'searchable';


Thanks for the help :)
Posts: 1
Joined: 23. August 2010 02:28

Re: Can't fix error #1045 when trying to access phpmyadmin

Postby JonB » 23. August 2010 15:52

You should change the value of 'AllowNoPassword' to false

Try using the 'http' option instead of cookie - this will create a session login using Basic Authentication - at least until you get the bugs out.


I hope you actually called the file :?:

Good Luck
User avatar
AF Moderator
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 43 guests