xampp install on Windows 7

Problems with the Windows version of XAMPP, questions, comments, and anything related.

xampp install on Windows 7

Postby daneaffr » 22. August 2010 07:21

I'm having a problem with the windows 7 install. First let me say that I have done programming many years ago, but have not done any serious coding in a couple of decades. Needless to say, I'm fumbling my way around in the dark with php and mysql. But here I am!

I installed xampp and am trying to create a testing site in Dreamweaver. I found this lovely gentleman, David Powers(? I think), that has a nice tutorial for doing this. In fact, it was his tutorial that recommended xampp. So the tutorial instructions are using DW CS4, which is the same as I have, but I do not know what Windows version David is working on. His instructions are very clear, but my results differ. When he goes to his local root folder in the Site Definition window, his is c:\htdocs; mine is c:\xampp. On my system htdocs is a folder underneath xampp. That is the first difference.

When David creates a phptesting folder under c:\htdocs and then selects it, the local root folder in the Site Definition window shows as c:\htdocs\phptesting. When I do the corresponding steps on mysystem, the local root folder in the Site Definition window shows as c:\xampp. If I navigate to c:\xampp\htdocs and build the phptesting folder and select it, the local root folder in the DW Site Definition window shows as c:\xampp\htdocs. For whatever reason, it is not picking up the bottom directory in the selection.

Next, the tutorial creates a php file with nothing in it but <? phpinfo(); ?> and saves it as index.php. Then David views it in 'live view' within DW. He gets a nice phpinfo page. I get a nice HTTP 404 - Not Found error. I get this same result if I set up the new site by going down to c:\xampp\phptesting or c:\xampp\htdocs\phptesting. I also tried this by adding the bottom directory \phptesting by typing it into the local root directory path in the Site Definition window, and then followed the steps to create and save the file and view it in live view. When I do this, I get nothing - no error, no page, nothing.

When I open a browser window and navigate to http://localhost, I get the nice IIS 7 page asking me to select a language and when I do, instead of getting to mysql admin, I end up at http://www.iis.net. If I try to go to http://localhost.index.html, I get that nice HTTP 404 error.

It seems pretty obvious that this is not working as it should, but I'm not sure why or what I can do to fix it. Naturally,since I'm less than knowledgeable about all this, I'm not sure where to begin. I've tried to provide as much detail as I can in the hopes I can get some help.
daneaffr
 
Posts: 6
Joined: 22. August 2010 06:47

Re: xampp install on Windows 7

Postby JonB » 22. August 2010 08:45

He probably used a different version of XAMPP, and its possible he made other changes as well

We can help you with the 'getting XAMMP to work' part.

The FIRST step will be disabling IIS.

You can either 'uninstall it' with the Windows Controk Panel or change its Startup type to 'Manual' in Manage Services. Personally, I think disabling it is adequate.

Then you can test XAMPP to see if its working correctly.

After that, you can start sorting out your folder locations. I would suggest you adaot his instructions to the current state of the default XAMMP installation - rather than trying to move folders which will likely cause more things to break - you probably have enough else on your plate.

Good Luck
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: xampp install on Windows 7

Postby daneaffr » 22. August 2010 09:36

Jon B,

Thanks for your response. I uninstalled iis, rebooted and within DW, I'm getting a similar result. I still don't see the full path in the local host field in the Site Definition panel in DW and if I add /phptesting to include the bottom folder, I still get the blank page. The difference is that when I don't type in the bottom folder, instead of a nicely formatted page showing the entire http 404 error, I now just get a white page saying Not Found The requested URL /htdocs/phptesting/index.php was not found on this server.

This happens regardless of how I setup the site in DW (see previous post for variations).

Another difference is that when I try to access http://localhost in the browser, instead of the http 404 error, I'm now getting the index.html page that says "It Works!" that was installed with xampp.

It seem that we are moving in the right direction? But something still is not quite right.
daneaffr
 
Posts: 6
Joined: 22. August 2010 06:47

Re: xampp install on Windows 7

Postby JonB » 22. August 2010 15:39

You will need to get all the folders you want to work with in DreamWeaver inside your DocumentRoot (that's xammp\htdocs by default) IF you want them to work as if they were on a server. (as in have the PHP parsed)

The fact that "It Works" was displayed indicates that someone (or thing) has changed the values in IfModule dir_module DirectoryIndex in the xampp\apache\httpd.conf file. (or perhaps that PHP is not working for some reason)

try this URL - http://localhost/xampp and see what happens. :shock:

You should get the XAMPP configuration page :mrgreen:

Good Luck
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: xampp install on Windows 7

Postby JonB » 22. August 2010 16:02

Hi again

I am working with another member on getting DW CS4 and XAMPP working. His issue is a bit different, but both probably have elements in common, I'm going to suggest you both watch each others topic as 2 or 3 heads are better than one. :shock: (and it saves me typing the same thing twice) :mrgreen:

viewtopic.php?f=16&t=41713&p=164641#p164641

8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: xampp install on Windows 7

Postby daneaffr » 22. August 2010 17:03

Jon B,

I did try http://localhost/xampp and http://localhost/xampp/phptesting in addition to http://localhost - all with the same results. I put my index.php file in all of those folders, but using localhost, I can't access it.

The webpage cannot be found
HTTP 404

I reviewed joe_fontane's issue before I posted. I hoped I could glean something from his experience, but I'm not even getting as far as he is - yet. :wink:

I tried running php.exe in the xampp/php folder and I get a window that says "cli has stopped working - windows is checking for a solution" It spins for a while and then displays, "A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available." There is a php-win.exe in the same folder and it doesn't even open when I click on it.

Shutting down iis did make some difference in that I can at least get to the index.html page that was included in the xampp download by pointing to http://localhost/index.html. I've been poking around in the folder structure there looking for some documentation that might be helpful. I'm totally lost and mucked around with this until 3am.

Before installing xampp, I had Microsoft SQL Server 2005 and 2008 installed. Could this have anything to do with it?
daneaffr
 
Posts: 6
Joined: 22. August 2010 06:47

Re: xampp install on Windows 7

Postby JonB » 22. August 2010 18:44

The previous Microsoft installs should not matter, as long as you have IIS disabled. That's a port conflict issue really.

you probably should do two things

1. post the complete 404 error (it might tell us soemthing that is not apparent to you)

2. look in the Apache errror log, it often gives a better description of a particular problem

Were any changes made to the apache\conf\httpd.conf or apache\conf\extra\httpd-xampp.conf files?

if so - you could be tilting at windmills, as there's no way for me to guess what those changes may be.

where is your XAMPP installed?

I'd look in Explorer and get the true local path to htdocs

In the default install - it 'should' be c:\xampp\htdocs

If it is anything else - this may be the cause on getting a 404.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: xampp install on Windows 7

Postby daneaffr » 22. August 2010 20:11

Unfortunately, I can't run the admin function within the XAMPP control Panel - I get the same 404 error. I looked in c:/xampp/apache/logs/error and found this:

(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs


I've been looking around in my windows network and Norton to see if there is some conflict there. I have been able to look up the configuration in Norton to find that mysql (c:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld.exe) is configured to port 3306 for TCP and apache (c:\xampp\apache\bin\httpd.exe) is configured to port 80 for TCP. Both of them show protocol TCP/UDP configured to port 53. I'm not sure if this is significant, but listed in Smart Firewall Program Control I found another apache server under c:\Program Files (x86)Apache Software Foundation\Apache2.2\bin\httpd.ext)

I've gone through this so many times now, I'm not sure what I am missing. I've created a pdf that shows everything I'm trying. If there is something I'm doing wrong - hopefully it will be obvious! I'm not sure how to post it as an attachment though. :?
daneaffr
 
Posts: 6
Joined: 22. August 2010 06:47

Re: xampp install on Windows 7

Postby daneaffr » 22. August 2010 20:13

Were any changes made to the apache\conf\httpd.conf or apache\conf\extra\httpd-xampp.conf files?


I have not made any changes to any files installed with xampp.
daneaffr
 
Posts: 6
Joined: 22. August 2010 06:47

Re: xampp install on Windows 7

Postby joe_fontane » 22. August 2010 23:06

c:/xampp/htdoc/phptesting is were you need to upload your specific tutorial files, your website root folder being htdocs. Then, for accessing it via your browser, type: http://localhost/phptesting/index.php

I'm not eactly sure what kind of problem you're having, but for setting up and securing xampp I found this article useful:
http://www.sitepoint.com/forums/showthread.php?t=540980
If it still doesn't work, reinstall the complete package and try again.
The mysql command line is accessible through the mysql admin button on the xampp control panel, btw.

Regarding DW CS4 I noticed that the site definition box is a bit flaky, and you might need to type in the folder paths multiple times for them to get chosen. I got mine to stick by entering the folder of choice under htdocs manually and making sure to end the path with a slash or back-slash, respectively. Definetly an irritating bug, right there - and to think it's even possible to regress the functionality of something that has worked in previous software versions. Oh well.

Remember to breathe. I blew my own problem right out of proportion and was lightyears away from how simple the solution turned out to be.

Best of luck.
joe_fontane
 
Posts: 5
Joined: 21. August 2010 20:42

Re: xampp install on Windows 7

Postby JonB » 23. August 2010 00:27

If you are not using teh previous installations for anything, uninstall the Apache and MySQL standalones.

The error message most likely means another service uses port 80. (probably the other Apache install). You could go into Windows Service Manager, look for Apache 2.2 then right click, Properties - it will list the 'Path to executable' for the service.

As for MySQL, its almost impossible to run two instances of MySQL on the same machine. The same tip can be used to track down what MySQL install thinks its in control.

Good Luck
:shock:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: xampp install on Windows 7

Postby daneaffr » 23. August 2010 03:07

Jon B,

Thanks for all your time on this. Actually even though DW doesn't show the full path extending to the phptesting folder in the local host field, it does recognize that this is the path. If I add '\phptesting\ on to the path, it will save the documents in xampp\htdocs\phptesting\phptesting.

the results from using Port-Check in the XAMPP Control Panel show that apache and mysql are using the right ports.

I've uninstalled and installed this all so many times now it's ridiculous already. What I haven't mentioned - and I think might be the factor that is related to these issues, is that this is a 64-bit machine.

I've uninstalled everything and am trying to install and configure mysql 5.1 and the configuration step is getting hung on writing the configuration file. I can see that the old version was backed up and the new file is there, but the configuration wizard is hanging there. I'm afraid I've mucked things up with all the install/configure/startup/shutdown/reconfigure/uninstall...... that has been going on over the last 48 hours here. :(

I'm going to try this other path (no pun intended!) to see if I can get this all working.
daneaffr
 
Posts: 6
Joined: 22. August 2010 06:47


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 65 guests