Wordpress unable to start after using another http port

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Wordpress unable to start after using another http port

Postby francisongsw » 21. August 2010 06:16

Hi,

I am rather puzzled and unable to solve this problem of mine. I run xampplite and wordpress.

I started apache to listen at port 80. I can access http://localhost/ and http://localhost/wordpress. After changing the apache setting to listen to port 90, i can access http://localhost:90/ but not http://localhost:90/wordpress/

Anything I missed out?

Thanks.
francisongsw
 
Posts: 2
Joined: 21. August 2010 06:12

Re: Wordpress unable to start after using another http port

Postby Nobbie » 21. August 2010 10:45

francisongsw wrote:Anything I missed out?


Yes, a fully detailed description of the behaviour including all error messages (if there are any). "I can ... not access ..." is barely nothing.
Nobbie
 
Posts: 8765
Joined: 09. March 2008 13:04

Re: Wordpress unable to start after using another http port

Postby JonB » 21. August 2010 18:05

Anything I missed out?


Yes - Its not such a complete mystery

Did you change the URL in WordPress > Dashboard > Settings > General?

WordPress (like most scripts) has to generate the URL for every action it takes from its own configuration.

You will need to switch back and make the change, then try it. If you DID change the WordPress URL's see the next line and its link:

There's a real possibility it won't work at all - read the last post in this Wordpress topic:
http://wordpress.org/support/topic/running-on-port-8080

Now that you know the 'reason' - realize that this is a WordPress issue not a XAMPP one. If my recommendation does not work, you should inquire on a WordPress forum.

Oh yeah, Gooogle is your best friend. :mrgreen:

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Wordpress unable to start after using another http port

Postby francisongsw » 22. August 2010 04:34

Yeah! I got it. I changed the wordpress URL to reflect the port change and it worked! Thanks!
francisongsw
 
Posts: 2
Joined: 21. August 2010 06:12


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 57 guests