apache won't start on win7 enterprise 64bit

Problems with the Windows version of XAMPP, questions, comments, and anything related.

apache won't start on win7 enterprise 64bit

Postby Onoref » 17. August 2010 13:54

I guess you guys must be getting tired of this type of topic by now.

Here's what's going wrong:
-I start the control panel. Hit the start button next to Apache, I get the message: Busy ... Apache starting. Running goes green, 1 second later it goes away again.
-MySQL and all the other things work perfectly.
-This is 1 computer in a set of HP Compaq systems in a class room, all installed using the same WSUS image.

Things I tried:
-Install xampp using the .exe
-Install xampp using the .zip (so just extract)
-Checked the path, it's c:\xampp
-Checked the error log in c:\xampp\apache\logs\error.log ... it's empty
-check ports, everything is free
-turn off Symantec Endpoint Protection
-try running as a service
-check for apache services
-run as administrator
-in the setup turn off SSI, turn off HTTPS, only use IPv4

I'm running into a brick wall here ... Ooh all mighty guru's ... please help me! :)
Onoref
 
Posts: 3
Joined: 17. August 2010 13:35

Re: apache won't start on win7 enterprise 64bit

Postby Altrea » 17. August 2010 15:21

Onoref wrote:-run as administrator

The option in the rightclick context-menu on xampp control panel link?
Have you tried to run the install exe as administrator too?

Onoref wrote:-Checked the error log in c:\xampp\apache\logs\error.log ... it's empty

Seems like Apache can't change/write to the logfiles.
Are you sure you run the control panel as Administrator (rightclick context menu)?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: apache won't start on win7 enterprise 64bit

Postby Onoref » 18. August 2010 13:04

Altrea wrote:The option in the rightclick context-menu on xampp control panel link?
Have you tried to run the install exe as administrator too?

Just did that, same result
Altrea wrote:Seems like Apache can't change/write to the logfiles.
Are you sure you run the control panel as Administrator (rightclick context menu)?

-go to c:\xampp\
-right click xampp-control.exe and chose Run as Administrator

Yes tried, same result :(
Onoref
 
Posts: 3
Joined: 17. August 2010 13:35

Re: apache won't start on win7 enterprise 64bit

Postby Onoref » 18. August 2010 13:19

Just got the answer handed to me.

-Run xampp-control.exe as administrator
-right click on \xampp\apache\bin\httpd.exe and select properties.
-go to the compatibility tab and select: "Run this program in compatibility mode: winxp sp3"
-apply / ok, close the window.
-hit the Start button in the control panel

... it works :)
Onoref
 
Posts: 3
Joined: 17. August 2010 13:35


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 40 guests