phpPgAdmin and XAMPP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

phpPgAdmin and XAMPP

Postby Soviet » 14. August 2010 21:53

I would like to use phpPgAdmin 4.2.3 in combination with XAMPP 1.7.3 and postgresql-8.4.4.

When I finally managed to get all the files edited in order to run phpPgAdmin and postgresql-8.4.4 all I have after visiting mz http://127.0.0.1/phppgadmin/ is:

Code: Select all
Deprecated: Assigning the return value of new by reference is deprecated in D:\Programs\xampp\phpPgAdmin\classes\Misc.php on line 344

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at D:\Programy\xampp\phpPgAdmin\classes\Misc.php:344) in D:\Programs\xampp\phpPgAdmin\libraries\lib.inc.php on line 56

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at D:\Programy\xampp\phpPgAdmin\classes\Misc.php:344) in D:\Programs\xampp\phpPgAdmin\libraries\lib.inc.php on line 56

Warning: Cannot modify header information - headers already sent by (output started at D:\Programs\xampp\phpPgAdmin\classes\Misc.php:344) in D:\Programs\xampp\phpPgAdmin\classes\Misc.php on line 361


I read somewhere that this is PHP5.3.0 error and that I have to set error_reporting = 0. Is that right? How and where do I do that?
Soviet
 
Posts: 4
Joined: 14. August 2010 21:47

Re: phpPgAdmin and XAMPP

Postby Altrea » 14. August 2010 22:55

Soviet wrote:I read somewhere that this is PHP5.3.0 error

That's wrong. It's not an error, it's a notice.

Soviet wrote:and that I have to set error_reporting = 0. Is that right?

No. Either set display_errors Off or set error_reporting to anything serious (e.g. show all errors exept Notices and deprecated messages).
You have some examples in your php.ini.
There is a doc for all predefined constants in php.

Soviet wrote:How and where do I do that?

Depends on your knowledge.
You can:
- use the php function error_reporting()
- define error_reporting in the php.ini
- set error_reporting in .htaccess files
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: phpPgAdmin and XAMPP

Postby Soviet » 14. December 2010 19:55

It's been a while :P

My error_reporting in php.ini looks like this:
Code: Select all
error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED


Why it's still not working? I understand "E_ALL & ~E_NOTICE" as "Show all errors, except for notices and coding standards warnings." Buy i bet im wrong again :). Can anyone advice?
Soviet
 
Posts: 4
Joined: 14. August 2010 21:47

Re: phpPgAdmin and XAMPP

Postby WilliL » 14. December 2010 23:01

try
Code: Select all
error_reporting = E_ALL & ~(E_NOTICE | E_DEPRECATED)
Willi
WilliL
 
Posts: 661
Joined: 08. January 2010 10:54
Operating System: Win7Home Prem 64 SP1

Re: phpPgAdmin and XAMPP

Postby Soviet » 22. December 2010 15:23

Nope, still the same error :(.
Soviet
 
Posts: 4
Joined: 14. August 2010 21:47

Re: phpPgAdmin and XAMPP

Postby Soviet » 28. January 2011 21:25

Bump?

Is there maybe some other piece of software with Apache and Postgres?
Soviet
 
Posts: 4
Joined: 14. August 2010 21:47


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 56 guests