Not accessible MySQL

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Not accessible MySQL

Postby ucas » 07. August 2010 12:51

Hi. I’ve installed XAMPP BETA edition suitable for Windows 7. I started Apache and MySQL and both run.
But upon accessing phpMyAdmin page I am getting the error message. It says, that “The server is not responding (or the local MySQL server’s socket is not correctly configured).
So how to resolve this problem? :roll: The MySQL uses default assigned port. Having previous version of XAMPP MySQL was accessible.
Cheers
ucas
 
Posts: 8
Joined: 07. August 2010 12:43

Re: Not accessible MySQL

Postby JonB » 07. August 2010 14:51

You installed WHAT XAMPP Beta Edition that is suitable for Windows 7?

:?:

Did someone upload a new project when I was asleep? :lol:

Did you get your DL from this page?
http://www.apachefriends.org/en/xampp-windows.html

You should have installed version 1.7.3 (which is not beta anything) -- as far as I know.

:roll:

YSF
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Not accessible MySQL

Postby ucas » 08. August 2010 22:55

Beta edition, that‘s a new release of XAMPP. According to them, that edition is suitable for Windows 7, at least some one who is responsible for that Project said so (emailed). That edition was uploaded few days ago.
On the previous edition Apache doe not want to run.
JonB wrote:You installed WHAT XAMPP Beta Edition that is suitable for Windows 7?

:?:

Did someone upload a new project when I was asleep? :lol:

Did you get your DL from this page?
http://www.apachefriends.org/en/xampp-windows.html

You should have installed version 1.7.3 (which is not beta anything) -- as far as I know.

:roll:

YSF
ucas
 
Posts: 8
Joined: 07. August 2010 12:43

Re: Not accessible MySQL

Postby JonB » 09. August 2010 01:35

I am going to see what I can do to change how certain information tasking is done.

Unfortunately, the Project doesn't seem to communicate very well, nor have thought through some issues. These things are not your fault, and I will speak my own mind on them privately.

Sorry, I can't help you on this yet.

Good Luck
:)
Last edited by JonB on 09. August 2010 16:29, edited 3 times in total.
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Not accessible MySQL

Postby BigWetDog » 09. August 2010 14:20

Hey Jon,
Check out http://www.apachefriends.org/en/index.html
which links to:
http://www.apachefriends.org/en/xampp-beta.html
so go easy on the guy.

Though I must say given the interest here in the windows port, Oswald might have put something out on the announcements forum, but he is a pretty busy guy so I'll cut him some slack and see if I can't post it.

As for the email, he probably subscribes to the newsletter.
User avatar
BigWetDog
 
Posts: 148
Joined: 25. February 2010 15:54

Re: Not accessible MySQL

Postby JonB » 09. August 2010 19:16

If you are having problems with the BETA version :shock:

post them on the form provided here:

http://www.apachefriends.org/en/xampp-beta.html

Thanks and good luck
:roll:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Not accessible MySQL

Postby BigWetDog » 10. August 2010 12:00

This is apparently a known issue and is being worked on. There appears to be an issue with PHP 5.3.1 + and the mysql extension (though based on php bug reports it may be an issue with the fsockopen interface). Also, are you using 64-bit windows?
Try the following:
A good workaround for this problem is to comment out “::1 localhost” in your “hosts” file (C:\Windows\System32\drivers\etc\hosts) if it isn’t already, and uncomment “127.0.0.1 localhost” if it is commented out by default, as is the case with Windows 7. Another workaround is to use “127.0.0.1″ in your PHP scripts instead of “localhost”.

and for more info take a look at the php bug here:
http://bugs.php.net/bug.php?id=50953

which interestingly enough has input from Heir Wiedmann.
User avatar
BigWetDog
 
Posts: 148
Joined: 25. February 2010 15:54

Re: Not accessible MySQL

Postby BigWetDog » 10. August 2010 14:38

Another idea is to make sure that you don't have any firewall software on your system that is preventing IPv6 from working.
Also, take a look at your hosts file and check the following entries
127.0.0.1 localhost
::1 localhost

Another option is to try using the machine name instead of "localhost".
User avatar
BigWetDog
 
Posts: 148
Joined: 25. February 2010 15:54

Re: Not accessible MySQL

Postby ucas » 11. August 2010 18:57

I use 32 bit Windows. Okay, I will shut off firewall and will look at host file. :shock:
ucas
 
Posts: 8
Joined: 07. August 2010 12:43

Re: Not accessible MySQL

Postby nitro2010 » 14. August 2010 12:16

Try in php.ini

;extension=php_mysql.dll
;extension=php_mysqli.dll
extension=php_mysql_libmysql.dll
extension=php_mysqli_libmysql.dll

reset apache and mysql
nitro2010
 
Posts: 2
Joined: 13. August 2010 12:53

Re: Not accessible MySQL

Postby ucas » 15. August 2010 09:31

Fuck, the OS does not allow to modify the “hosts” file. On that file I removed “read only” mark, logged in as administrator, but upon modification the OS screams that “ access is denied”. As the admin I have full control on that file. What’s the problem? :?
ucas
 
Posts: 8
Joined: 07. August 2010 12:43

Re: Not accessible MySQL

Postby ucas » 15. August 2010 10:47

The problem resolved. In Safe Mode I managed to modify the "hosts" file. And now XAMPP runs.
ucas
 
Posts: 8
Joined: 07. August 2010 12:43


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 64 guests