[solved]404 error

Problems with the Windows version of XAMPP, questions, comments, and anything related.

[solved]404 error

Postby umarmir_123 » 31. July 2010 14:54

hi
i installed xampp on my windows_xp_sp2 system.when i types http:\\localhost it works fine, but whenever i try to run ant other file .html or .php it shows me following msg
***************************************************************************************************
Object not found!
The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster.

Error 404
127.0.0.1
7/31/2010 7:23:00 PM
Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1
****************************************************************************************************
can u plz tel me what i have done wrong?
i only installed xampp and no other software.
thnkx in anticippation
umarmir_123
 
Posts: 5
Joined: 31. July 2010 14:47

Re: 404 error

Postby Altrea » 31. July 2010 14:56

look into the Apache error.log file to see, what path Apache tries zu request.
That should give you some hints whats going wrong
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: 404 error

Postby umarmir_123 » 31. July 2010 16:35

where to find that file and wat changes to make?
xampp is installed in c:xampp
umarmir_123
 
Posts: 5
Joined: 31. July 2010 14:47

Re: 404 error

Postby umarmir_123 » 01. August 2010 02:29

here are the contents of the file error.log.
*******************************************************************************************************************
[Sat Jul 31 00:00:39 2010] [notice] Digest: generating secret for digest authentication ...
[Sat Jul 31 00:00:39 2010] [notice] Digest: done
[Sat Jul 31 00:00:39 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sat Jul 31 00:00:39 2010] [notice] Server built: Nov 11 2009 14:29:03
[Sat Jul 31 00:00:39 2010] [notice] Parent: Created child process 3260
[Sat Jul 31 00:00:41 2010] [notice] Digest: generating secret for digest authentication ...
[Sat Jul 31 00:00:41 2010] [notice] Digest: done
[Sat Jul 31 00:00:41 2010] [notice] Child 3260: Child process is running
[Sat Jul 31 00:00:41 2010] [notice] Child 3260: Acquired the start mutex.
[Sat Jul 31 00:00:41 2010] [notice] Child 3260: Starting 150 worker threads.
[Sat Jul 31 00:00:41 2010] [notice] Child 3260: Starting thread to listen on port 443.
[Sat Jul 31 00:00:41 2010] [notice] Child 3260: Starting thread to listen on port 80.
[Sat Jul 31 00:07:54 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/hello.htm
[Sat Jul 31 00:07:54 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/hello.htm
[Sat Jul 31 13:05:40 2010] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Sat Jul 31 13:05:40 2010] [notice] Child 3260: Exit event signaled. Child process is ending.
[Sat Jul 31 13:05:41 2010] [notice] Child 3260: Released the start mutex
[Sat Jul 31 13:05:43 2010] [notice] Child 3260: All worker threads have exited.
[Sat Jul 31 13:05:43 2010] [notice] Child 3260: Child process is exiting
[Sat Jul 31 13:05:43 2010] [notice] Parent: Child process exited successfully.
[Sat Jul 31 17:58:04 2010] [notice] Digest: generating secret for digest authentication ...
[Sat Jul 31 17:58:04 2010] [notice] Digest: done
[Sat Jul 31 17:58:04 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sat Jul 31 17:58:04 2010] [notice] Server built: Nov 11 2009 14:29:03
[Sat Jul 31 17:58:04 2010] [notice] Parent: Created child process 1960
[Sat Jul 31 17:58:05 2010] [notice] Digest: generating secret for digest authentication ...
[Sat Jul 31 17:58:05 2010] [notice] Digest: done
[Sat Jul 31 17:58:06 2010] [notice] Child 1960: Child process is running
[Sat Jul 31 17:58:06 2010] [notice] Child 1960: Acquired the start mutex.
[Sat Jul 31 17:58:06 2010] [notice] Child 1960: Starting 150 worker threads.
[Sat Jul 31 17:58:06 2010] [notice] Child 1960: Starting thread to listen on port 443.
[Sat Jul 31 17:58:06 2010] [notice] Child 1960: Starting thread to listen on port 80.
[Sat Jul 31 18:24:43 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/hello.htm
[Sat Jul 31 18:24:43 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/hello.htm
[Sat Jul 31 18:24:48 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/hello.html
[Sat Jul 31 18:24:48 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/hello.html
[Sat Jul 31 18:25:22 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/htdocs
[Sat Jul 31 18:25:22 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/htdocs
[Sat Jul 31 18:25:43 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/htdocs
[Sat Jul 31 18:25:43 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/htdocs
[Sat Jul 31 18:25:53 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/htdocs
[Sat Jul 31 18:25:53 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/htdocs
[Sat Jul 31 18:26:38 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/htdocs
[Sat Jul 31 18:26:38 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/htdocs
[Sat Jul 31 18:32:52 2010] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Sat Jul 31 18:32:52 2010] [notice] Child 1960: Exit event signaled. Child process is ending.
[Sat Jul 31 18:32:53 2010] [notice] Child 1960: Released the start mutex
[Sat Jul 31 18:32:54 2010] [notice] Child 1960: All worker threads have exited.
[Sat Jul 31 18:32:54 2010] [notice] Child 1960: Child process is exiting
[Sat Jul 31 18:32:54 2010] [notice] Parent: Child process exited successfully.
[Sat Jul 31 18:34:56 2010] [notice] Digest: generating secret for digest authentication ...
[Sat Jul 31 18:34:56 2010] [notice] Digest: done
[Sat Jul 31 18:34:56 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sat Jul 31 18:34:56 2010] [notice] Server built: Nov 11 2009 14:29:03
[Sat Jul 31 18:34:56 2010] [notice] Parent: Created child process 2024
Terminating on signal SIGTERM(15)
] Digest: generating secret for digest authentication ...
[Sat Jul 31 18:34:57 2010] [notice] Digest: done
[Sat Jul 31 18:34:58 2010] [notice] Child 2024: Child process is running
[Sat Jul 31 18:34:58 2010] [notice] Child 2024: Acquired the start mutex.
[Sat Jul 31 18:34:58 2010] [notice] Child 2024: Starting 150 worker threads.
[Sat Jul 31 18:34:58 2010] [notice] Child 2024: Starting thread to listen on port 443.
[Sat Jul 31 18:34:58 2010] [notice] Child 2024: Starting thread to listen on port 80.
[Sat Jul 31 18:38:56 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/htdocs
[Sat Jul 31 19:23:00 2010] [error] [client 127.0.0.1] script 'C:/xampp/htdocs/xampp/inde4x.php' not found or unable to stat
Terminating on signal SIGTERM(15)
[Sat Jul 31 19:31:55 2010] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sat Jul 31 19:31:56 2010] [notice] Digest: generating secret for digest authentication ...
[Sat Jul 31 19:31:56 2010] [notice] Digest: done
[Sat Jul 31 19:31:57 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sat Jul 31 19:31:57 2010] [notice] Server built: Nov 11 2009 14:29:03
[Sat Jul 31 19:31:57 2010] [notice] Parent: Created child process 1740
Terminating on signal SIGTERM(15)
] Digest: generating secret for digest authentication ...
[Sat Jul 31 19:31:58 2010] [notice] Digest: done
[Sat Jul 31 19:31:58 2010] [notice] Child 1740: Child process is running
[Sat Jul 31 19:31:58 2010] [notice] Child 1740: Acquired the start mutex.
[Sat Jul 31 19:31:58 2010] [notice] Child 1740: Starting 150 worker threads.
[Sat Jul 31 19:31:58 2010] [notice] Child 1740: Starting thread to listen on port 443.
[Sat Jul 31 19:31:58 2010] [notice] Child 1740: Starting thread to listen on port 80.
Terminating on signal SIGTERM(15)
[Sat Jul 31 19:33:57 2010] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sat Jul 31 19:33:58 2010] [notice] Digest: generating secret for digest authentication ...
[Sat Jul 31 19:33:58 2010] [notice] Digest: done
[Sat Jul 31 19:33:58 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sat Jul 31 19:33:58 2010] [notice] Server built: Nov 11 2009 14:29:03
[Sat Jul 31 19:33:58 2010] [notice] Parent: Created child process 1756
Terminating on signal SIGTERM(15)
] Digest: generating secret for digest authentication ...
[Sat Jul 31 19:33:59 2010] [notice] Digest: done
[Sat Jul 31 19:34:00 2010] [notice] Child 1756: Child process is running
[Sat Jul 31 19:34:00 2010] [notice] Child 1756: Acquired the start mutex.
[Sat Jul 31 19:34:00 2010] [notice] Child 1756: Starting 150 worker threads.
[Sat Jul 31 19:34:00 2010] [notice] Child 1756: Starting thread to listen on port 443.
[Sat Jul 31 19:34:00 2010] [notice] Child 1756: Starting thread to listen on port 80.
Terminating on signal SIGTERM(15)
[Sat Jul 31 19:40:20 2010] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sat Jul 31 19:40:21 2010] [notice] Digest: generating secret for digest authentication ...
[Sat Jul 31 19:40:21 2010] [notice] Digest: done
[Sat Jul 31 19:40:22 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sat Jul 31 19:40:22 2010] [notice] Server built: Nov 11 2009 14:29:03
[Sat Jul 31 19:40:22 2010] [notice] Parent: Created child process 184
Terminating on signal SIGTERM(15)
] Digest: generating secret for digest authentication ...
[Sat Jul 31 19:40:23 2010] [notice] Digest: done
[Sat Jul 31 19:40:23 2010] [notice] Child 184: Child process is running
[Sat Jul 31 19:40:23 2010] [notice] Child 184: Acquired the start mutex.
[Sat Jul 31 19:40:23 2010] [notice] Child 184: Starting 150 worker threads.
[Sat Jul 31 19:40:23 2010] [notice] Child 184: Starting thread to listen on port 443.
[Sat Jul 31 19:40:23 2010] [notice] Child 184: Starting thread to listen on port 80.
Terminating on signal SIGTERM(15)
[Sat Jul 31 20:27:35 2010] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sat Jul 31 20:27:37 2010] [notice] Digest: generating secret for digest authentication ...
[Sat Jul 31 20:27:37 2010] [notice] Digest: done
[Sat Jul 31 20:27:37 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sat Jul 31 20:27:37 2010] [notice] Server built: Nov 11 2009 14:29:03
[Sat Jul 31 20:27:37 2010] [notice] Parent: Created child process 544
Terminating on signal SIGTERM(15)
] Digest: generating secret for digest authentication ...
[Sat Jul 31 20:27:39 2010] [notice] Digest: done
[Sat Jul 31 20:27:39 2010] [notice] Child 544: Child process is running
[Sat Jul 31 20:27:39 2010] [notice] Child 544: Acquired the start mutex.
[Sat Jul 31 20:27:39 2010] [notice] Child 544: Starting 150 worker threads.
[Sat Jul 31 20:27:39 2010] [notice] Child 544: Starting thread to listen on port 443.
[Sat Jul 31 20:27:39 2010] [notice] Child 544: Starting thread to listen on port 80.
Terminating on signal SIGTERM(15)
[Sun Aug 01 06:35:34 2010] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sun Aug 01 06:35:35 2010] [notice] Digest: generating secret for digest authentication ...
[Sun Aug 01 06:35:35 2010] [notice] Digest: done
[Sun Aug 01 06:35:36 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sun Aug 01 06:35:36 2010] [notice] Server built: Nov 11 2009 14:29:03
[Sun Aug 01 06:35:36 2010] [notice] Parent: Created child process 584
[Sun Aug 01 06:35:37 2010] [notice] Digest: generating secret for digest authentication ...
[Sun Aug 01 06:35:37 2010] [notice] Digest: done
[Sun Aug 01 06:35:37 2010] [notice] Child 584: Child process is running
[Sun Aug 01 06:35:37 2010] [notice] Child 584: Acquired the start mutex.
[Sun Aug 01 06:35:37 2010] [notice] Child 584: Starting 150 worker threads.
[Sun Aug 01 06:35:37 2010] [notice] Child 584: Starting thread to listen on port 443.
[Sun Aug 01 06:35:37 2010] [notice] Child 584: Starting thread to listen on port 80.
*************************************************************************************************************
so where hav i done wrong.
C:\xampp\htdocs\xampp/hello.html is already there
umarmir_123
 
Posts: 5
Joined: 31. July 2010 14:47

Re: 404 error

Postby JonB » 01. August 2010 03:10

I'm betting you have more than once instance of Apache (or XAMPP) installed.

:idea:

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: 404 error

Postby umarmir_123 » 01. August 2010 03:28

i was having wamp installed on D drive. now i formated that drive but error is still there.
can u plz suggest me the way so that i can do my work..
thnx :!:
umarmir_123
 
Posts: 5
Joined: 31. July 2010 14:47

Re: 404 error

Postby Altrea » 01. August 2010 11:29

[Sat Jul 31 18:25:22 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/htdocs

Do you try to access the file with the URL http://localhost/xampp/htdocs/?
Thats wrong! localhost already routes to your htdocs folder, so the URL should be http://localhost/
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: 404 error

Postby umarmir_123 » 01. August 2010 11:48

hey that worked.....thnx buddy..thnx a lot.
God bless you. :P
umarmir_123
 
Posts: 5
Joined: 31. July 2010 14:47

Re: 404 error

Postby Altrea » 01. August 2010 11:57

No problem. You're welcome :D
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: 404 error

Postby RB1000 » 05. September 2011 17:40

i got this error in apache log
some one help me if i start apache it says running then it stops
this is the error:

[notice] Digest: generating secret for digest authentication ...
[notice] Digest: done
[notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[notice] Server built: Nov 11 2009 14:29:03
[crit] (22)Invalid argument: Parent: Failed to create the child process.
[crit] (OS 6)De ingang is ongeldig. : master_main: create child process failed. Exiting.
[notice] Parent: Child process exited successfully.
RB1000
 
Posts: 2
Joined: 05. September 2011 14:33

Re: 404 error

Postby atluri.suhas » 26. December 2011 19:17

i have installed xampp 1.7.3 ..the index page is displayed well
when ever i try to diaply anyothr file i get an error

Object not found!

The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster.
Error 404
localhost
12/26/2011 11:29:40 PM
Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1

i have aslo tried http:localhost/xampp/htdocs/?....no use...i am getting the same error..

I have also checked the error log file..

[Mon Dec 26 22:48:58 2011] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 26 22:48:58 2011] [notice] Digest: done
[Mon Dec 26 22:48:59 2011] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Mon Dec 26 22:48:59 2011] [notice] Server built: Nov 11 2009 14:29:03
[Mon Dec 26 22:48:59 2011] [notice] Parent: Created child process 1920
[Mon Dec 26 22:49:01 2011] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 26 22:49:01 2011] [notice] Digest: done
[Mon Dec 26 22:49:01 2011] [notice] Child 1920: Child process is running
[Mon Dec 26 22:49:01 2011] [notice] Child 1920: Acquired the start mutex.
[Mon Dec 26 22:49:01 2011] [notice] Child 1920: Starting 150 worker threads.
[Mon Dec 26 22:49:01 2011] [notice] Child 1920: Starting thread to listen on port 443.
[Mon Dec 26 22:49:01 2011] [notice] Child 1920: Starting thread to listen on port 80.
[Mon Dec 26 22:52:01 2011] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Mon Dec 26 22:52:01 2011] [notice] Child 1920: Exit event signaled. Child process is ending.
[Mon Dec 26 22:52:02 2011] [notice] Child 1920: Released the start mutex
[Mon Dec 26 22:52:03 2011] [notice] Child 1920: All worker threads have exited.
[Mon Dec 26 22:52:03 2011] [notice] Child 1920: Child process is exiting
[Mon Dec 26 22:52:03 2011] [notice] Parent: Child process exited successfully.
[Mon Dec 26 22:58:23 2011] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 26 22:58:23 2011] [notice] Digest: done
[Mon Dec 26 22:58:24 2011] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Mon Dec 26 22:58:24 2011] [notice] Server built: Nov 11 2009 14:29:03
[Mon Dec 26 22:58:24 2011] [notice] Parent: Created child process 884
Terminating on signal SIGTERM(15)
] Digest: generating secret for digest authentication ...
[Mon Dec 26 22:58:27 2011] [notice] Digest: done
[Mon Dec 26 22:58:28 2011] [notice] Child 884: Child process is running
[Mon Dec 26 22:58:28 2011] [notice] Child 884: Acquired the start mutex.
[Mon Dec 26 22:58:28 2011] [notice] Child 884: Starting 150 worker threads.
[Mon Dec 26 22:58:28 2011] [notice] Child 884: Starting thread to listen on port 443.
[Mon Dec 26 22:58:28 2011] [notice] Child 884: Starting thread to listen on port 80.
Terminating on signal SIGTERM(15)
[Mon Dec 26 23:03:39 2011] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Mon Dec 26 23:03:41 2011] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 26 23:03:41 2011] [notice] Digest: done
[Mon Dec 26 23:03:42 2011] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Mon Dec 26 23:03:42 2011] [notice] Server built: Nov 11 2009 14:29:03
[Mon Dec 26 23:03:42 2011] [notice] Parent: Created child process 304
[Mon Dec 26 23:03:46 2011] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 26 23:03:46 2011] [notice] Digest: done
[Mon Dec 26 23:03:47 2011] [notice] Child 304: Child process is running
[Mon Dec 26 23:03:47 2011] [notice] Child 304: Acquired the start mutex.
[Mon Dec 26 23:03:47 2011] [notice] Child 304: Starting 150 worker threads.
[Mon Dec 26 23:03:47 2011] [notice] Child 304: Starting thread to listen on port 443.
[Mon Dec 26 23:03:47 2011] [notice] Child 304: Starting thread to listen on port 80.
[Mon Dec 26 23:13:54 2011] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Mon Dec 26 23:13:54 2011] [notice] Child 304: Exit event signaled. Child process is ending.
[Mon Dec 26 23:13:55 2011] [notice] Child 304: Released the start mutex
[Mon Dec 26 23:13:56 2011] [notice] Child 304: All worker threads have exited.
[Mon Dec 26 23:13:56 2011] [notice] Child 304: Child process is exiting
[Mon Dec 26 23:13:56 2011] [notice] Parent: Child process exited successfully.
[Mon Dec 26 23:14:06 2011] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 26 23:14:06 2011] [notice] Digest: done
[Mon Dec 26 23:14:07 2011] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Mon Dec 26 23:14:07 2011] [notice] Server built: Nov 11 2009 14:29:03
[Mon Dec 26 23:14:07 2011] [notice] Parent: Created child process 3664
[Mon Dec 26 23:14:09 2011] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 26 23:14:09 2011] [notice] Digest: done
[Mon Dec 26 23:14:10 2011] [notice] Child 3664: Child process is running
[Mon Dec 26 23:14:10 2011] [notice] Child 3664: Acquired the start mutex.
[Mon Dec 26 23:14:10 2011] [notice] Child 3664: Starting 150 worker threads.
[Mon Dec 26 23:14:10 2011] [notice] Child 3664: Starting thread to listen on port 443.
[Mon Dec 26 23:14:10 2011] [notice] Child 3664: Starting thread to listen on port 80.
[Mon Dec 26 23:14:38 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/vjp
[Mon Dec 26 23:14:38 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/favicon.ico
[Mon Dec 26 23:14:38 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/favicon.ico
[Mon Dec 26 23:17:02 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/login.html
[Mon Dec 26 23:17:09 2011] [error] [client 127.0.0.1] script 'C:/xampp/htdocs/xampp/dologin.php' not found or unable to stat
[Mon Dec 26 23:17:20 2011] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Mon Dec 26 23:17:20 2011] [notice] Child 3664: Exit event signaled. Child process is ending.
[Mon Dec 26 23:17:21 2011] [notice] Child 3664: Released the start mutex
[Mon Dec 26 23:17:22 2011] [notice] Child 3664: All worker threads have exited.
[Mon Dec 26 23:17:22 2011] [notice] Child 3664: Child process is exiting
[Mon Dec 26 23:17:22 2011] [notice] Parent: Child process exited successfully.
[Mon Dec 26 23:23:46 2011] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 26 23:23:46 2011] [notice] Digest: done
[Mon Dec 26 23:23:46 2011] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Mon Dec 26 23:23:46 2011] [notice] Server built: Nov 11 2009 14:29:03
[Mon Dec 26 23:23:46 2011] [notice] Parent: Created child process 308
[Mon Dec 26 23:23:49 2011] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 26 23:23:49 2011] [notice] Digest: done
[Mon Dec 26 23:23:49 2011] [notice] Child 308: Child process is running
[Mon Dec 26 23:23:49 2011] [notice] Child 308: Acquired the start mutex.
[Mon Dec 26 23:23:49 2011] [notice] Child 308: Starting 150 worker threads.
[Mon Dec 26 23:23:49 2011] [notice] Child 308: Starting thread to listen on port 443.
[Mon Dec 26 23:23:49 2011] [notice] Child 308: Starting thread to listen on port 80.
[Mon Dec 26 23:24:23 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/login.html
[Mon Dec 26 23:27:01 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/login.html
[Mon Dec 26 23:29:37 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/login.html
[Mon Dec 26 23:29:40 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/login.html

plz help me out...

PLZ HELP ME OUT.....
atluri.suhas
 
Posts: 3
Joined: 26. December 2011 19:10
Operating System: windows xp

Re: 404 error

Postby Altrea » 26. December 2011 19:24

atluri.suhas wrote:[Mon Dec 26 23:17:02 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/login.html
[Mon Dec 26 23:17:09 2011] [error] [client 127.0.0.1] script 'C:/xampp/htdocs/xampp/dologin.php' not found or unable to stat

You have tried http://localhost/xampp/login.html and http://localhost/xampp/dologin.php
But have you ever tried http://localhost/login.html and http://localhost/dologin.php ?
(assumed your files are saved directly in your htdocs folder)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: 404 error

Postby atluri.suhas » 27. December 2011 06:07

i have tried both the methods you have mentioned
1). http://localhost/login.html
and
2). http://localhost/dologin.php
The good thing is both are working,but the all the code is written well and free of errors...but the php script is not running..when the http://localhost/dologin.php" is tried it displays all the content written in the " echo " command.,,
this is the content in the error log file
[Tue Dec 27 10:16:35 2011] [notice] Child 2692: Starting thread to listen on port 443.
[Tue Dec 27 10:16:35 2011] [notice] Child 2692: Starting thread to listen on port 80.
[Tue Dec 27 10:17:31 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/dologin, referer: http://localhost/login.html
[Tue Dec 27 10:18:25 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/dologin, referer: http://localhost/login.html
[Tue Dec 27 10:19:31 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/dologin, referer: http://localhost/login.html
i am giving the sample code of the file plz do check them and help me through

login.html

<html>
<head>
<title>login</title>
</head>
<body bgcolor="#66ccff" text="#000000">
<form action="dologin.php" method="get">
<center></br></br>
<h1><font face="lucid handwriting">LOGIN PAGE</font></h1></br></br>
<table cellpaddding=4 cellspacing=2>
<tr>
<td>USER NAME :</td>
<td><input type="text" name="uname"></br></td>
</tr>
<tr>
<td>PASSWORD :</td>
<td><input type="password" name="password"></br></td>
</tr>
<tr>
<td><input type="submit" value="Login" name="login"></td>
</tr>
</table>
</center>
</form>
</body>
</html>

dologin.php

<?php
$num=$_REQUEST['uname'];
$pwd=$_REQUEST['password'];
$conn=mysql_connect("localhost","root","abc123");
$db=mysql_select_db("ex",$conn);
$query="select email_id,password from users";
$result=mysql_query($query);
while($row=mysql_fetch_array($result))
{
if($num==$row['email_id']&&$pwd==$row['password'])
{

header("Location: example.html");
}
}
echo "<h1>Invalid username or password</h1>";
?>

example.html
<h1>hai..!!</h1>

plz check them out and let me know..TQ.
atluri.suhas
 
Posts: 3
Joined: 26. December 2011 19:10
Operating System: windows xp

Re: 404 error

Postby Altrea » 27. December 2011 10:19

Your script is working fine on my development environment.

Please make sure that:
- you have named all files correct
- your database connection data is correct
- the databasename exists
- the database has a valid entry you can request

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: 404 error

Postby atluri.suhas » 27. December 2011 14:22

Any ways a gret thanks bro...you helped me a lot..thaks a lot..
its working ..i have renintalled xampp..and check my script..:-)
atluri.suhas
 
Posts: 3
Joined: 26. December 2011 19:10
Operating System: windows xp

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 34 guests