Xamp, Windows 7 64bit, MySQL + Phpmyadmin

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Xamp, Windows 7 64bit, MySQL + Phpmyadmin

Postby dashby » 30. July 2010 16:22

I have xampp running fine on a vista laptop however setting it up on windows 7 seems to have issues.

I have Php working fine but I cannot access phpmyadmin at all

when I try to browse http://localhost/phpmyadmin I get

#1045 - Access denied for user 'root'@'localhost' (using password: NO)

Now to my knowledge by default there is not a password set, I have not set one until I manage to get everything running but at no point am I asked for a login and password so I do not even have the opportunity to enter anything.

When I goto

http://localhost/security/

I try to set a password but all I get is

ERROR: The string for the user name and password must be 3 to 15 characters long. Special characters like <öäü (usw.) and empty characters are not allowed!

I am only entering a string of letters and 3 numbers without spaces.

When I look at the xampp consol the only difference between this one and the one running on vista is that the svc checkbox on the windows 7 version has a tick in it but the Vista one doesnt.

Can anyone shed any light on how I fix this please?

Thanks
dashby
 
Posts: 12
Joined: 30. July 2010 16:10

Re: Xamp, Windows 7 64bit, MySQL + Phpmyadmin

Postby JonB » 30. July 2010 20:51

I hope you have MySQL running as a service or Started MySQL in the Control Panel on your Windows 7 box...

:shock:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Xamp, Windows 7 64bit, MySQL + Phpmyadmin

Postby dashby » 30. July 2010 21:07

JonB wrote:I hope you have MySQL running as a service or Started MySQL in the Control Panel on your Windows 7 box...

:shock:


I have started the services for both MySQL and Php but firstly why is the tick in the Svc checkbox on the XAMPP console?
dashby
 
Posts: 12
Joined: 30. July 2010 16:10

Re: Xamp, Windows 7 64bit, MySQL + Phpmyadmin

Postby JonB » 30. July 2010 21:45

Two possibilities - (I don't think you said if it is Apache or MyQSL that is ticked)

BUT the same case is true whichever it is (or both)

One - you checked it/them at some point -

or

Two - there is either a standalone installation present already of that program/service - (and it is running by default) or a prior XAMPP installation is lurking about.

Here's a topic on how to determine if #2 is the case, and how to fix:
viewtopic.php?f=16&t=40717&hilit=+MySQL+won%27t+start

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Xamp, Windows 7 64bit, MySQL + Phpmyadmin

Postby dashby » 30. July 2010 22:21

Yes it is running by default because as soon as xampp is started the service says running, thatnks for the pointer, will follow link and let comment when fixed/ or not.
dashby
 
Posts: 12
Joined: 30. July 2010 16:10

Re: Xamp, Windows 7 64bit, MySQL + Phpmyadmin

Postby dashby » 30. July 2010 22:59

I went down my apps list in control panel, there was a version of MySQL in there, uninstalled it, reinstalled XAMPP, hey presto evrything working as it should.

Thanks JonB
dashby
 
Posts: 12
Joined: 30. July 2010 16:10

Re: Xamp, Windows 7 64bit, MySQL + Phpmyadmin

Postby JonB » 30. July 2010 23:02

Excellent!

glad you got it fixed
:mrgreen:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Xamp, Windows 7 64bit, MySQL + Phpmyadmin

Postby dashby » 01. August 2010 03:30

This is just for information, I dont know if anyone else has had this problem but if alongside Xampp you have Visual Studio 2008 everything runs fine but if you uninstall visual studio 2008 to upgrade to 2010 you need to change your port in xampp to 8080.

I did any how

I would assume that this is when you uninstall the MySQL software with VS and then there are obviously some changes in the 2010 versions, perhaps someone could advise me what?

A quick guide to change your port for Xamp from 80 to 8080 - http://www.youtube.com/watch?v=f1qS5oiK-i0
dashby
 
Posts: 12
Joined: 30. July 2010 16:10


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 23 guests