xampp php problems

Problems with the Windows version of XAMPP, questions, comments, and anything related.

xampp php problems

Postby michaelg252 » 27. July 2010 00:05

hello all, thanks in advance for any help given i really need it. my issue is that ive been trying to create a template in joomla using xampp for a testing server, after months of chipping away i come to realize that my php is not working properly, or maybe im missing something in my newbness. for example if i echo hello world it will not return. or any of the many php commands that ive written to my website..when i open the index.php file it gives me an error stating that theres something wrong with my installation..however my html seems to show..when i check my status under my xampp control panel everything says activated except for stmp and ftp which i did not activate..if these symptoms sound familiar or correctable it would be appreciated....
michaelg252
 
Posts: 3
Joined: 26. July 2010 22:54

Re: xampp php problems

Postby JustMe » 27. July 2010 00:17

If you could post the actual PHP error messages, we might be able to help you...
JustMe
 
Posts: 12
Joined: 22. March 2010 20:34

Re: xampp php problems

Postby michaelg252 » 27. July 2010 00:24

wow thanks for the promptness...i dont really get an error my content just does not show up.. but my xampp/htdocs/index.php returns this ..>>
<?php
if (!empty($_SERVER['HTTPS']) && ('on' == $_SERVER['HTTPS'])) {
$uri = 'https://';
} else {
$uri = 'http://';
}
$uri .= $_SERVER['HTTP_HOST'];
header('Location: '.$uri.'/xampp/');
exit;
?>
Something is wrong with the XAMPP installation :-(

..<<
not sure if it means anything..thanks again
michaelg252
 
Posts: 3
Joined: 26. July 2010 22:54

Re: xampp php problems

Postby JustMe » 27. July 2010 00:43

When I ran your script, I also got an error, but not the same one. Why not try something simple like:


<?php
$test = "Hi mom";
echo $text ;
exit;
?>

and see if that works. If it does, then try the code you posted, but comment out the header statement and try:
echo "location='$uri/xampp/'";

instead - does it show your localhost/xampp folder?

JustMe
JustMe
 
Posts: 12
Joined: 22. March 2010 20:34

Re: xampp php problems

Postby michaelg252 » 27. July 2010 01:09

that works, so i guess i can factor xampp out as my problem and continue troubleshooting my joomla code..hey but thanks for helping out a noob. lol..you dont happen to know anything about joomla (i know its off topic)? if not thanks anyway
michaelg252
 
Posts: 3
Joined: 26. July 2010 22:54

Re: xampp php problems

Postby jmoghari » 13. August 2010 02:06

Please delete this post. Thank you.
jmoghari
 
Posts: 2
Joined: 13. August 2010 01:53

Re: xampp php problems

Postby WilliL » 13. August 2010 10:42

michaelg252 wrote:<?php
if (!empty($_SERVER['HTTPS']) && ('on' == $_SERVER['HTTPS'])) {
$uri = 'https://';
} else {
$uri = 'http://';
}
$uri .= $_SERVER['HTTP_HOST'];
header('Location: '.$uri.'/xampp/');
exit;
?>

try
Code: Select all
<?php
        error_reporting(E_ALL|E_STRICT); // force PHP to show errors, warnings, notices
        if (isset($_SERVER['HTTPS']) && ('on' == $_SERVER['HTTPS'])) {
        ...
Willi
WilliL
 
Posts: 661
Joined: 08. January 2010 10:54
Operating System: Win7Home Prem 64 SP1


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 48 guests