XAMPP installed, Apache and MySQL running, Localhost fails

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP installed, Apache and MySQL running, Localhost fails

Postby Nathan2508 » 12. July 2010 22:12

I am new to XAMPP and need some installation help. I have been struggling with this for weeks and am on my wits end. I am running Windows Vista Home Premium, Service Pack 1, and the XAMPP download is:

###### Apache Friends XAMPP (Basis Package) version 1.7.3 ######

+ Apache 2.2.14 (IPV6 enabled)
+ MySQL 5.1.41 (Community Server) with PBXT engine 1.0.09-rc
+ PHP 5.3.1 (PEAR, Mail_Mime, MDB2, Zend)
+ Perl 5.10.1 (Bundle::Apache2, Apache2::Request, Bundle::Apache::ASP, Bundle::Email, Bundle::DBD::mysql, DBD::SQlite, Randy Kobes PPM)
+ XAMPP Control Version 2.5.8 (ApacheFriends Edition)
+ XAMPP CLI Bundle 1.6
+ XAMPP Port Check 1.5
+ XAMPP Security 1.1
+ SQLite 2.8.17
+ SQLite 3.6.20
+ OpenSSL 0.9.8l
+ phpMyAdmin 3.2.4
+ ADOdb v5.10
+ FPDF v1.6
+ Zend Framework 1.9.6 Minimal Package (via PEAR)
+ Mercury Mail Transport System v4.72
+ msmtp 1.4.19 (a sendmail compatible SMTP client)
+ FileZilla FTP Server 0.9.33
+ Webalizer 2.21-02 (with GeoIP lite)
+ apc 3.1.3p1 for PHP
+ eAccelerator 0.9.6-rc1 for PHP
+ Ming 0.4.3 for PHP
+ PDF with pdflib lite v7.0.4p4 for PHP
+ rar 2.0.0-dev for PHP
+ Xdebug 2.0.6-dev for PHP
+ libapreq2 v2.12 (mod_apreq2) for Apache

First Apache wouldn't even run but I found that the Windows Service "World Wide Web Publishing Service" was running on Port 80. I disabled that program and set it to only start manually because I was told it was only needed for remote IIS management.

Now, Apache and MySQL are running properly according to the XAMPP Control Panel but when I type

"http://localhost"
"http://127.0.0.1"

or any variants of these two that i can find, the page is unable to be displayed by Firefox, Chrome or IE.

A possible solution that I found on Google was to change the ports because Skype and a few other programs try to use port 80. I changed the ports to 8080 in httpd.conf and 4499 in httpd-ssl.conf. This still didn't solve my problem (coincidentally, I uninstalled Skype a few months ago anyway).

Port-Check provides me with the following information:

Apache (HTTP) 80 free
Apache (WebDAV) 81 free
Apache (HTTPS) 81 free
MySQL 3306 Program: C:\xampp\mysql\bin\mysqld.exe
FileZilla (FTP) 21 free
FileZilla (Admin) 14147 free

...
(All the Mercury ports are free)
...

Tomcat (AJP/1.3) 8009 free
Tomcat (HTTP) 8080 Program: C:\xampp\apache\bin\httpd.exe



My Apache error log used to show:

(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

Before I could get Apache working. Now it shows:

[Mon Jul 12 15:25:37 2010] [notice] Digest: generating secret for digest authentication ...
[Mon Jul 12 15:25:37 2010] [notice] Digest: done
[Mon Jul 12 15:25:37 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Mon Jul 12 15:25:37 2010] [notice] Server built: Nov 11 2009 14:29:03
[Mon Jul 12 15:25:37 2010] [notice] Parent: Created child process 756
[Mon Jul 12 15:25:39 2010] [notice] Digest: generating secret for digest authentication ...
[Mon Jul 12 15:25:39 2010] [notice] Digest: done
[Mon Jul 12 15:25:39 2010] [notice] Child 756: Child process is running
[Mon Jul 12 15:25:39 2010] [notice] Child 756: Acquired the start mutex.
[Mon Jul 12 15:25:39 2010] [notice] Child 756: Starting 150 worker threads.
[Mon Jul 12 15:25:39 2010] [notice] Child 756: Starting thread to listen on port 443.
[Mon Jul 12 15:25:39 2010] [notice] Child 756: Starting thread to listen on port 80.
[Mon Jul 12 15:25:39 2010] [notice] Child 756: Starting thread to listen on port 443.
[Mon Jul 12 15:25:39 2010] [notice] Child 756: Starting thread to listen on port 80.
[Mon Jul 12 16:05:20 2010] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Mon Jul 12 16:05:20 2010] [notice] Child 756: Exit event signaled. Child process is ending.
[Mon Jul 12 16:05:21 2010] [notice] Child 756: Released the start mutex
[Mon Jul 12 16:05:22 2010] [notice] Child 756: All worker threads have exited.
[Mon Jul 12 16:05:22 2010] [notice] Child 756: Child process is exiting
[Mon Jul 12 16:05:22 2010] [notice] Parent: Child process exited successfully.
[Mon Jul 12 16:06:36 2010] [notice] Digest: generating secret for digest authentication ...
[Mon Jul 12 16:06:36 2010] [notice] Digest: done
[Mon Jul 12 16:06:37 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Mon Jul 12 16:06:37 2010] [notice] Server built: Nov 11 2009 14:29:03
[Mon Jul 12 16:06:37 2010] [notice] Parent: Created child process 2268
[Mon Jul 12 16:06:39 2010] [notice] Digest: generating secret for digest authentication ...
[Mon Jul 12 16:06:39 2010] [notice] Digest: done
[Mon Jul 12 16:06:39 2010] [notice] Child 2268: Child process is running
[Mon Jul 12 16:06:39 2010] [notice] Child 2268: Acquired the start mutex.
[Mon Jul 12 16:06:39 2010] [notice] Child 2268: Starting 150 worker threads.
[Mon Jul 12 16:06:39 2010] [notice] Child 2268: Starting thread to listen on port 443.
[Mon Jul 12 16:06:39 2010] [notice] Child 2268: Starting thread to listen on port 80.
[Mon Jul 12 16:06:39 2010] [notice] Child 2268: Starting thread to listen on port 443.
[Mon Jul 12 16:06:39 2010] [notice] Child 2268: Starting thread to listen on port 80.
[Mon Jul 12 16:28:19 2010] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Mon Jul 12 16:28:19 2010] [notice] Child 2268: Exit event signaled. Child process is ending.
[Mon Jul 12 16:28:20 2010] [notice] Child 2268: Released the start mutex
[Mon Jul 12 16:28:21 2010] [notice] Child 2268: All worker threads have exited.
[Mon Jul 12 16:28:21 2010] [notice] Child 2268: Child process is exiting
[Mon Jul 12 16:28:21 2010] [notice] Parent: Child process exited successfully.
[Mon Jul 12 16:28:32 2010] [notice] Digest: generating secret for digest authentication ...
[Mon Jul 12 16:28:32 2010] [notice] Digest: done
[Mon Jul 12 16:28:32 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Mon Jul 12 16:28:32 2010] [notice] Server built: Nov 11 2009 14:29:03
[Mon Jul 12 16:28:32 2010] [notice] Parent: Created child process 1972
[Mon Jul 12 16:28:34 2010] [notice] Digest: generating secret for digest authentication ...
[Mon Jul 12 16:28:34 2010] [notice] Digest: done
[Mon Jul 12 16:28:35 2010] [notice] Child 1972: Child process is running
[Mon Jul 12 16:28:35 2010] [notice] Child 1972: Acquired the start mutex.
[Mon Jul 12 16:28:35 2010] [notice] Child 1972: Starting 150 worker threads.
[Mon Jul 12 16:28:35 2010] [notice] Child 1972: Starting thread to listen on port 4499.
[Mon Jul 12 16:28:35 2010] [notice] Child 1972: Starting thread to listen on port 8080.
[Mon Jul 12 16:28:35 2010] [notice] Child 1972: Starting thread to listen on port 4499.
[Mon Jul 12 16:28:35 2010] [notice] Child 1972: Starting thread to listen on port 8080.

I don't know if that helps but you can see how I changed the ports. Any help would be greatly appreciated!
Nathan2508
 
Posts: 5
Joined: 12. July 2010 21:40

Re: XAMPP installed, Apache and MySQL running, Localhost fails

Postby JonB » 13. July 2010 16:50

read this topic, its specific to a problem with Vista and localhost

viewtopic.php?f=16&t=32503
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 56 guests