changing ports for mercury

Problems with the Windows version of XAMPP, questions, comments, and anything related.

changing ports for mercury

Postby larryfroot » 11. July 2010 14:50

We learn.

I have learned that Windows 7 uses some ports that are default in xammp. In my case, mercury mail is affected. Rather than change the default ports for the system, I have sought to change the ports assigned to mercury. I am trying to set it up to work locally, btw.

This is the port allocation for mercury (before I change the ports) via port-check with mercury running as a service:

Code: Select all
smtp 25 free
pop3 110 free
imap 143 Process: System
http 2224 Process: System
Finger 79 free
PH 105 free
PopPass 106 Process: System


So I changed the ports for imap and http in mercury.ini to 8888 and 8889 respectively. I stop and restart mercury and try port-check again and this time I get:

Code: Select all
smtp 25 free
pop3 110 free
imap 143 free
http 2224 free
Finger 79 free
PH 105 free
PopPass 106 free


What do I need to do to get unused ports assigned to mercury, specifically imap, http and PopPass?

Please!!!

Thanks!
larryfroot
 
Posts: 5
Joined: 07. July 2010 10:59

Re: changing ports for mercury

Postby JonB » 11. July 2010 15:11

The built-in XAMMP portcheck is hardwired, it can only check the XAMPP port defaults.

try ActivePorts instead

http://www.devicelock.com/freeware.html

Good Luck
8)

About loopback SMTP, plus there is a video about loopbacking Mercury in this thread:
viewtopic.php?f=16&t=41130&p=162653&hilit=mercury#p162653
:shock:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: changing ports for mercury

Postby larryfroot » 11. July 2010 17:00

thanks mate - will check it out asap : )
larryfroot
 
Posts: 5
Joined: 07. July 2010 10:59

Re: changing ports for mercury

Postby larryfroot » 11. July 2010 17:14

Looks like active ports has an issue with windows 7, I have tried running it in compatibility mode, but no joy. Googling the problem brought nothing useful up.

I have disabled windows firewall, and cleared mercury.exe and loader.exe (found in the mercury folder) with comodo firewall, btw.

The ports I specified in mercury.ini (8888 and 8889) are active as listening ports according to my firewall.

But thank you very much, I really appreciate your help. Any further advice will be recieved with gratitude...cheers, LF
larryfroot
 
Posts: 5
Joined: 07. July 2010 10:59

Re: changing ports for mercury

Postby larryfroot » 11. July 2010 17:33

AHA!

With my blind, flailing manner I cleared the req'd ports through my firewall. Success!

Thanks v much for your time dear froot, LF
larryfroot
 
Posts: 5
Joined: 07. July 2010 10:59

Re: changing ports for mercury

Postby JonB » 12. July 2010 15:41

cool!

8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 44 guests