MySQL will not run as a service

Problems with the Windows version of XAMPP, questions, comments, and anything related.

MySQL will not run as a service

Postby naomid » 22. June 2010 10:34

Hi all,

New to this, just installed xampp for windows 1.7.3 on windows server 2003.

Apache is running fine but by MySQL will not run as a service. If I manually start it it works absolutley fine but click on Svc, and nothing happens.

Edited to add: I ran mysqld --install from the command line and the service now shows when I press the SCM button, however when I try to start it I get the message "could not start the MySQL service on Local Computer Error 1067: The process terminated unexpectedly"

Any help much appreciated.
Naomi
naomid
 
Posts: 1
Joined: 22. June 2010 10:27

Re: MySQL will not run as a service

Postby JonB » 23. June 2010 14:35

Before anything else, a few questions:

What in user context did you install XAMPP ?

Where did you install XAMPP?

Is there any possibility MySQL is or has been installed previously/elsewhere on this same W2K3 server?

I have NO WAY of knowing 'what naomid knows', LOL , so don't take my explanation below as condescending.

All the 'Svc' box actually does is add/install the MySQL service to the MS Service Control Manager. Once that is done MySQL will autostart when the server is restarted. (you should see the green 'Running' status thereafter). For the 'first' time, you must start the service -- unless you restart the W2K3 server. If you 'see' the MySQL service in SCM, then the service is installed - its Startup Type should be Automatic (that means it starts when the Windows Server is initiated).

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 82 guests