InnoDB not work

Problems with the Windows version of XAMPP, questions, comments, and anything related.

InnoDB not work

Postby juanbejar » 20. June 2010 13:49

Hi,

I use xampp in localhost to test websites before uploading to server. I work with InnoDB tables but can´t work they in localhost.

My file "C:/xampp/mysql/bin/my.ini" is the next:

Code: Select all
# Example MySQL config file for small systems.
#
# This is for a system with little memory (<= 64M) where MySQL is only used
# from time to time and it's important that the mysqld daemon
# doesn't use much resources.
#
# You can copy this file to
# C:/xampp/mysql/bin/my.cnf to set global options,
# mysql-data-dir/my.cnf to set server-specific options (in this
# installation this directory is C:/xampp/mysql/data) or
# ~/.my.cnf to set user-specific options.
#
# In this file, you can use all long options that a program supports.
# If you want to know which options a program supports, run the program
# with the "--help" option.

# The following options will be passed to all MySQL clients
[client]
# password       = your_password
port            = 3306
socket          = "C:/xampp/mysql/mysql.sock"

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
port= 3306
socket= "C:/xampp/mysql/mysql.sock"
basedir="C:/xampp/mysql"
tmpdir="C:/xampp/tmp"
datadir="C:/xampp/mysql/data"
skip-locking
key_buffer = 16M
max_allowed_packet = 1M
table_cache = 64
sort_buffer_size = 512K
net_buffer_length = 8K
read_buffer_size = 256K
read_rnd_buffer_size = 512K
myisam_sort_buffer_size = 8M
log_error="mysql_error.log"



# Don't listen on a TCP/IP port at all. This can be a security enhancement,
# if all processes that need to connect to mysqld run on the same host.
# All interaction with mysqld must be made via Unix sockets or named pipes.
# Note that using this option without enabling named pipes on Windows
# (via the "enable-named-pipe" option) will render mysqld useless!
#
# commented in by lampp security
#skip-networking
skip-federated

# Replication Master Server (default)
# binary logging is required for replication
# log-bin deactivated by default since XAMPP 1.4.11
#log-bin=mysql-bin

# required unique id between 1 and 2^32 - 1
# defaults to 1 if master-host is not set
# but will not function as a master if omitted
server-id   = 1

# Replication Slave (comment out master section to use this)
#
# To configure this host as a replication slave, you can choose between
# two methods :
#
# 1) Use the CHANGE MASTER TO command (fully described in our manual) -
#    the syntax is:
#
#    CHANGE MASTER TO MASTER_HOST=<host>, MASTER_PORT=<port>,
#    MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
#
#    where you replace <host>, <user>, <password> by quoted strings and
#    <port> by the master's port number (3306 by default).
#
#    Example:
#
#    CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
#    MASTER_USER='joe', MASTER_PASSWORD='secret';
#
# OR
#
# 2) Set the variables below. However, in case you choose this method, then
#    start replication for the first time (even unsuccessfully, for example
#    if you mistyped the password in master-password and the slave fails to
#    connect), the slave will create a master.info file, and any later
#    change in this file to the variables' values below will be ignored and
#    overridden by the content of the master.info file, unless you shutdown
#    the slave server, delete master.info and restart the slaver server.
#    For that reason, you may want to leave the lines below untouched
#    (commented) and instead use CHANGE MASTER TO (see above)
#
# required unique id between 2 and 2^32 - 1
# (and different from the master)
# defaults to 2 if master-host is set
# but will not function as a slave if omitted
#server-id       = 2
#
# The replication master for this slave - required
#master-host     =   <hostname>
#
# The username the slave will use for authentication when connecting
# to the master - required
#master-user     =   <username>
#
# The password the slave will authenticate with when connecting to
# the master - required
#master-password =   <password>
#
# The port the master is listening on.
# optional - defaults to 3306
#master-port     =  <port>
#
# binary logging - not required for slaves, but recommended
#log-bin=mysql-bin


# Point the following paths to different dedicated disks
#tmpdir = "C:/xampp/tmp"
#log-update = /path-to-dedicated-directory/hostname

# Uncomment the following if you are using BDB tables
#bdb_cache_size = 4M
#bdb_max_lock = 10000

# Comment the following if you are using InnoDB tables
skip-innodb
innodb_data_home_dir = "C:/xampp/mysql/data"
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = "C:/xampp/mysql/data"
innodb_log_arch_dir = "C:/xampp/mysql/data"
## You can set .._buffer_pool_size up to 50 - 80 %
## of RAM but beware of setting memory usage too high
innodb_buffer_pool_size = 16M
innodb_additional_mem_pool_size = 2M
## Set .._log_file_size to 25 % of buffer pool size
innodb_log_file_size = 5M
innodb_log_buffer_size = 8M
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout


As you see, I uncommented the section innodb, but not work.

Please can you help?

Thanks
juanbejar
 
Posts: 6
Joined: 19. June 2010 23:10

Re: InnoDB not work

Postby Nobbie » 20. June 2010 21:46

juanbejar wrote:but not work


What a brilliant error description!
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: InnoDB not work

Postby juanbejar » 21. June 2010 20:40

Nobbie wrote:
juanbejar wrote:but not work


What a brilliant error description!



Sorry, it's a problem of my bad english. I try to say that the line:

skip-innodb


I be change to:

#skip-innodb


And no show Innodb.

Please, can you help me?
juanbejar
 
Posts: 6
Joined: 19. June 2010 23:10

Re: InnoDB not work

Postby JonB » 22. June 2010 01:32

Are you using phpMyADmin to create tables? or are you doing it programmatically, say with PHP?

Try using the default my.ini that came with XAMPP, then try using phpMyAdmin. If you can create the database and tables and update them (as I just did on my XAMPP test server) then the problem is with the scripting language (or your use of it) - not MySQL.

I was able to add an InnoDB table and then access it with phpMyEdit -- and other than me needing to fix the error_reporting levels in PHP to suppress deprecated warnings, it just worked...

Good Luck
:)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: InnoDB not work

Postby juanbejar » 22. June 2010 01:54

Hi JonB, thanks for your post.

I use phpMyAdmin to create tables and not work the Innodb whit they. The default my.ini have the skyp-innodb key uncommented and I suppose that this is te error, but no changes with the key commented.

Any other thing?

Sorry about my poor englis, I try. My first lenguaje is spanish.
juanbejar
 
Posts: 6
Joined: 19. June 2010 23:10

Re: InnoDB not work

Postby JonB » 22. June 2010 02:37

On the Index page of phpMyAdmin, click on Engines...

Is InnoDB listed in blue with a link? If so, the InnoDB storage engine is installed.

You do know that the storage engine is defined at the table level?

So you define a database first, then add a new table and use the Storage Engine drop down box to that new table InnoDB.

---------- Googlese Castilian ------------------------------

En la página Índice de phpMyAdmin, haga clic en los motores (de almacenamiento) ...

Image

Es InnoDB aparecen en azul con un enlace? Si es así, el motor de almacenamiento InnoDB está instalado.

Usted sabe que el motor de almacenamiento se define a nivel de tabla?

Así se define una primera base de datos, a continuación, añadir una nueva tabla y utilizar el motor de almacenamiento cuadro desplegable para que la nueva tabla InnoDB.

Image

Buena suerte.

:)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: InnoDB not work

Postby juanbejar » 22. June 2010 02:47

Thanks JonB. I enclose a screenshot of the flap motors. I want to clarify that if I know that the storage engine is chosen at table.

Image
juanbejar
 
Posts: 6
Joined: 19. June 2010 23:10

Re: InnoDB not work

Postby JonB » 22. June 2010 04:15

The configuration page for Engines(Motores) says that InnoDB is not running.

In my earlier post, I suggested to you to replace your edited my.ini with the one that came with XAMPP.

I can tell you did not do that by using the WinMerge program to compare the original XAMPP file with yours. It's clear you adapted one from a different system. Please look at line 8.

I can't help you with a mix and match my.ini

A question - you DO know what the skip-innodb directive does? It means 'disable the innoDB engine' so it SHOULD be commented out - meaning you want inno-db to work.

Right - #skip-innodb
Wrong - skip-innodb

You must restart the MySQL service each time you make any changes to my.ini.

You should begin with XAMPP original my.ini and THEN make changes, one at a time.
---------------------------------
La página de configuración para los motores dice que InnoDB no se está ejecutando.

En mi post anterior, he sugerido a usted para reemplazar su my.ini editado con el que vino con XAMPP.

Puedo decir que no hiciste que por usar el programa WinMerge para comparar el archivo original de XAMPP con la suya. Está claro que una adaptación de un sistema diferente. Por favor, mire la línea 8.

No te puedo ayudar con una mezcla y combinación my.ini

Una pregunta - ¿Sabes lo que la directiva skip-innodb hace? Significa 'desactivar el motor InnoDB así que debe ser comentada - lo que significa que quieren inno-db a trabajar.

Derecho - # skip-innodb
Incorrecto - skip-innodb

Debe reiniciar el servicio MySQL cada vez que realice algún cambio en my.ini.

Usted debe comenzar con my.ini XAMPP original y luego hacer cambios, uno a la vez.

Buena suerte
:)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 31 guests