Problem with usernames and passwords

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problem with usernames and passwords

Postby MarkHoward » 16. June 2010 03:08

I've started a new thread because the nature of my problem has changed. Hope that is OK.
I've done a complete re-install of XAMPP
Using XAMPP control panel I started Apache and MySql
The Apache Admin button showed the Welcome page. Status showed MySql and PHP etc were activated
No usernames or passwords have been set.
MySql Admin gets me straight into the MySql home page - I can see the start-up databases.
I then go back to the Welcome screen Security and set the root password with Cookie checked and Save it in the txt file.
It tells me "Successful change"
Control Panel > MySql > Admin still gives me access but now requires login through root and the password I set.
In the Privileges tab I create a new user markh and specify a password with All privileges.
I also create 1 new database.
That is all.
NOW when I go Control Panel > MySql > Admin it asks me to login but will not accept a login by either root or markh, saying "Cannot log in to the MySQL server".
The relvant part of config.inc.php reads as follows:
$cfg['Servers'][$i]['auth_type'] = 'cookie'; // Authentication method (config, http or cookie based)
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['AllowNoPasswordRoot'] = true;

I'm at my wit's end and would really appreciate some help, please.

Thanks
MarkHoward
 
Posts: 14
Joined: 27. May 2009 04:56

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 69 guests