Installing CURL

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Installing CURL

Postby cornernote » 25. January 2004 14:58

Hello,

Has anyone installed CURL with XAMPP for windows? I would appriciate any tips of advice on installing it.


Best regards,
Brett
cornernote
 
Posts: 6
Joined: 19. January 2004 11:35

Postby cornernote » 25. January 2004 15:03

Just found this post:
http://community.apachefriends.org/f/viewtopic.php?t=16

I did what it said with no luck. curl_init() still comes back as undefined function. I cannot read any of the comments as they are not in english.
cornernote
 
Posts: 6
Joined: 19. January 2004 11:35

Postby cornernote » 22. February 2004 05:06

Hello,

After hours and hours of looking around I figured it out! YAY!

I was editing:
C:\xampp\php\php.ini

Then I looked at my phpinfo to see where the php.ini was loading from. Turns out it is here:
C:\xampp\apache\bin\php.ini

I feel so stupid but I will post incase someone else makes the same mistake.


Best regards,
Brett
cornernote
 
Posts: 6
Joined: 19. January 2004 11:35

i did for a while

Postby MAGnUm » 26. February 2004 00:37

but when i change things and nothing changed i looked around. thx for finally posting it though. (EDIT: what the heck was i on? i made no sense as)
Last edited by MAGnUm on 17. March 2004 21:13, edited 1 time in total.
~~:M A G n U m:~~
(Disclaimer: if any of this info is confusing or vague tough, its free!!)
User avatar
MAGnUm
 
Posts: 151
Joined: 16. October 2003 18:08
Location: USA

Postby TheStormer » 17. March 2004 11:33

mhhh ... any solutions? irgendwelche Lösungen?

I'd the same problem, still: Call to undefined function: curl_init()

- edit php.ini
- copy the dll's to system32

Thanks for supporting!

Greets
TheStormer
TheStormer
 
Posts: 2
Joined: 17. March 2004 11:28

Postby Kristian Marcroft » 17. March 2004 11:37

Hi,

I have it running here...
You problably got the wrong php.ini.
You need the one in /xampp/apache/bin

Works fine here, without installing anything extra.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby TheStormer » 17. March 2004 11:45

Hit ... yes, after editing the third php.ini ;-) it works lovely.

Thanks-a-lot for the very quick answer!

Greets
TheStormer
TheStormer
 
Posts: 2
Joined: 17. March 2004 11:28

Postby arya009 » 11. December 2006 11:38

cornernote wrote:Hello,

After hours and hours of looking around I figured it out! YAY!

I was editing:
C:\xampp\php\php.ini

Then I looked at my phpinfo to see where the php.ini was loading from. Turns out it is here:
C:\xampp\apache\bin\php.ini

I feel so stupid but I will post incase someone else makes the same mistake.


Best regards,
Brett


Thanks...that works....apparantly i was also editing C:\xampp\php\php.ini but i was not checking with phpinfo :D
arya009
 
Posts: 1
Joined: 11. December 2006 10:45

Postby harryatworld » 31. December 2006 16:59

thanks für die hilfreichen antworten, weil ohne diese hätte ich nicht weiter gewusst. Da die Anleitung bei cUrl mir nicht besonders weiter geholfen hatte.
harryatworld
 
Posts: 1
Joined: 25. December 2004 20:50
Location: Naumburg/Saale

Do I edit JUST the php.ini under C:\xampp\apache\bin\php.ini

Postby lostndazed » 20. March 2007 20:05

Or all php.ini files?
lostndazed
 
Posts: 37
Joined: 20. March 2007 19:26

Postby mscand » 15. July 2007 13:02

cornernote

Your method for fixing cURL (i.e. editing the file in the apache/bin folder) worked for me too.

Thank you very much.
mscand
 
Posts: 1
Joined: 24. June 2007 16:29

curl_init()

Postby shrg18 » 28. December 2007 22:05

I got this error message:

Fatal error: Call to undefined function curl_init() in C:\xampp\htdocs\webbots\LIB_http.php on line 249

I have enabled curl in xampp\php\php.ini (extension=php_curl.dll at line 582). it works fine at command line, but not in localhost.

check the list, xampp\php\php -m , curl is among the list.

look at xampp\apache\bin\php.ini , there is none curl in the file and all extensions are uncommented. Is it the right file? where should I look and what should I do?
shrg18
 
Posts: 43
Joined: 16. August 2007 13:59
Location: windsor, on, canada
Operating System: windows 8

Postby sari42 » 29. December 2007 00:03

...look at xampp\apache\bin\php.ini , there is none curl in the file and all extensions are uncommented. Is it the right file?
it is the right place (didn't you read this thread?)

;extension=php_curl.dll
just change it to
extension=php_curl.dll
(or add that line if it's missing) and restart apache.

____
p.s.
it's always clever to ask phpinfo(); for the location of the used php.ini
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby shrg18 » 29. December 2007 04:44

sari42 wrote:
...look at xampp\apache\bin\php.ini , there is none curl in the file and all extensions are uncommented. Is it the right file?
it is the right place (didn't you read this thread?)

;extension=php_curl.dll
just change it to
extension=php_curl.dll
(or add that line if it's missing) and restart apache.

____
p.s.
it's always clever to ask phpinfo(); for the location of the used php.ini


thank you. it is fixed.

I copied extension=php_curl.dll to xampp\apache\bin\php.ini and restart the windows. it works.

thanks
shrg18
 
Posts: 43
Joined: 16. August 2007 13:59
Location: windsor, on, canada
Operating System: windows 8


Return to XAMPP for Windows

Who is online

Users browsing this forum: speller and 70 guests