perl module failing

Problems with the Windows version of XAMPP, questions, comments, and anything related.

perl module failing

Postby ebohatch » 14. June 2010 21:50

I have a perl module which maintains a simple visitors count. If I move it up to my web host (running Unix/linux) it works fine.
I used to have an Apache server (on XP) that I use to set up manually with php, perl and Mysql it worked also.
I have recently got back to doing some web work and used the latest Xampp to install and setup Apache, I am running Win 7 Ultimate.
I have the shebang line set to #!/usr/bin/perl and when I run the index.shtml page I get the following [an error occurred while processing this directive]. I have changed the line to #!"C:\xampp\perl\bin\perl.exe" and it still fails (even used forward slashes).
Even put the "c:\xampp\perl\bin\" into the PATH environment.

Posts: 11
Joined: 09. February 2010 18:52

Re: perl module failing

Postby JonB » 14. June 2010 22:20

[an error occurred while processing this directive]

That's an Apache SSI error, not a Perl Error - note the word 'directive'.

also hints here:

When you installed, did you enable mod_perl? If so, try disabling it with the Setup option in the XAMPP Control Panel. Not all Perl code is mod_perl compatible. BTW - mod_perl is virtualized Perl that runs inside httpd.exe by way of a DLL.

But, If mod_perl was not enabled (I still don't think this is a Perl error directly)

Perl error debugging - lemme remember the syntax on this :roll:

right below your shebang, add this to your Perl script:

use CGI::Carp qw(fatalsToBrowser);

"Then upload the script again, set it to executable and point your browser at it. If all goes according to plan, the error message will now be printed to the browser for all to see. Fix the error it details, and then comment out (or remove) that line because its never a good idea to give server settings out."

from the YaBB codex... (where YT is a support team member)

Good Luck
User avatar
AF Moderator
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: perl module failing

Postby ebohatch » 15. June 2010 18:03

finally go it to work by changing the shebang line from


this now works on my local test environment and when I move the perl module up to my webhost (without any changes) it still works.

I removed the perl path from the PATH environment variable.
Posts: 11
Joined: 09. February 2010 18:52

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 80 guests