apache crashing with status 3221225477 error

Problems with the Windows version of XAMPP, questions, comments, and anything related.

apache crashing with status 3221225477 error

Postby kj37 » 01. June 2010 12:57

I am using XAMPP 1.7.3 to run Symfony (1.4.4)

It was working fine until now when it starts crashing with

Code: Select all
[Tue Jun 01 13:27:44 2010] [notice] Parent: child process exited with status 3221225477 -- Restarting.


It seems the corresponding mysql call before crashing is

Code: Select all
"2010-06-01 13:27:20","st[st] @ localhost [127.0.0.1]",5,1,"Query","SET NAMES 'UTF8'"
"2010-06-01 13:27:20","st[st] @ localhost [127.0.0.1]",5,1,"Query","START TRANSACTION"


I think the transaction call (which I dont think was being used until now) is from a PDO call by the underlying ORM (Doctrine)

I have read in other posts which seem to point to this error being caused by PDO calls, though Im unsure on how to go fixing it.

There is a copy of libmysql.dll in
windows\system32
apache\bin
mysql\bin
mysql\lib\opt
perl\bin
perl\site\lib\auto\DBD\mysql
php\
(for some reason the version in mysql\lib\opt is smaller than the other ones which seem to be identical copies)

I only have 1 php.ini as far as I can tell.

any ideas on what to fix to get this stop crashing??

thanks
kj37
 
Posts: 1
Joined: 01. June 2010 12:34

Re: apache crashing with status 3221225477 error

Postby trebly » 08. June 2010 01:50

hello,

I have such a case with pdo and tikiwiki (beta 5.0RC2).
Not solved.
But be careful libmysql.dll have several versions and has been changed with php 5.2-5.3 from 5.1 sometimes some products have still the not right version. This can generate a crash depending of the opened first dll.
Has I need to use for debug several versions, I have developed (in my context) a batch script based on this principle :
the versions of *.dll are copied in the right dirs and if several possible they are named *.dll.ver, so in each dir you have the various available versions and a current one. The batch, depending of the apache-php-mysql version to execute :
    *- deletes and copies the right current version of the used *.dll in their right places
    *- launches the right APACHE-PHP-MYSQL
So if you look at each dir you will know (if available in the dir (like system32 with windows)) which current version is set and can be run, either you run the batch (set_ver_xxx.cmd)

So make a bit-to-bit comparison of the dll(s);

Good luck, I am keeping aware of you finding a right solution.
If I find something good I will answer here.

trebly
trebly
 
Posts: 1
Joined: 08. June 2010 01:15


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 58 guests