My router blocks outside acces to xmapp?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

My router blocks outside acces to xmapp?

Postby Dkc » 31. May 2010 18:47

Okay, few months ago I got my new router "DLINK DSL-2640R" . Now I can access to my localhost using: http://localhost/ but there's problem when I write my IP in browser like this http://121.122. ... . When I do that it loads modem page (same happens if I write modem IP, etc. 192.168.0.1 ), it loads modem settings not my localhost, or anything hosted on my xampp.

How to fix this? I'm not very familiar with port forwading etc. so I really don't know what to do here. It was fine with my old router ... :cry:

EDIT: Oh yea I forgot to mention same happens if I host my ventrilo server or anything similar. People should be able to join using my IP but they can't :?

Sorry for my bad English...
Dkc
 
Posts: 4
Joined: 31. May 2010 18:40

Re: My router blocks outside acces to xmapp?

Postby JonB » 31. May 2010 18:51

you need to read in your router manual how to set up a DMZ or virtual server.
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: My router blocks outside acces to xmapp?

Postby Dkc » 31. May 2010 19:48

JonB wrote:you need to read in your router manual how to set up a DMZ or virtual server.


Okay I found DMZ option in modem settings, could you help me and tell what should I put in "DMZ IP Address :" option?

My IP or?
Dkc
 
Posts: 4
Joined: 31. May 2010 18:40

Re: My router blocks outside acces to xmapp?

Postby Mario Lanz » 31. May 2010 19:55

yes, you have to set up port forwarding

Question :
How do I open up ports to my computer (port forwarding) on this router?

Answer :
Step 1 Type in the default IP address of therouter in your browser (default IP is 192.168.1.1)

Step 2 Log in using the default username andpassword (username: admin, password: admin)

Step 3 Click on Advanced atthe top of the screen and then click on the PortForwarding option on the left.

Step 4 Under the 'Port Forwarding Rules'configuration, do the following:

a. Type in the name of the application/Service under the 'Name'field. i.e. WEBSERVER

b. Enter the TCP and/or UDP port in the TCP and UDP fields. i.e.TCP = 80 for a web server. For a range of ports, type in hyphen toseparate the Start and End of the port range (i.e. 2000-2009).

c. Select one of the Computer names under the 'ComputerName' drop down list. Click on the'<<' button. This will then add the IPAddress of the computer under the 'IP address' field. If themachine is not in the list, type in the IP Address manually in theIP Address field.

d. Click on the Add/Apply button to add the newPort Forwarding entry into the 'Active Port Forwarding Rules'list.

Step 5 Click on the Rebootbutton on the left to reboot the router with the new settings.






or use this link:
ftp://ftp.dlink.co.uk/dsl_routers_modems/dsl-2640b/DSL-2640B_Manual_v1.pdf
User avatar
Mario Lanz
 
Posts: 104
Joined: 13. October 2004 22:47
Location: CH, Volketswil


Re: My router blocks outside acces to xmapp?

Postby Mario Lanz » 31. May 2010 20:34

oh...

found this:
Question :
Why can I not access my webserver using the WAN IP address?

Answer :
Your router has no support for NAT Loopback, and can thereforenot view a server by its WAN IP, from the LAN.



To view your servers from a LAN computer, use the LAN IPaddress of the server.

To view your servers from the internet, use the WAN IPaddress.



For a list of devices supporting NAT Loopback, click here


I do not know, without portforwarding - how this should work - why have you bought this D-Link firewall?

What was the cause to replace the old one...

I think you have to return it and buy one, with NAT


I can suggest a zyxell 2 or USG 200 I do not know your budget

cheers

Mario
User avatar
Mario Lanz
 
Posts: 104
Joined: 13. October 2004 22:47
Location: CH, Volketswil

Re: My router blocks outside acces to xmapp?

Postby JonB » 31. May 2010 20:45

I'm not sure the lack of NAT loopback is such a big problem

For the DMZ IP just give the Local IP of your XAMPP box. You should be using a fixed IP address for your XAMPP box, not DHCP.

If you have a domain name, then point it to the Routers fixed IP, if you have thing set up right others should be able to see you.

You can always, after all, get to your server on your LAN through its local address.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: My router blocks outside acces to xmapp?

Postby Dkc » 01. June 2010 07:34

Mario Lanz wrote:oh...

found this:
Question :
Why can I not access my webserver using the WAN IP address?

Answer :
Your router has no support for NAT Loopback, and can thereforenot view a server by its WAN IP, from the LAN.



To view your servers from a LAN computer, use the LAN IPaddress of the server.

To view your servers from the internet, use the WAN IPaddress.



For a list of devices supporting NAT Loopback, click here


I do not know, without portforwarding - how this should work - why have you bought this D-Link firewall?

What was the cause to replace the old one...

I think you have to return it and buy one, with NAT


I can suggest a zyxell 2 or USG 200 I do not know your budget

cheers

Mario


My ISP gave me this when my old one died. This isn't so important to me so nvm if it can't be done.
Dkc
 
Posts: 4
Joined: 31. May 2010 18:40


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 75 guests