httpd.exe Error

Problems with the Windows version of XAMPP, questions, comments, and anything related.

httpd.exe Error

Postby TonyBunney » 24. May 2010 09:34

I keep receiving this error when I am debugging.
szAppName : httpd.exe szAppVer : 2.2.14.0
szModName : php_xdebug-2.1.0RC1-5.3-vc6.dll szModVer : 2.1.0.4
offset : 00012c1f

Can anyone help.

Thanks
TonyBunney
 
Posts: 3
Joined: 24. May 2010 08:47

Re: httpd.exe Error

Postby BBellar » 01. July 2010 13:28

I have the same problem,
Faulting application httpd.exe, version 2.2.14.0, faulting module php_xdebug-2.1.0rc1-5.3-vc6.dll, version 2.1.0.4, fault address 0x00012c1f.
Have you an update?
Thanks.
BBellar
 
Posts: 1
Joined: 01. July 2010 13:19

Re: httpd.exe Error

Postby JonB » 01. July 2010 20:49

OK -

Uhhh - folks its NOT httpd.exe that is the problem, its xdebug...

it looks like you are both on release candidate one -

read here:
http://xdebug.org/updates.php

:roll:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: httpd.exe Error

Postby TonyBunney » 02. July 2010 08:42

Thanks JonB.
I have had a quick look at the http://xdebug.org/download.php and you are correct there is a newer version Xdebug 2.1.0 Release date: 2010-06-29.
But there are many versions to choose from.
Which one do you recommend.

Thanks Again
Tony
TonyBunney
 
Posts: 3
Joined: 24. May 2010 08:47

Re: httpd.exe Error

Postby JonB » 02. July 2010 11:16

You need one of the VC6 versions - as the PHP and Apache that come with XAMPP were compiled with the MS VC6 compiler.

Past that advice, they have provided a tool to analyze the output of phpinfo.php to guide you on selecting the correct version (which depends on how PHP is set up).

http://xdebug.org/find-binary.php

I tested it for 'my setup', and got very clear intructions including how to fix php.ini and where to place the new binary -- VERY clever! LOL

:mrgreen:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: httpd.exe Error

Postby TonyBunney » 02. July 2010 11:56

Thanks for that JonB.
TonyBunney
 
Posts: 3
Joined: 24. May 2010 08:47

Re: httpd.exe Error

Postby avibodha » 11. January 2011 19:16

Having same problem, xampp 1.73 with newest xdebug, php_xdebug-2.1.0-5.3-vc6.dll, and apache crashes when viewing variables in eclipse.

Using xdebug that comes with xampp means you can't see local variables.

Has anyone solved this? Any ideas? does thread-safe debugging work with php 5.3 and xdebug?
avibodha
 
Posts: 3
Joined: 30. August 2006 22:31


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 56 guests